summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb3
-rw-r--r--meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb3
-rw-r--r--meta-skeleton/recipes-skeleton/service/service_0.1.bb11
-rw-r--r--meta-skeleton/recipes-skeleton/useradd/useradd-example.bb3
4 files changed, 12 insertions, 8 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
index a2fb212a68..79f2e8a092 100644
--- a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -10,7 +10,8 @@ SRC_URI = "file://Makefile \
file://COPYING \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
diff --git a/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb b/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
index 90d3aefd86..8be7980919 100644
--- a/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
+++ b/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "file://helloworld.c"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_compile() {
${CC} ${LDFLAGS} helloworld.c -o helloworld
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index 912f6b0f61..54b834d45f 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -2,22 +2,23 @@ SUMMARY = "The canonical example of init scripts"
SECTION = "base"
DESCRIPTION = "This recipe is a canonical example of init scripts"
LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
SRC_URI = "file://skeleton \
file://skeleton_test.c \
file://COPYRIGHT \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_compile () {
- ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
+ ${CC} ${CFLAGS} ${LDFLAGS} ${S}/skeleton_test.c -o ${B}/skeleton-test
}
do_install () {
install -d ${D}${sysconfdir}/init.d
- cat ${WORKDIR}/skeleton | \
+ cat ${S}/skeleton | \
sed -e 's,/etc,${sysconfdir},g' \
-e 's,/usr/sbin,${sbindir},g' \
-e 's,/var,${localstatedir},g' \
@@ -26,7 +27,7 @@ do_install () {
chmod a+x ${D}${sysconfdir}/init.d/skeleton
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
+ install -m 0755 ${S}/skeleton-test ${D}${sbindir}/
}
RDEPENDS:${PN} = "initscripts"
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
index 8437a5a774..b0d96e7f71 100644
--- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
+++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
@@ -9,7 +9,8 @@ SRC_URI = "file://file1 \
file://file3 \
file://file4"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
PACKAGES =+ "${PN}-user3"