summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/acinclude.m486
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/mkdir.patch26
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/quotefix.patch43
3 files changed, 155 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/acinclude.m4 b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/acinclude.m4
new file mode 100644
index 0000000000..4b00668476
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/acinclude.m4
@@ -0,0 +1,86 @@
+# Extracted from the package's shipped aclocal.m4. Custom macros should be in
+# acinclude.m4 so running aclocal doesn't blow them away.
+#
+# RP 1/6/2010
+
+# ===========================================================================
+# http://www.nongnu.org/autoconf-archive/check_gnu_make.html
+# ===========================================================================
+#
+# SYNOPSIS
+#
+# CHECK_GNU_MAKE()
+#
+# DESCRIPTION
+#
+# This macro searches for a GNU version of make. If a match is found, the
+# makefile variable `ifGNUmake' is set to the empty string, otherwise it
+# is set to "#". This is useful for including a special features in a
+# Makefile, which cannot be handled by other versions of make. The
+# variable _cv_gnu_make_command is set to the command to invoke GNU make
+# if it exists, the empty string otherwise.
+#
+# Here is an example of its use:
+#
+# Makefile.in might contain:
+#
+# # A failsafe way of putting a dependency rule into a makefile
+# $(DEPEND):
+# $(CC) -MM $(srcdir)/*.c > $(DEPEND)
+#
+# @ifGNUmake@ ifeq ($(DEPEND),$(wildcard $(DEPEND)))
+# @ifGNUmake@ include $(DEPEND)
+# @ifGNUmake@ endif
+#
+# Then configure.in would normally contain:
+#
+# CHECK_GNU_MAKE()
+# AC_OUTPUT(Makefile)
+#
+# Then perhaps to cause gnu make to override any other make, we could do
+# something like this (note that GNU make always looks for GNUmakefile
+# first):
+#
+# if ! test x$_cv_gnu_make_command = x ; then
+# mv Makefile GNUmakefile
+# echo .DEFAULT: > Makefile ;
+# echo \ $_cv_gnu_make_command \$@ >> Makefile;
+# fi
+#
+# Then, if any (well almost any) other make is called, and GNU make also
+# exists, then the other make wraps the GNU make.
+#
+# LICENSE
+#
+# Copyright (c) 2008 John Darrington <j.darrington@elvis.murdoch.edu.au>
+#
+# Copying and distribution of this file, with or without modification, are
+# permitted in any medium without royalty provided the copyright notice
+# and this notice are preserved.
+#
+# Note: Modified by Ted Ts'o to add @ifNotGNUMake@
+
+AC_DEFUN(
+ [CHECK_GNU_MAKE], [ AC_CACHE_CHECK( for GNU make,_cv_gnu_make_command,
+ _cv_gnu_make_command='' ;
+dnl Search all the common names for GNU make
+ for a in "$MAKE" make gmake gnumake ; do
+ if test -z "$a" ; then continue ; fi ;
+ if ( sh -c "$a --version" 2> /dev/null | grep GNU 2>&1 > /dev/null ) ; then
+ _cv_gnu_make_command=$a ;
+ break;
+ fi
+ done ;
+ ) ;
+dnl If there was a GNU version, then set @ifGNUmake@ to the empty string, '#' otherwise
+ if test "x$_cv_gnu_make_command" != "x" ; then
+ ifGNUmake='' ;
+ ifNotGNUmake='#' ;
+ else
+ ifGNUmake='#' ;
+ ifNotGNUmake='' ;
+ AC_MSG_RESULT("Not found");
+ fi
+ AC_SUBST(ifGNUmake)
+ AC_SUBST(ifNotGNUmake)
+] )
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/mkdir.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/mkdir.patch
new file mode 100644
index 0000000000..b0577e3bcb
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/mkdir.patch
@@ -0,0 +1,26 @@
+Index: e2fsprogs-1.41.5/po/Makefile.in.in
+===================================================================
+--- e2fsprogs-1.41.5.orig/po/Makefile.in.in 2009-02-14 13:49:08.000000000 +0000
++++ e2fsprogs-1.41.5/po/Makefile.in.in 2009-08-19 17:52:31.000000000 +0100
+@@ -30,7 +30,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
++mkinstalldirs = $(MKINSTALLDIRS)
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
+Index: e2fsprogs-1.41.5/configure.in
+===================================================================
+--- e2fsprogs-1.41.5.orig/configure.in 2009-08-19 17:53:50.000000000 +0100
++++ e2fsprogs-1.41.5/configure.in 2009-08-19 17:48:38.000000000 +0100
+@@ -970,6 +970,8 @@
+ fi
+ AC_SUBST(BUILD_CFLAGS)
+ AC_SUBST(BUILD_LDFLAGS)
++MKINSTALLDIRS="mkdir -p"
++AC_SUBST(MKINSTALLDIRS)
+ dnl
+ dnl Make our output files, being sure that we create the some miscellaneous
+ dnl directories
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/quotefix.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/quotefix.patch
new file mode 100644
index 0000000000..528e319d84
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.41.12/quotefix.patch
@@ -0,0 +1,43 @@
+These macros are underquoted and break with recent autoconf+automake
+combinations.
+
+RP 1/2/10
+
+Index: e2fsprogs-1.41.5/configure.in
+===================================================================
+--- e2fsprogs-1.41.5.orig/configure.in 2010-02-01 11:40:10.547790252 +0000
++++ e2fsprogs-1.41.5/configure.in 2010-02-01 11:44:51.577876485 +0000
+@@ -397,11 +397,11 @@
+ AC_MSG_ERROR([pkg-config not installed; please install it.])
+ fi
+
+- AC_CHECK_LIB(blkid, blkid_get_cache,
++ [AC_CHECK_LIB(blkid, blkid_get_cache,
+ [LIBBLKID=`$PKG_CONFIG --libs blkid`;
+ STATIC_LIBBLKID=`$PKG_CONFIG --static --libs blkid`],
+ [AC_MSG_ERROR([external blkid library not found])],
+- [$LIBBLKID])
++ [$LIBBLKID])]
+ BLKID_CMT=#
+ AC_MSG_RESULT([Disabling private blkid library])
+ else
+@@ -786,15 +786,15 @@
+ dnl
+ SEM_INIT_LIB=''
+ AC_CHECK_FUNC(sem_init, ,
+- AC_CHECK_LIB(pthread, sem_init,
++ [AC_CHECK_LIB(pthread, sem_init,
+ AC_DEFINE(HAVE_SEM_INIT)
+ SEM_INIT_LIB=-lpthread,
+- AC_CHECK_LIB(rt, sem_init,
++ [AC_CHECK_LIB(rt, sem_init,
+ AC_DEFINE(HAVE_SEM_INIT)
+ SEM_INIT_LIB=-lrt,
+- AC_CHECK_LIB(posix4, sem_init,
++ [AC_CHECK_LIB(posix4, sem_init,
+ AC_DEFINE(HAVE_SEM_INIT)
+- SEM_INIT_LIB=-lposix4))))dnl
++ SEM_INIT_LIB=-lposix4)])])])dnl
+ AC_SUBST(SEM_INIT_LIB)
+ dnl
+ dnl Check for unified diff