summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file/fix_version_check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/file/file/fix_version_check.patch')
-rw-r--r--meta/recipes-devtools/file/file/fix_version_check.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file/fix_version_check.patch b/meta/recipes-devtools/file/file/fix_version_check.patch
new file mode 100644
index 0000000000..bd24ccb49f
--- /dev/null
+++ b/meta/recipes-devtools/file/file/fix_version_check.patch
@@ -0,0 +1,21 @@
+Since we are cross-compiling and need to have a cover script this
+version check sees "file.real-5.09" not "file-5.09", so fix the
+sed.
+
+Upstream-Status: Inapproriate [build-specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: file-5.09/magic/Makefile.am
+===================================================================
+--- file-5.09.orig/magic/Makefile.am
++++ file-5.09/magic/Makefile.am
+@@ -260,7 +260,7 @@ ${MAGIC}: $(EXTRA_DIST) $(FILE_COMPILE_D
+ @(if expr "${FILE_COMPILE}" : '.*/.*' > /dev/null; then \
+ echo "Using ${FILE_COMPILE} to generate ${MAGIC}" > /dev/null; \
+ else \
+- v=$$(file --version | sed -e s/file-// -e q); \
++ v=$$(file --version | sed -e s/file.real-// -e q); \
+ if [ "$$v" != "${PACKAGE_VERSION}" ]; then \
+ echo "Cannot use the installed version of file ($$v) to"; \
+ echo "cross-compile file ${PACKAGE_VERSION}"; \