summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.11.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.11.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.bb b/meta/recipes-devtools/gdb/gdb_7.11.bb
index ccc33b8656..f02e6431dd 100644
--- a/meta/recipes-devtools/gdb/gdb_7.11.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.11.bb
@@ -1,15 +1,15 @@
require gdb.inc
require gdb-${PV}.inc
-inherit python-dir
+inherit python3-dir
do_configure_prepend() {
if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
cat > ${WORKDIR}/python << EOF
#!/bin/sh
case "\$2" in
- --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
- --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
+ --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
+ --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
--exec-prefix) echo "${exec_prefix}" ;;
*) exit 1 ;;
esac