summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/git
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/git')
-rw-r--r--meta/recipes-devtools/git/files/autotools.patch14
-rw-r--r--meta/recipes-devtools/git/git.inc22
-rw-r--r--meta/recipes-devtools/git/git_1.7.2.1.bb3
3 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/git/files/autotools.patch b/meta/recipes-devtools/git/files/autotools.patch
new file mode 100644
index 0000000000..1c69c22817
--- /dev/null
+++ b/meta/recipes-devtools/git/files/autotools.patch
@@ -0,0 +1,14 @@
+Index: git-1.7.2.1/configure.ac
+===================================================================
+--- git-1.7.2.1.orig/configure.ac 2010-07-28 18:03:43.000000000 +0100
++++ git-1.7.2.1/configure.ac 2010-08-13 14:54:29.181971250 +0100
+@@ -697,7 +697,8 @@
+ else if (strcmp(buf, "12345"))
+ return 2;]])],
+ [ac_cv_c_c99_format=yes],
+- [ac_cv_c_c99_format=no])
++ [ac_cv_c_c99_format=no],
++ [ac_cv_c_c99_format=yes])
+ ])
+ if test $ac_cv_c_c99_format = no; then
+ NO_C99_FORMAT=YesPlease
diff --git a/meta/recipes-devtools/git/git.inc b/meta/recipes-devtools/git/git.inc
new file mode 100644
index 0000000000..5d72df59d1
--- /dev/null
+++ b/meta/recipes-devtools/git/git.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "perl-native openssl curl zlib expat"
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1"
+S = "${WORKDIR}/git-${PV}"
+
+EXTRA_OECONF = "--with-perl=${STAGING_BINDIR_NATIVE}/perl --without-tcltk"
+
+inherit autotools
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+
+FILES_${PN} += "${datadir}/git-core"
+
+BBCLASSEXTEND = "native"
diff --git a/meta/recipes-devtools/git/git_1.7.2.1.bb b/meta/recipes-devtools/git/git_1.7.2.1.bb
new file mode 100644
index 0000000000..7f822f69b3
--- /dev/null
+++ b/meta/recipes-devtools/git/git_1.7.2.1.bb
@@ -0,0 +1,3 @@
+require git.inc
+
+PR = "r2"