summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go_1.12.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.12.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.12.bb b/meta/recipes-devtools/go/go_1.12.bb
new file mode 100644
index 0000000000..42cdb0430a
--- /dev/null
+++ b/meta/recipes-devtools/go/go_1.12.bb
@@ -0,0 +1,14 @@
+require go-${PV}.inc
+require go-target.inc
+
+export GOBUILDMODE=""
+
+# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
+# doesn't support -buildmode=pie, so skip the QA checking for mips and its
+# variants.
+python() {
+ if 'mips' in d.getVar('TARGET_ARCH'):
+ d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
+ else:
+ d.setVar('GOBUILDMODE', 'pie')
+}