summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust/rust_1.51.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rust/rust_1.51.0.bb')
-rw-r--r--meta/recipes-devtools/rust/rust_1.51.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.51.0.bb b/meta/recipes-devtools/rust/rust_1.51.0.bb
new file mode 100644
index 0000000000..05904453f7
--- /dev/null
+++ b/meta/recipes-devtools/rust/rust_1.51.0.bb
@@ -0,0 +1,16 @@
+require rust-target.inc
+require rust-source-${PV}.inc
+require rust-snapshot-${PV}.inc
+
+SRC_URI += " \
+ file://riscv-march.patch \
+ file://rv64gc.patch \
+ "
+
+do_compile () {
+ rust_runx build --stage 2
+}
+
+rust_do_install() {
+ rust_runx install
+}