summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_10.5.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_10.5.6.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_10.5.6.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_10.5.6.bb b/meta/recipes-graphics/mesa/mesa_10.5.6.bb
new file mode 100644
index 0000000000..70cc8aa22a
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_10.5.6.bb
@@ -0,0 +1,14 @@
+require ${BPN}.inc
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "7a845c50fc8aaae4c9373e795c1f491d"
+SRC_URI[sha256sum] = "66017853bde5f7a6647db3eede30512a091a3491daa1708e0ad8027c328ba595"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)/#if ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}