summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/tslib
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/tslib')
-rw-r--r--meta/recipes-graphics/tslib/tslib/a780/tslib.sh6
-rw-r--r--meta/recipes-graphics/tslib/tslib/collie/ts.conf5
-rw-r--r--meta/recipes-graphics/tslib/tslib/collie/tslib.sh13
-rw-r--r--meta/recipes-graphics/tslib/tslib/devfs.patch18
-rw-r--r--meta/recipes-graphics/tslib/tslib/e680/tslib.sh6
-rw-r--r--meta/recipes-graphics/tslib/tslib/event1.patch80
-rw-r--r--meta/recipes-graphics/tslib/tslib/jornada56x/ts.conf5
-rw-r--r--meta/recipes-graphics/tslib/tslib/jornada56x/tslib.sh5
-rw-r--r--meta/recipes-graphics/tslib/tslib/jornada6xx/ts.conf5
-rw-r--r--meta/recipes-graphics/tslib/tslib/jornada6xx/tslib.sh5
-rw-r--r--meta/recipes-graphics/tslib/tslib/jornada7xx/ts.conf5
-rw-r--r--meta/recipes-graphics/tslib/tslib/jornada7xx/tslib.sh5
-rw-r--r--meta/recipes-graphics/tslib/tslib/mnci/ts.conf5
-rw-r--r--meta/recipes-graphics/tslib/tslib/mnci/tslib.sh1
-rw-r--r--meta/recipes-graphics/tslib/tslib/netbook-pro/ts.conf5
-rw-r--r--meta/recipes-graphics/tslib/tslib/netbook-pro/tslib.sh5
-rw-r--r--meta/recipes-graphics/tslib/tslib/omap1610h2/tslib.sh5
-rw-r--r--meta/recipes-graphics/tslib/tslib/omap5912osk/tslib.sh4
-rw-r--r--meta/recipes-graphics/tslib/tslib/simpad/tslib.sh14
-rw-r--r--meta/recipes-graphics/tslib/tslib/ts.conf-collie-2.45
-rw-r--r--meta/recipes-graphics/tslib/tslib/ts.conf-simpad-2.45
-rw-r--r--meta/recipes-graphics/tslib/tslib_1.0.bb32
22 files changed, 1 insertions, 238 deletions
diff --git a/meta/recipes-graphics/tslib/tslib/a780/tslib.sh b/meta/recipes-graphics/tslib/tslib/a780/tslib.sh
deleted file mode 100644
index 51cd0f1f36..0000000000
--- a/meta/recipes-graphics/tslib/tslib/a780/tslib.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=/dev/input/event1
-TSLIB_CONFFILE=/etc/ts.conf
-
-export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/meta/recipes-graphics/tslib/tslib/collie/ts.conf b/meta/recipes-graphics/tslib/tslib/collie/ts.conf
deleted file mode 100644
index 2099b9b414..0000000000
--- a/meta/recipes-graphics/tslib/tslib/collie/ts.conf
+++ /dev/null
@@ -1,5 +0,0 @@
-module_raw collie
-module pthres pmin=1
-module variance delta=30
-module dejitter delta=100
-module linear
diff --git a/meta/recipes-graphics/tslib/tslib/collie/tslib.sh b/meta/recipes-graphics/tslib/tslib/collie/tslib.sh
deleted file mode 100644
index 664bda426a..0000000000
--- a/meta/recipes-graphics/tslib/tslib/collie/tslib.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=/dev/input/touchscreen0
-TSLIB_CONFFILE=/etc/ts.conf
-
-case `uname -r` in
-2.4*)
- TSLIB_TSDEVICE=/dev/ts
- TSLIB_CONFFILE=/usr/share/tslib/ts.conf-collie-2.4
- ;;
-esac
-
-export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/meta/recipes-graphics/tslib/tslib/devfs.patch b/meta/recipes-graphics/tslib/tslib/devfs.patch
deleted file mode 100644
index d7ef0a9589..0000000000
--- a/meta/recipes-graphics/tslib/tslib/devfs.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- tslib/tests/fbutils.c~devfs.patch
-+++ tslib/tests/fbutils.c
-@@ -44,8 +44,8 @@
- static unsigned colormap [256];
- int xres, yres;
-
--static char *defaultfbdevice = "/dev/fb0";
--static char *defaultconsoledevice = "/dev/tty";
-+static char *defaultfbdevice = "/dev/fb/0";
-+static char *defaultconsoledevice = "/dev/vc/";
- static char *fbdevice = NULL;
- static char *consoledevice = NULL;
-
diff --git a/meta/recipes-graphics/tslib/tslib/e680/tslib.sh b/meta/recipes-graphics/tslib/tslib/e680/tslib.sh
deleted file mode 100644
index 51cd0f1f36..0000000000
--- a/meta/recipes-graphics/tslib/tslib/e680/tslib.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=/dev/input/event1
-TSLIB_CONFFILE=/etc/ts.conf
-
-export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/meta/recipes-graphics/tslib/tslib/event1.patch b/meta/recipes-graphics/tslib/tslib/event1.patch
deleted file mode 100644
index 88cc3f3a2a..0000000000
--- a/meta/recipes-graphics/tslib/tslib/event1.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- tslib/tests/ts_calibrate.c~event1
-+++ tslib/tests/ts_calibrate.c
-@@ -179,11 +179,7 @@
- if( (tsdevice = getenv("TSLIB_TSDEVICE")) != NULL ) {
- ts = ts_open(tsdevice,0);
- } else {
--#ifdef USE_INPUT_API
-- ts = ts_open("/dev/input/event0", 0);
--#else
-- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
--#endif /* USE_INPUT_API */
-+ ts = ts_open("/dev/input/event1", 0);
- }
-
- if (!ts) {
---- tslib/tests/ts_print.c~event1
-+++ tslib/tests/ts_print.c
-@@ -28,11 +28,7 @@
- if( (tsdevice = getenv("TSLIB_TSDEVICE")) != NULL ) {
- ts = ts_open(tsdevice,0);
- } else {
--#ifdef USE_INPUT_API
-- ts = ts_open("/dev/input/event0", 0);
--#else
-- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
--#endif /* USE_INPUT_API */
-+ ts = ts_open("/dev/input/event1", 0);
- }
-
- if (!ts) {
---- tslib/tests/ts_test.c~event1
-+++ tslib/tests/ts_test.c
-@@ -120,11 +120,7 @@
- signal(SIGTERM, sig);
-
- if ((tsdevice = getenv("TSLIB_TSDEVICE")) == NULL) {
--#ifdef USE_INPUT_API
-- tsdevice = strdup ("/dev/input/event0");
--#else
-- tsdevice = strdup ("/dev/touchscreen/ucb1x00");
--#endif /* USE_INPUT_API */
-+ tsdevice = strdup ("/dev/input/event1");
- }
-
- ts = ts_open (tsdevice, 0);
---- tslib/tests/ts_print_raw.c~event1
-+++ tslib/tests/ts_print_raw.c
-@@ -28,11 +28,7 @@
- if( (tsdevice = getenv("TSLIB_TSDEVICE")) != NULL ) {
- ts = ts_open(tsdevice,0);
- } else {
--#ifdef USE_INPUT_API
-- ts = ts_open("/dev/input/event0", 0);
--#else
-- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
--#endif /* USE_INPUT_API */
-+ ts = ts_open("/dev/input/event1", 0);
- }
-
- if (!ts) {
---- tslib/tests/ts_harvest.c~event1
-+++ tslib/tests/ts_harvest.c
-@@ -75,11 +75,7 @@
- signal(SIGTERM, sig);
-
- if ((tsdevice = getenv("TSLIB_TSDEVICE")) == NULL) {
--#ifdef USE_INPUT_API
-- tsdevice = strdup ("/dev/input/event0");
--#else
-- tsdevice = strdup ("/dev/touchscreen/ucb1x00");
--#endif /* USE_INPUT_API */
-+ tsdevice = strdup ("/dev/input/event1");
- }
-
- ts = ts_open (tsdevice, 0);
diff --git a/meta/recipes-graphics/tslib/tslib/jornada56x/ts.conf b/meta/recipes-graphics/tslib/tslib/jornada56x/ts.conf
deleted file mode 100644
index 20729b6154..0000000000
--- a/meta/recipes-graphics/tslib/tslib/jornada56x/ts.conf
+++ /dev/null
@@ -1,5 +0,0 @@
-module_raw h3600
-module pthres pmin=1
-module variance delta=30
-module dejitter delta=100
-module linear
diff --git a/meta/recipes-graphics/tslib/tslib/jornada56x/tslib.sh b/meta/recipes-graphics/tslib/tslib/jornada56x/tslib.sh
deleted file mode 100644
index 8f907b0755..0000000000
--- a/meta/recipes-graphics/tslib/tslib/jornada56x/tslib.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=/dev/input/tsraw0
-
-export TSLIB_TSDEVICE
diff --git a/meta/recipes-graphics/tslib/tslib/jornada6xx/ts.conf b/meta/recipes-graphics/tslib/tslib/jornada6xx/ts.conf
deleted file mode 100644
index 20729b6154..0000000000
--- a/meta/recipes-graphics/tslib/tslib/jornada6xx/ts.conf
+++ /dev/null
@@ -1,5 +0,0 @@
-module_raw h3600
-module pthres pmin=1
-module variance delta=30
-module dejitter delta=100
-module linear
diff --git a/meta/recipes-graphics/tslib/tslib/jornada6xx/tslib.sh b/meta/recipes-graphics/tslib/tslib/jornada6xx/tslib.sh
deleted file mode 100644
index 1b5db781c1..0000000000
--- a/meta/recipes-graphics/tslib/tslib/jornada6xx/tslib.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=/dev/input/ts0
-
-export TSLIB_TSDEVICE
diff --git a/meta/recipes-graphics/tslib/tslib/jornada7xx/ts.conf b/meta/recipes-graphics/tslib/tslib/jornada7xx/ts.conf
deleted file mode 100644
index 09309719f2..0000000000
--- a/meta/recipes-graphics/tslib/tslib/jornada7xx/ts.conf
+++ /dev/null
@@ -1,5 +0,0 @@
-module_raw input
-module pthres pmin=1
-module variance delta=30
-module dejitter delta=100
-module linear
diff --git a/meta/recipes-graphics/tslib/tslib/jornada7xx/tslib.sh b/meta/recipes-graphics/tslib/tslib/jornada7xx/tslib.sh
deleted file mode 100644
index 040f4de3d5..0000000000
--- a/meta/recipes-graphics/tslib/tslib/jornada7xx/tslib.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=/dev/input/event1
-
-export TSLIB_TSDEVICE
diff --git a/meta/recipes-graphics/tslib/tslib/mnci/ts.conf b/meta/recipes-graphics/tslib/tslib/mnci/ts.conf
deleted file mode 100644
index adff17717b..0000000000
--- a/meta/recipes-graphics/tslib/tslib/mnci/ts.conf
+++ /dev/null
@@ -1,5 +0,0 @@
-module_raw input
-module pthres pmin=600
-module variance delta=30
-module dejitter delta=100
-module linear
diff --git a/meta/recipes-graphics/tslib/tslib/mnci/tslib.sh b/meta/recipes-graphics/tslib/tslib/mnci/tslib.sh
deleted file mode 100644
index 07928f226d..0000000000
--- a/meta/recipes-graphics/tslib/tslib/mnci/tslib.sh
+++ /dev/null
@@ -1 +0,0 @@
-export TSLIB_TSDEVICE=/dev/input/event1
diff --git a/meta/recipes-graphics/tslib/tslib/netbook-pro/ts.conf b/meta/recipes-graphics/tslib/tslib/netbook-pro/ts.conf
deleted file mode 100644
index 6d94a8f468..0000000000
--- a/meta/recipes-graphics/tslib/tslib/netbook-pro/ts.conf
+++ /dev/null
@@ -1,5 +0,0 @@
-module_raw input
-module variance delta=80
-#module dejitter delta=2
-module linear
-
diff --git a/meta/recipes-graphics/tslib/tslib/netbook-pro/tslib.sh b/meta/recipes-graphics/tslib/tslib/netbook-pro/tslib.sh
deleted file mode 100644
index d31bc76368..0000000000
--- a/meta/recipes-graphics/tslib/tslib/netbook-pro/tslib.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=`detect-stylus --device`
-
-export TSLIB_TSDEVICE
diff --git a/meta/recipes-graphics/tslib/tslib/omap1610h2/tslib.sh b/meta/recipes-graphics/tslib/tslib/omap1610h2/tslib.sh
deleted file mode 100644
index 040f4de3d5..0000000000
--- a/meta/recipes-graphics/tslib/tslib/omap1610h2/tslib.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=/dev/input/event1
-
-export TSLIB_TSDEVICE
diff --git a/meta/recipes-graphics/tslib/tslib/omap5912osk/tslib.sh b/meta/recipes-graphics/tslib/tslib/omap5912osk/tslib.sh
deleted file mode 100644
index 6bb56651f8..0000000000
--- a/meta/recipes-graphics/tslib/tslib/omap5912osk/tslib.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-export TSLIB_TSDEVICE=/dev/input/event1
-export QWS_MOUSE_PROTO=TPanel
diff --git a/meta/recipes-graphics/tslib/tslib/simpad/tslib.sh b/meta/recipes-graphics/tslib/tslib/simpad/tslib.sh
deleted file mode 100644
index 9c4eb1e0f9..0000000000
--- a/meta/recipes-graphics/tslib/tslib/simpad/tslib.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-TSLIB_TSDEVICE=/dev/input/touchscreen0
-TSLIB_CONFFILE=/etc/ts.conf
-
-case `uname -r` in
-2.4*)
- TSLIB_TSDEVICE=/dev/touchscreen/ucb1x00
- TSLIB_CONFFILE=/usr/share/tslib/ts.conf-simpad-2.4
- ;;
-esac
-
-export TSLIB_TSDEVICE TSLIB_CONFFILE
-
diff --git a/meta/recipes-graphics/tslib/tslib/ts.conf-collie-2.4 b/meta/recipes-graphics/tslib/tslib/ts.conf-collie-2.4
deleted file mode 100644
index 2099b9b414..0000000000
--- a/meta/recipes-graphics/tslib/tslib/ts.conf-collie-2.4
+++ /dev/null
@@ -1,5 +0,0 @@
-module_raw collie
-module pthres pmin=1
-module variance delta=30
-module dejitter delta=100
-module linear
diff --git a/meta/recipes-graphics/tslib/tslib/ts.conf-simpad-2.4 b/meta/recipes-graphics/tslib/tslib/ts.conf-simpad-2.4
deleted file mode 100644
index 035e794cb4..0000000000
--- a/meta/recipes-graphics/tslib/tslib/ts.conf-simpad-2.4
+++ /dev/null
@@ -1,5 +0,0 @@
-module_raw ucb1x00
-module pthres pmin=1
-module variance delta=10
-module dejitter delta=150
-module linear
diff --git a/meta/recipes-graphics/tslib/tslib_1.0.bb b/meta/recipes-graphics/tslib/tslib_1.0.bb
index 51529e3f13..9ab8259e47 100644
--- a/meta/recipes-graphics/tslib/tslib_1.0.bb
+++ b/meta/recipes-graphics/tslib/tslib_1.0.bb
@@ -10,19 +10,15 @@ SECTION = "base"
LICENSE = "LGPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a"
-PR = "r16"
+PR = "r17"
SRC_URI = "http://download.berlios.de/tslib/tslib-${PV}.tar.bz2 \
file://fix_version.patch;patch=1 \
file://ts.conf \
- file://ts.conf-simpad-2.4 \
- file://ts.conf-collie-2.4 \
file://tslib.sh"
SRC_URI[md5sum] = "92b2eb55b1e4ef7e2c0347069389390e"
SRC_URI[sha256sum] = "9c40d914e4f6fe00bdd77137d671c7ce4f211686228f2eb8b2d3c2360bc249c8"
-SRC_URI_append_mnci += " file://devfs.patch;patch=1"
-SRC_URI_append_mnci += " file://event1.patch;patch=1"
SRC_URI_append_qemumips += " file://32bitBE-support.patch;patch=1"
@@ -37,18 +33,6 @@ do_install_prepend() {
do_install_append() {
install -d ${D}${sysconfdir}/profile.d/
install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
- case ${MACHINE} in
- collie )
- install -d ${D}${datadir}/tslib
- install -m 0644 ${WORKDIR}/ts.conf-collie-2.4 ${D}${datadir}/tslib/
- ;;
- simpad )
- install -d ${D}${datadir}/tslib
- install -m 0644 ${WORKDIR}/ts.conf-simpad-2.4 ${D}${datadir}/tslib/
- ;;
- *)
- ;;
- esac
}
SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
@@ -58,20 +42,6 @@ SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
RPROVIDES_tslib-conf = "libts-0.0-conf"
-# Machines with machine specific patches
-PACKAGE_ARCH_mnci = "${MACHINE_ARCH}"
-# Machines with machine specific config files (tslib.sh)
-PACKAGE_ARCH_tslib-conf_a780 = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_collie = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_e680 = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_jornada56x = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_jornada6xx = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_jornada7xx = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_netbook-pro = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_omap1610h2 = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_omap5912osk = "${MACHINE_ARCH}"
-PACKAGE_ARCH_tslib-conf_simpad = "${MACHINE_ARCH}"
-
PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate"
DEBIAN_NOAUTONAME_tslib-conf = "1"
DEBIAN_NOAUTONAME_tslib-tests = "1"