summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme/gpgme_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.3.2.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.3.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.3.2.bb b/meta/recipes-support/gpgme/gpgme_1.3.2.bb
new file mode 100644
index 0000000000..b3c1d469e9
--- /dev/null
+++ b/meta/recipes-support/gpgme/gpgme_1.3.2.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
+HOMEPAGE = "http://www.gnupg.org/gpgme.html"
+BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
+
+LICENSE = "GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
+ file://src/gpgme.h.in;endline=23;md5=00846fee29ec2a6f5c808bfe7fc24e65 \
+ file://src/engine.h;endline=22;md5=e96acfaab1cff82dd8fbefddd2f5c436"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
+ file://disable_gpgconf_check.patch"
+
+SRC_URI[md5sum] = "326fe97077141713f0930aa87949a287"
+SRC_URI[sha256sum] = "cfd235663f1d1adc97abb38dd5e6d093bb7e155580f171f9ba0158feab69f875"
+DEPENDS = "libgpg-error libassuan ${PTH}"
+PTH_libc-uclibc = "npth"
+PTH = "pth"
+
+PR = "r0"
+
+EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
+ --with-gpg=${bindir}/gpg --without-gpgsm"
+
+inherit autotools binconfig
+
+PACKAGES =+ "${PN}-pth ${PN}-pthread"
+FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
+FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
+FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
+
+do_install_append() {
+ rmdir ${D}/usr/libexec
+}