aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dietze <mdietze@gmail.com>2014-03-02 11:45:51 +0100
committerMartin Dietze <mdietze@gmail.com>2014-03-02 11:45:51 +0100
commited5ecaa6c890231ca541ed2686c842c6804c0f96 (patch)
tree204f0616dd07dde1be63cb0bb5c4658ec6128d58
parent5ba44f359a9bf200f1912d7ab4e431002411159b (diff)
downloadopenembedded-mdietze/nylon.tar.gz
Use wpa-supplicant 0.4.8. This still does not fix issues connecting one of the cube's wifi cards to a hotspot with WPA2 encryption, but it sort of comes closest for now..mdietze/nylon
-rw-r--r--conf/distro/nylon.conf1
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant-0.4.7/driver-madwifi.patch25
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant-0.4.7/nylon/defconfig160
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant-0.4.8/driver-madwifi.patch25
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant-0.4.8/nylon/defconfig160
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant_0.4.7.bb8
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant_0.4.8.bb9
7 files changed, 388 insertions, 0 deletions
diff --git a/conf/distro/nylon.conf b/conf/distro/nylon.conf
index 531db3bc0a..ecffaad826 100644
--- a/conf/distro/nylon.conf
+++ b/conf/distro/nylon.conf
@@ -80,6 +80,7 @@ PREFERRED_VERSION_binutils-cross-sdk_mtx-3 = "2.15.94.0.1"
PREFERRED_VERSION_binutils_mtx-3 = "2.16"
PREFERRED_VERSION_madwifi-modules = "0.9.3"
PREFERRED_VERSION_madwifi-tools = "0.9.3"
+PREFERRED_VERSION_wpa-supplicant = "0.4.8"
PREFERRED_VERSION_udev = "089"
diff --git a/recipes/wpa-supplicant/wpa-supplicant-0.4.7/driver-madwifi.patch b/recipes/wpa-supplicant/wpa-supplicant-0.4.7/driver-madwifi.patch
new file mode 100644
index 0000000000..8fcf5c7f4a
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-supplicant-0.4.7/driver-madwifi.patch
@@ -0,0 +1,25 @@
+--- wpa_supplicant-0.4.7/driver_madwifi.c-orig 2014-01-03 20:39:58.000000000 +0100
++++ wpa_supplicant-0.4.7/driver_madwifi.c 2014-01-03 20:40:11.000000000 +0100
+@@ -28,16 +28,16 @@
+ #include "wpa.h"
+ #include "wireless_copy.h"
+
+-#include <net80211/compat.h>
+-#include <net80211/_ieee80211.h>
+-#include <net80211/ieee80211.h>
++#include <madwifi/net80211/compat.h>
++#include <madwifi/net80211/_ieee80211.h>
++#include <madwifi/net80211/ieee80211.h>
+ #ifdef WME_NUM_AC
+ /* Assume this is built against BSD branch of madwifi driver. */
+ #define MADWIFI_BSD
+-#include <net80211/_ieee80211.h>
++#include <madwifi/net80211/_ieee80211.h>
+ #endif /* WME_NUM_AC */
+-#include <net80211/ieee80211_crypto.h>
+-#include <net80211/ieee80211_ioctl.h>
++#include <madwifi/net80211/ieee80211_crypto.h>
++#include <madwifi/net80211/ieee80211_ioctl.h>
+
+ #ifdef IEEE80211_IOCTL_SETWMMPARAMS
+ /* Assume this is built against madwifi-ng */
diff --git a/recipes/wpa-supplicant/wpa-supplicant-0.4.7/nylon/defconfig b/recipes/wpa-supplicant/wpa-supplicant-0.4.7/nylon/defconfig
new file mode 100644
index 0000000000..537da72dd6
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-supplicant-0.4.7/nylon/defconfig
@@ -0,0 +1,160 @@
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+CFLAGS = $(TARGET_CFLAGS) -I../hostapd -I../utils -I../driver/modules -Wall -MMD
+
+# for wpa_supplicant, wpa_cli
+LIBS = $(TARGET_LDFLAGS)
+
+# for wpa_passphrase:
+LIBS_p = $(TARGET_LDFLAGS)
+
+
+# Uncomment following two lines and fix the paths if you have installed openssl
+# in non-default location
+#CFLAGS += -I/usr/local/openssl/include
+#LIBS += -L/usr/local/openssl/lib
+
+# Example configuration for various cross-compilation platforms
+
+#### sveasoft (e.g., for Linksys WRT54G) ######################################
+#CC=mipsel-uclibc-gcc
+#CC=/opt/brcm/hndtools-mipsel-uclibc/bin/mipsel-uclibc-gcc
+#CFLAGS += -Os
+#CPPFLAGS += -I../src/include -I../../src/router/openssl/include
+#LIBS += -L/opt/brcm/hndtools-mipsel-uclibc-0.9.19/lib -lssl
+###############################################################################
+
+#### openwrt (e.g., for Linksys WRT54G) #######################################
+#CC=mipsel-uclibc-gcc
+#CC=/opt/brcm/hndtools-mipsel-uclibc/bin/mipsel-uclibc-gcc
+#CFLAGS += -Os
+#CPPFLAGS=-I../src/include -I../openssl-0.9.7d/include \
+# -I../WRT54GS/release/src/include
+#LIBS = -lssl
+###############################################################################
+
+
+# Driver interface for Host AP driver
+#CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for Agere driver
+#CONFIG_DRIVER_HERMES=y
+
+# Driver interface for madwifi driver
+CONFIG_DRIVER_MADWIFI=y
+# Change include directories to match with the local setup
+#CFLAGS += -I../madwifi/wpa
+
+# Driver interface for Prism54 driver
+#CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for ndiswrapper
+#CONFIG_DRIVER_NDISWRAPPER=y
+
+# Driver interface for Atmel driver
+#CONFIG_DRIVER_ATMEL=y
+
+# Driver interface for Broadcom driver
+#CONFIG_DRIVER_BROADCOM=y
+# Example path for wlioctl.h; change to match your configuration
+#CFLAGS += -I/opt/WRT54GS/release/src/include
+
+# Driver interface for Intel ipw2100 driver
+#CONFIG_DRIVER_IPW2100=y
+
+# Driver interface for the Zydas zd1211 driver
+CONFIG_DRIVER_ZD1211=y
+
+# Driver interface for generic Linux wireless extensions
+CONFIG_DRIVER_WEXT=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# Driver interface for Windows NDIS
+#CONFIG_DRIVER_NDIS=y
+#CFLAGS += -I/usr/include/w32api/ddk
+#LIBS += -L/usr/local/lib
+# For native build using mingw
+#CONFIG_NATIVE_WINDOWS=y
+# Additional directories for cross-compilation on Linux host for mingw target
+#CFLAGS += -I/opt/mingw/mingw32/include/ddk
+#LIBS += -L/opt/mingw/mingw32/lib
+#CC=mingw32-gcc
+
+# Driver interface for development testing
+#CONFIG_DRIVER_TEST=y
+
+# Enable IEEE 802.1X Supplicant (automatically included if any EAP method is
+# included)
+CONFIG_IEEE8021X_EAPOL=y
+
+# EAP-MD5 (automatically included if EAP-TTLS is enabled)
+CONFIG_EAP_MD5=y
+
+# EAP-MSCHAPv2 (automatically included if EAP-PEAP is enabled)
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-TLS
+CONFIG_EAP_TLS=y
+
+# EAL-PEAP
+CONFIG_EAP_PEAP=y
+
+# EAP-TTLS
+CONFIG_EAP_TTLS=y
+
+# EAP-GTC
+CONFIG_EAP_GTC=y
+
+# EAP-OTP
+CONFIG_EAP_OTP=y
+
+# EAP-SIM (enable CONFIG_PCSC, if EAP-SIM is used)
+#CONFIG_EAP_SIM=y
+
+# EAP-PSK (experimental; this is _not_ needed for WPA-PSK)
+#CONFIG_EAP_PSK=y
+
+# LEAP
+CONFIG_EAP_LEAP=y
+
+# EAP-AKA (enable CONFIG_PCSC, if EAP-AKA is used)
+#CONFIG_EAP_AKA=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# PC/SC interface for smartcards (USIM, GSM SIM)
+# Enable this if EAP-SIM or EAP-AKA is included
+#CONFIG_PCSC=y
+
+# Development testing
+#CONFIG_EAPOL_TEST=y
+
+# Replace native Linux implementation of packet sockets with libdnet/libpcap.
+# This will be automatically set for non-Linux OS.
+#CONFIG_DNET_PCAP=y
+
+# Include control interface for external programs, e.g, wpa_cli
+CONFIG_CTRL_IFACE=y
+
+# Include interface for using external supplicant (Xsupplicant) for EAP
+# authentication
+#CONFIG_XSUPPLICANT_IFACE=y
+
+# Include support for GNU Readline and History Libraries in wpa_cli.
+# When building a wpa_cli binary for distribution, please note that these
+# libraries are licensed under GPL and as such, BSD license may not apply for
+# the resulting binary.
+#CONFIG_READLINE=y
diff --git a/recipes/wpa-supplicant/wpa-supplicant-0.4.8/driver-madwifi.patch b/recipes/wpa-supplicant/wpa-supplicant-0.4.8/driver-madwifi.patch
new file mode 100644
index 0000000000..8fcf5c7f4a
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-supplicant-0.4.8/driver-madwifi.patch
@@ -0,0 +1,25 @@
+--- wpa_supplicant-0.4.7/driver_madwifi.c-orig 2014-01-03 20:39:58.000000000 +0100
++++ wpa_supplicant-0.4.7/driver_madwifi.c 2014-01-03 20:40:11.000000000 +0100
+@@ -28,16 +28,16 @@
+ #include "wpa.h"
+ #include "wireless_copy.h"
+
+-#include <net80211/compat.h>
+-#include <net80211/_ieee80211.h>
+-#include <net80211/ieee80211.h>
++#include <madwifi/net80211/compat.h>
++#include <madwifi/net80211/_ieee80211.h>
++#include <madwifi/net80211/ieee80211.h>
+ #ifdef WME_NUM_AC
+ /* Assume this is built against BSD branch of madwifi driver. */
+ #define MADWIFI_BSD
+-#include <net80211/_ieee80211.h>
++#include <madwifi/net80211/_ieee80211.h>
+ #endif /* WME_NUM_AC */
+-#include <net80211/ieee80211_crypto.h>
+-#include <net80211/ieee80211_ioctl.h>
++#include <madwifi/net80211/ieee80211_crypto.h>
++#include <madwifi/net80211/ieee80211_ioctl.h>
+
+ #ifdef IEEE80211_IOCTL_SETWMMPARAMS
+ /* Assume this is built against madwifi-ng */
diff --git a/recipes/wpa-supplicant/wpa-supplicant-0.4.8/nylon/defconfig b/recipes/wpa-supplicant/wpa-supplicant-0.4.8/nylon/defconfig
new file mode 100644
index 0000000000..53429b6766
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-supplicant-0.4.8/nylon/defconfig
@@ -0,0 +1,160 @@
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+CFLAGS = $(TARGET_CFLAGS) -I../hostapd -I../utils -I../driver/modules -Wall -MMD
+
+# for wpa_supplicant, wpa_cli
+LIBS = $(TARGET_LDFLAGS)
+
+# for wpa_passphrase:
+LIBS_p = $(TARGET_LDFLAGS)
+
+
+# Uncomment following two lines and fix the paths if you have installed openssl
+# in non-default location
+#CFLAGS += -I/usr/local/openssl/include
+#LIBS += -L/usr/local/openssl/lib
+
+# Example configuration for various cross-compilation platforms
+
+#### sveasoft (e.g., for Linksys WRT54G) ######################################
+#CC=mipsel-uclibc-gcc
+#CC=/opt/brcm/hndtools-mipsel-uclibc/bin/mipsel-uclibc-gcc
+#CFLAGS += -Os
+#CPPFLAGS += -I../src/include -I../../src/router/openssl/include
+#LIBS += -L/opt/brcm/hndtools-mipsel-uclibc-0.9.19/lib -lssl
+###############################################################################
+
+#### openwrt (e.g., for Linksys WRT54G) #######################################
+#CC=mipsel-uclibc-gcc
+#CC=/opt/brcm/hndtools-mipsel-uclibc/bin/mipsel-uclibc-gcc
+#CFLAGS += -Os
+#CPPFLAGS=-I../src/include -I../openssl-0.9.7d/include \
+# -I../WRT54GS/release/src/include
+#LIBS = -lssl
+###############################################################################
+
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for Agere driver
+CONFIG_DRIVER_HERMES=y
+
+# Driver interface for madwifi driver
+CONFIG_DRIVER_MADWIFI=y
+# Change include directories to match with the local setup
+#CFLAGS += -I../madwifi/wpa
+
+# Driver interface for Prism54 driver
+#CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for ndiswrapper
+#CONFIG_DRIVER_NDISWRAPPER=y
+
+# Driver interface for Atmel driver
+#CONFIG_DRIVER_ATMEL=y
+
+# Driver interface for Broadcom driver
+#CONFIG_DRIVER_BROADCOM=y
+# Example path for wlioctl.h; change to match your configuration
+#CFLAGS += -I/opt/WRT54GS/release/src/include
+
+# Driver interface for Intel ipw2100 driver
+#CONFIG_DRIVER_IPW2100=y
+
+# Driver interface for the Zydas zd1211 driver
+CONFIG_DRIVER_ZD1211=y
+
+# Driver interface for generic Linux wireless extensions
+CONFIG_DRIVER_WEXT=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# Driver interface for Windows NDIS
+#CONFIG_DRIVER_NDIS=y
+#CFLAGS += -I/usr/include/w32api/ddk
+#LIBS += -L/usr/local/lib
+# For native build using mingw
+#CONFIG_NATIVE_WINDOWS=y
+# Additional directories for cross-compilation on Linux host for mingw target
+#CFLAGS += -I/opt/mingw/mingw32/include/ddk
+#LIBS += -L/opt/mingw/mingw32/lib
+#CC=mingw32-gcc
+
+# Driver interface for development testing
+#CONFIG_DRIVER_TEST=y
+
+# Enable IEEE 802.1X Supplicant (automatically included if any EAP method is
+# included)
+CONFIG_IEEE8021X_EAPOL=y
+
+# EAP-MD5 (automatically included if EAP-TTLS is enabled)
+CONFIG_EAP_MD5=y
+
+# EAP-MSCHAPv2 (automatically included if EAP-PEAP is enabled)
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-TLS
+CONFIG_EAP_TLS=y
+
+# EAL-PEAP
+CONFIG_EAP_PEAP=y
+
+# EAP-TTLS
+CONFIG_EAP_TTLS=y
+
+# EAP-GTC
+CONFIG_EAP_GTC=y
+
+# EAP-OTP
+CONFIG_EAP_OTP=y
+
+# EAP-SIM (enable CONFIG_PCSC, if EAP-SIM is used)
+#CONFIG_EAP_SIM=y
+
+# EAP-PSK (experimental; this is _not_ needed for WPA-PSK)
+#CONFIG_EAP_PSK=y
+
+# LEAP
+CONFIG_EAP_LEAP=y
+
+# EAP-AKA (enable CONFIG_PCSC, if EAP-AKA is used)
+#CONFIG_EAP_AKA=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# PC/SC interface for smartcards (USIM, GSM SIM)
+# Enable this if EAP-SIM or EAP-AKA is included
+#CONFIG_PCSC=y
+
+# Development testing
+#CONFIG_EAPOL_TEST=y
+
+# Replace native Linux implementation of packet sockets with libdnet/libpcap.
+# This will be automatically set for non-Linux OS.
+#CONFIG_DNET_PCAP=y
+
+# Include control interface for external programs, e.g, wpa_cli
+CONFIG_CTRL_IFACE=y
+
+# Include interface for using external supplicant (Xsupplicant) for EAP
+# authentication
+#CONFIG_XSUPPLICANT_IFACE=y
+
+# Include support for GNU Readline and History Libraries in wpa_cli.
+# When building a wpa_cli binary for distribution, please note that these
+# libraries are licensed under GPL and as such, BSD license may not apply for
+# the resulting binary.
+#CONFIG_READLINE=y
diff --git a/recipes/wpa-supplicant/wpa-supplicant_0.4.7.bb b/recipes/wpa-supplicant/wpa-supplicant_0.4.7.bb
index 412c65dc06..e3506abe15 100644
--- a/recipes/wpa-supplicant/wpa-supplicant_0.4.7.bb
+++ b/recipes/wpa-supplicant/wpa-supplicant_0.4.7.bb
@@ -14,6 +14,14 @@ SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \
file://driver-zd1211.patch;patch=1 \
file://wpa_supplicant.conf"
+SRC_URI_nylon = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \
+ file://madwifi-bsd-fix.diff;patch=1;pnum=0 \
+ file://defconfig \
+ file://driver-madwifi.patch;patch=1 \
+ file://driver-hermes.patch;patch=1 \
+ file://driver-zd1211.patch;patch=1 \
+ file://wpa_supplicant.conf"
+
S = "${WORKDIR}/wpa_supplicant-${PV}"
do_configure () {
diff --git a/recipes/wpa-supplicant/wpa-supplicant_0.4.8.bb b/recipes/wpa-supplicant/wpa-supplicant_0.4.8.bb
index 81dd5f8457..c9fde06a68 100644
--- a/recipes/wpa-supplicant/wpa-supplicant_0.4.8.bb
+++ b/recipes/wpa-supplicant/wpa-supplicant_0.4.8.bb
@@ -15,6 +15,15 @@ SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \
file://wpa-supplicant.sh \
file://wpa_supplicant.conf"
+SRC_URI_nylon = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \
+ file://madwifi-bsd-fix.diff;patch=1;pnum=0 \
+ file://defconfig \
+ file://driver-madwifi.patch;patch=1 \
+ file://driver-hermes.patch;patch=1 \
+ file://driver-zd1211.patch;patch=1 \
+ file://wpa-supplicant.sh \
+ file://wpa_supplicant.conf"
+
S = "${WORKDIR}/wpa_supplicant-${PV}"
do_configure () {