aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLudovic Desroches <ludovic.desroches@atmel.com>2011-05-30 18:43:14 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-06-09 21:31:09 +0200
commit0052931adafee8db2bc4c9221934aa2ebae8f69b (patch)
tree1172b7b705aaf2cc82449ad63adc30d19195c8ed
parentca688dd2de58dbec865ac7e70fab4d2c373ad822 (diff)
downloadopenembedded-0052931adafee8db2bc4c9221934aa2ebae8f69b.tar.gz
tiobench: Add version 0.3.3 (initial recipe)
Build tested and run tested with task-base image with the tiobench package on atmel boards by Ludovic Desroches and Build tested using `angstrom-2010.x` and `minimal{,-uclibc}` for `MACHINE = "beagleboard"` by Paul Menzel. Signed-off-by: Ludovic Desroches <ludovic.desroches@atmel.com> Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
-rw-r--r--recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch47
-rw-r--r--recipes/tiobench/tiobench_0.3.3.bb24
2 files changed, 71 insertions, 0 deletions
diff --git a/recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch b/recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch
new file mode 100644
index 0000000000..f924c1bd66
--- /dev/null
+++ b/recipes/tiobench/tiobench-0.3.3/tiobench-makefile.patch
@@ -0,0 +1,47 @@
+Author: Ludovic Desroches <ludovic.desroches@atmel.com>
+
+Adapt tiobench to OE
+Index: Makefile
+===================================================================
+--- a/Makefile 2011-05-26 07:48:46.341400974 +0200
++++ b/Makefile 2011-05-30 06:32:38.091401358 +0200
+@@ -1,8 +1,9 @@
+ # Makefile for tiotest
+
+-CC=gcc
++CC?=gcc
+ #CFLAGS=-O3 -fomit-frame-pointer -Wall
+ CFLAGS=-O2 -Wall
++LDFLAGS?=
+
+ #DEFINES=-DUSE_MMAP
+ #-DUSE_MADVISE
+@@ -14,16 +15,16 @@
+
+ #DEFINES=
+
+-LINK=gcc
++LINK?=$(CC)
+ EXE=tiotest
+ PROJECT=tiobench
+ # do it once instead of each time referenced
+ VERSION=$(shell egrep "tiotest v[0-9]+.[0-9]+" tiotest.c | cut -d " " -f 7 | sed "s/v//g")
+ DISTNAME=$(PROJECT)-$(VERSION)
+ INSTALL=install
+-PREFIX=/usr/local
++PREFIX?=/usr/local
+ BINDIR=$(PREFIX)/bin
+-DOCDIR=/usr/local/doc/$(DISTNAME)
++DOCDIR=$(PREFIX)/doc/$(DISTNAME)
+
+ all: $(EXE)
+
+@@ -34,7 +35,7 @@
+ $(CC) -c $(CFLAGS) $(DEFINES) tiotest.c -o tiotest.o
+
+ $(EXE): tiotest.o crc32.o
+- $(LINK) -o $(EXE) tiotest.o crc32.o -lpthread
++ $(LINK) -o $(EXE) tiotest.o crc32.o -lpthread $(LDFLAGS)
+ @echo
+ @echo "./tiobench.pl --help for usage options"
+ @echo
diff --git a/recipes/tiobench/tiobench_0.3.3.bb b/recipes/tiobench/tiobench_0.3.3.bb
new file mode 100644
index 0000000000..55894e3875
--- /dev/null
+++ b/recipes/tiobench/tiobench_0.3.3.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Threaded I/O tester"
+HOMEPAGE = "http://sourceforge.net/projects/tiobench/"
+LICENSE = "GPLv2"
+RDEPENDS = "\
+ perl \
+ perl-module-exporter-heavy \
+ perl-module-getopt-long \
+ perl-module-overload \
+ perl-module-strict \
+ "
+PR = "r0"
+
+SRC_URI = "\
+ http://sourceforge.net/projects/tiobench/files/tiobench/${PV}/${P}.tar.gz \
+ file://tiobench-makefile.patch \
+ "
+SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128"
+SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc"
+
+EXTRA_OEMAKE = "PREFIX=${D}"
+
+do_install() {
+ oe_runmake install
+}