aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-11 21:01:47 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-11 21:02:36 +0000
commit25db6767cbf1b00a4e8dbf746d2d16458c3696ea (patch)
tree6f3bb096161bfd8567fcf0bb822f6f96b1607016
parent177ca0dc717faafb67d9fa2f6236eccc182b8038 (diff)
downloadopenembedded-25db6767cbf1b00a4e8dbf746d2d16458c3696ea.tar.gz
perl: Move config.sh to STAGING_LIBDIR rather than trying to be clever with staging variables and losing
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rw-r--r--classes/cpan-base.bbclass6
-rw-r--r--classes/cpan.bbclass2
-rw-r--r--classes/cpan_build.bbclass2
-rw-r--r--recipes/perl/perl-native_5.8.8.bb9
-rw-r--r--recipes/perl/perl.inc4
-rw-r--r--recipes/perl/perl_5.8.4.bb2
-rw-r--r--recipes/perl/perl_5.8.7.bb2
-rw-r--r--recipes/perl/perl_5.8.8.bb5
8 files changed, 14 insertions, 18 deletions
diff --git a/classes/cpan-base.bbclass b/classes/cpan-base.bbclass
index cc0d11e515..82fd5b459a 100644
--- a/classes/cpan-base.bbclass
+++ b/classes/cpan-base.bbclass
@@ -9,8 +9,8 @@ RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}"
# Determine the staged version of perl from the perl configuration file
def get_perl_version(d):
- import os, bb, re
- cfg = bb.data.expand('${STAGING_DIR}/${HOST_SYS}/perl/config.sh', d)
+ import re
+ cfg = bb.data.expand('${STAGING_LIBDIR}/perl/config.sh', d)
try:
f = open(cfg, 'r')
except IOError:
@@ -33,7 +33,6 @@ def is_new_perl(d):
# Determine where the library directories are
def perl_get_libdirs(d):
- import bb
libdir = bb.data.getVar('libdir', d, 1)
if is_new_perl(d) == "yes":
libdirs = libdir + '/perl5'
@@ -42,7 +41,6 @@ def perl_get_libdirs(d):
return libdirs
def is_target(d):
- import bb
if not bb.data.inherits_class('native', d):
return "yes"
return "no"
diff --git a/classes/cpan.bbclass b/classes/cpan.bbclass
index 7b3faa2561..66054bc755 100644
--- a/classes/cpan.bbclass
+++ b/classes/cpan.bbclass
@@ -16,7 +16,7 @@ export PERL_ARCHLIB = "${STAGING_LIBDIR}/perl/${@get_perl_version(d)}"
cpan_do_configure () {
yes '' | perl Makefile.PL ${EXTRA_CPANFLAGS}
if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
- . ${STAGING_DIR_TARGET}/perl/config.sh
+ . ${STAGING_LIBDIR}/perl/config.sh
if [ "${IS_NEW_PERL}" = "yes" ]; then
sed -i -e "s:\(SITELIBEXP = \).*:\1${sitelibexp}:" \
-e "s:\(SITEARCHEXP = \).*:\1${sitearchexp}:" \
diff --git a/classes/cpan_build.bbclass b/classes/cpan_build.bbclass
index c3804ff4cc..2ca01996a9 100644
--- a/classes/cpan_build.bbclass
+++ b/classes/cpan_build.bbclass
@@ -25,7 +25,7 @@ DEPENDS_prepend = "${@cpan_build_dep_prepend(d)}"
cpan_build_do_configure () {
if [ ${@is_target(d)} == "yes" ]; then
# build for target
- . ${STAGING_DIR_TARGET}/perl/config.sh
+ . ${STAGING_LIBDIR}/perl/config.sh
if [ "${IS_NEW_PERL}" = "yes" ]; then
perl Build.PL --installdirs vendor \
--destdir ${D} \
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index ba05406eb0..60a5cf5b0f 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r14"
+PR = "r15"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -66,10 +66,9 @@ do_stage_append() {
# We need a hostperl link for building perl
ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl
# Store native config in non-versioned directory
- install -d ${STAGING_DIR}/${HOST_SYS}/perl \
- ${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE \
+ install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE \
${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils
- install config.sh ${STAGING_DIR}/${HOST_SYS}/perl
+ install config.sh ${STAGING_LIBDIR}/perl
# target configuration
install lib/Config.pm ${STAGING_LIBDIR_NATIVE}/perl/${PV}/
install lib/ExtUtils/typemap ${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils/
@@ -88,7 +87,7 @@ do_stage_append() {
}
do_stage_append_nylon() {
# get rid of definitions not supported by the gcc version we use for nylon...
- for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR}/${HOST_SYS}/perl/config.sh; do
+ for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_LIBDIR}/perl/config.sh; do
perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
done
}
diff --git a/recipes/perl/perl.inc b/recipes/perl/perl.inc
index 9e20ae63e6..15ae55cf17 100644
--- a/recipes/perl/perl.inc
+++ b/recipes/perl/perl.inc
@@ -36,8 +36,8 @@ do_install() {
}
do_stage() {
- install -d ${STAGING_DIR}/${HOST_SYS}/perl/
- install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
+ install -d ${STAGING_LIBDIR}/perl/
+ install config.sh ${STAGING_LIBDIR}/perl/
}
PACKAGES_DYNAMIC = "perl-module-*"
diff --git a/recipes/perl/perl_5.8.4.bb b/recipes/perl/perl_5.8.4.bb
index 10a871c8dd..881a2acee5 100644
--- a/recipes/perl/perl_5.8.4.bb
+++ b/recipes/perl/perl_5.8.4.bb
@@ -1,6 +1,6 @@
require perl.inc
-PR = "r5"
+PR = "r6"
SRC_URI += "file://uclibc.patch;patch=1 \
file://config.sh-mipsel-linux \
diff --git a/recipes/perl/perl_5.8.7.bb b/recipes/perl/perl_5.8.7.bb
index 6589180ff2..5891670394 100644
--- a/recipes/perl/perl_5.8.7.bb
+++ b/recipes/perl/perl_5.8.7.bb
@@ -26,7 +26,7 @@ SRC_URI_append_powerpc += " ${GCCLINK_SRC}"
PARALLEL_MAKE = ""
-PR = "r22"
+PR = "r23"
do_configure() {
ln -sf ${HOSTPERL} ${STAGING_BINDIR_NATIVE}/hostperl
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 35fcc83ccc..02ad7bf376 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -141,12 +141,11 @@ do_install() {
fi
}
do_stage() {
- install -d ${STAGING_DIR}/${HOST_SYS}/perl \
- ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
+ install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE \
${STAGING_DATADIR}/perl/${PV}/ExtUtils
# target config, used by cpan.bbclass to extract version information
- install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
+ install config.sh ${STAGING_LIBDIR}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# target configuration