aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Sorokin <sorokin@altell.ru>2010-11-25 15:09:43 +0300
committerRoman I Khimov <khimov@altell.ru>2010-12-28 22:52:54 +0300
commit707e20a57dac0dbd86d5648f4ba1e0fe72064d8e (patch)
tree1bf0d7dd15f8e894acfc40e7c5fb55b25ddbd70e
parent319f102271e020652dec091150d630b545597426 (diff)
downloadopenembedded-707e20a57dac0dbd86d5648f4ba1e0fe72064d8e.tar.gz
perl-5.10.1: fix config var. 'need_va_copy'
On x86_64, powerpc & s390 architectures need to copy va_list variable, if it got from overlying function, before it passed to underlying function. Signed-off-by: Vladimir Sorokin <sorokin@altell.ru> Signed-off-by: Roman I Khimov <khimov@altell.ru> Acked-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/perl/perl_5.10.1.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 0e6a1f933f..a58b8ec626 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r16"
+PR = "r17"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -149,6 +149,13 @@ do_configure() {
-e 's,/usr/,${exec_prefix}/,g' \
config.sh-${TARGET_ARCH}-${TARGET_OS}
+ case "${TARGET_ARCH}" in
+ x86_64 | powerpc | s390)
+ sed -i -e "s,\(need_va_copy=\)'undef',\1'define',g" \
+ config.sh-${TARGET_ARCH}-${TARGET_OS}
+ ;;
+ esac
+
if test "${MACHINE}" != "native"; then
# These are strewn all over the source tree
for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do