aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-02 00:21:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-02 00:27:39 +0200
commit99e01c4f2f5c2de1621506358026a33ba9b1ac9d (patch)
tree9dea48f2442d1a204aee0b6890b0d4b1a0880ec4
parent926280dac03410f8c535afc948dabfd73ce10463 (diff)
downloadopenembedded-99e01c4f2f5c2de1621506358026a33ba9b1ac9d.tar.gz
gpsd: add 2.91 needed for mcnavi (needs gps_waiting())
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/gpsd/files/cross-compile-on-gentoo.patch28
-rw-r--r--recipes/gpsd/gpsd_2.91.bb10
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes/gpsd/files/cross-compile-on-gentoo.patch b/recipes/gpsd/files/cross-compile-on-gentoo.patch
new file mode 100644
index 0000000000..d3d3231653
--- /dev/null
+++ b/recipes/gpsd/files/cross-compile-on-gentoo.patch
@@ -0,0 +1,28 @@
+diff -uNr gpsd-2.91.orig//configure.ac gpsd-2.91/configure.ac
+--- gpsd-2.91.orig//configure.ac 2010-03-01 22:56:56.000000000 +0100
++++ gpsd-2.91/configure.ac 2010-04-01 16:58:00.000000000 +0200
+@@ -974,12 +974,6 @@
+ AC_SUBST(MANTARGET)
+ AC_SUBST(MANFLAGS)
+
+-dnl Gentoo systems can have a problem with the Python path
+-if test -e /etc/gentoo-release; then
+- AC_MSG_WARN([This is a Gentoo system.])
+- AC_MSG_WARN([Adjust your PYTHONPATH to see library directories under /usr/local/lib])
+-fi
+-
+ dnl Output the configuration summary
+ echo ""
+ echo "=========================================="
+diff -uNr gpsd-2.91.orig//Makefile.am gpsd-2.91/Makefile.am
+--- gpsd-2.91.orig//Makefile.am 2010-04-02 00:04:47.000000000 +0200
++++ gpsd-2.91/Makefile.am 2010-04-02 00:03:18.000000000 +0200
+@@ -257,7 +257,7 @@
+
+ # Install Python modules
+ install-exec-local:
+- $(PYTHON) setup.py install --prefix=${prefix} # --root=$(DESTDIR)
++ $(PYTHON) setup.py install --prefix=${prefix} --root=$(DESTDIR)
+ endif
+
+ if LIBGPSMM_ENABLE
diff --git a/recipes/gpsd/gpsd_2.91.bb b/recipes/gpsd/gpsd_2.91.bb
new file mode 100644
index 0000000000..d0e858d09a
--- /dev/null
+++ b/recipes/gpsd/gpsd_2.91.bb
@@ -0,0 +1,10 @@
+require gpsd.inc
+
+SRC_URI += "file://libtool.patch;patch=1 \
+ file://cross-compile-on-gentoo.patch;patch=1 "
+SRC_URI[gpsd.md5sum] = "c1f97199168c03a431db1a6559b13448"
+SRC_URI[gpsd.sha256sum] = "02ee0f0a86a3c74fe807ea0a3fce908cb94dd7ff3afcef0b1fb663a46c1f71d8"
+
+PR = "${INC_PR}.0"
+
+PARALLEL_MAKE = ""