aboutsummaryrefslogtreecommitdiffstats
path: root/packages/boa
diff options
context:
space:
mode:
authorDan Williams <dan.j.williams@gmail.com>2006-12-03 20:27:29 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-03 20:27:29 +0000
commit45d3f7f53efa86e05af551a4ee77356d8858d7cc (patch)
tree48aa5da9ccbbc872b94408b6f9e40b4eea676b3f /packages/boa
parent249535ba069c94ab58f92f9cfb9d8df7c29aa2c1 (diff)
downloadopenembedded-45d3f7f53efa86e05af551a4ee77356d8858d7cc.tar.gz
boa: added php via cgi support, initscripts fixes for busybox - close #262
Diffstat (limited to 'packages/boa')
-rw-r--r--packages/boa/boa-0.94.13/cgi.patch10
-rw-r--r--packages/boa/boa_0.94.13.bb11
-rw-r--r--packages/boa/files/boa.conf3
-rw-r--r--packages/boa/files/boa.init19
4 files changed, 23 insertions, 20 deletions
diff --git a/packages/boa/boa-0.94.13/cgi.patch b/packages/boa/boa-0.94.13/cgi.patch
new file mode 100644
index 0000000000..4f6a0ee322
--- /dev/null
+++ b/packages/boa/boa-0.94.13/cgi.patch
@@ -0,0 +1,10 @@
+--- boa-0.94.13/src/cgi.c 2002-07-23 08:49:54.000000000 -0700
++++ boa-0.94.13/src/cgi.c~ 2005-06-22 23:13:54.000000000 -0700
+@@ -214,6 +214,7 @@
+ my_add_cgi_env(req, "SERVER_ADDR", req->local_ip_addr);
+ my_add_cgi_env(req, "SERVER_PROTOCOL", req->http_version);
+ my_add_cgi_env(req, "REQUEST_URI", req->request_uri);
++ my_add_cgi_env(req, "SCRIPT_FILENAME", req->request_uri);
+
+ if (req->path_info)
+ my_add_cgi_env(req, "PATH_INFO", req->path_info);
diff --git a/packages/boa/boa_0.94.13.bb b/packages/boa/boa_0.94.13.bb
index 7dc783210e..342dce97bd 100644
--- a/packages/boa/boa_0.94.13.bb
+++ b/packages/boa/boa_0.94.13.bb
@@ -1,16 +1,16 @@
DESCRIPTION = "Lightweight and High Performance WebServer"
SECTION = "console/network"
-RPROVIDES = "httpd"
LICENSE = "GPL"
-PR = "r2"
-
-DEPENDS = "mime-support"
RDEPENDS = "mime-support"
+RPROVIDES = "httpd"
+PR = "r3"
SRC_URI = "http://www.boa.org/boa-${PV}.tar.gz \
+ file://cgi.patch;patch=1;pnum=2 \
file://debian-patch.diff;patch=1;pnum=2 \
file://boa.conf \
file://boa.init"
+
S = "${WORKDIR}/boa-${PV}/src"
inherit autotools update-rc.d
@@ -31,4 +31,7 @@ do_install() {
install -d ${D}${sysconfdir}/init.d
install -m 0640 ${WORKDIR}/boa.conf ${D}${sysconfdir}/${PN}
install -m 0755 ${WORKDIR}/boa.init ${D}${sysconfdir}/init.d/boa
+
+ install -d ${D}${mandir}/man8
+ install -m 0644 ${S}/../docs/boa.8 ${D}${mandir}/man8
}
diff --git a/packages/boa/files/boa.conf b/packages/boa/files/boa.conf
index 349da47ee0..fbe15f4fdf 100644
--- a/packages/boa/files/boa.conf
+++ b/packages/boa/files/boa.conf
@@ -168,7 +168,8 @@ DefaultType text/plain
# Example: AddType type extension [extension ...]
# Uncomment the next line if you want .cgi files to execute from anywhere
-#AddType application/x-httpd-cgi cgi
+AddType application/x-httpd-cgi cgi
+AddType application/x-httpd-cgi php
# Redirect, Alias, and ScriptAlias all have the same semantics -- they
# match the beginning of a request and take appropriate action. Use
diff --git a/packages/boa/files/boa.init b/packages/boa/files/boa.init
index 9c05c5ada3..7ac99f29fb 100644
--- a/packages/boa/files/boa.init
+++ b/packages/boa/files/boa.init
@@ -26,30 +26,19 @@ case "$1" in
;;
stop)
echo -n "Stopping $DESC: $NAME"
- start-stop-daemon --stop --quiet --oknodo --exec $DAEMON
+ start-stop-daemon --stop --quiet --exec $DAEMON
echo "."
;;
restart)
echo -n "Restarting $DESC: $NAME"
- start-stop-daemon --stop --signal HUP --quiet --oknodo --exec $DAEMON
- echo "done."
- ;;
- reload)
- #
- # If the daemon can reload its config files on the fly
- # for example by sending it SIGHUP, do it here.
- #
- # If the daemon responds to changes in its config file
- # directly anyway, make this a do-nothing entry.
- #
- echo -n "Reloading $DESC configuration..."
- start-stop-daemon --stop --signal 1 --quiet --oknodo --exec $DAEMON
+ start-stop-daemon --stop --exec $DAEMON
+ start-stop-daemon --start --exec $DAEMON
echo "done."
;;
*)
N=/etc/init.d/$NAME
# echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
- echo "Usage: $N {start|stop|restart|reload}" >&2
+ echo "Usage: $N {start|stop|restart}" >&2
exit 1
;;
esac