aboutsummaryrefslogtreecommitdiffstats
path: root/packages/boa
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/boa
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/boa')
-rw-r--r--packages/boa/boa_0.94.13.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/boa/boa_0.94.13.bb b/packages/boa/boa_0.94.13.bb
index e69de29bb2..e88ded7df5 100644
--- a/packages/boa/boa_0.94.13.bb
+++ b/packages/boa/boa_0.94.13.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Lightweight and High Performance WebServer"
+SECTION = "console/network"
+RPROVIDES = "httpd"
+MAINTAINER = "Rene Wagner <reenoo@gmx.de>"
+LICENSE = "GPL"
+PR = "r1"
+
+DEPENDS = "mime-support"
+RDEPENDS = "mime-support"
+
+SRC_URI = "http://www.boa.org/boa-${PV}.tar.gz \
+ file://debian-patch.diff;patch=1;pnum=2 \
+ file://boa.conf \
+ file://boa.init"
+S = "${WORKDIR}/boa-${PV}/src"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "boa"
+INITSCRIPT_PARAMS = "defaults 20"
+
+CFLAGS_append = " -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"
+#CFLAGS_append = " -DSERVER_ROOT=..."
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${libdir}/${PN}
+ install -m 0755 boa ${D}${sbindir}
+ install -m 0755 boa_indexer ${D}${libdir}/${PN}
+
+ install -d ${D}${sysconfdir}/${PN}
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0640 ${WORKDIR}/boa.conf ${D}${sysconfdir}/${PN}
+ install -m 0755 ${WORKDIR}/boa.init ${D}${sysconfdir}/init.d/boa
+}