aboutsummaryrefslogtreecommitdiffstats
path: root/packages/chillispot
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-02-15 02:59:55 +0000
committerRene Wagner <rw@handhelds.org>2005-02-15 02:59:55 +0000
commita1d8d152aaffdbc2944f8340ce2d982cbe9e44b8 (patch)
tree434b1e13b3a498061cdd9fdf204552de19d9d1d4 /packages/chillispot
parent1180bd0205b882137f2d9d2038fd888a24202e2d (diff)
downloadopenembedded-a1d8d152aaffdbc2944f8340ce2d982cbe9e44b8.tar.gz
chillispot: demote kernel-module-tun to RRECOMMENDS
BKrev: 421165abftEfDv1LDq31qPZ9qLxtUQ
Diffstat (limited to 'packages/chillispot')
-rw-r--r--packages/chillispot/chillispot_0.98.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/chillispot/chillispot_0.98.bb b/packages/chillispot/chillispot_0.98.bb
index e69de29bb2..c36d45606f 100644
--- a/packages/chillispot/chillispot_0.98.bb
+++ b/packages/chillispot/chillispot_0.98.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
+HOMEPAGE = "http://www.chillispot.org/"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
+ file://init"
+RRECOMMENDS = "kernel-module-tun"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/${sysconfdir} ${D}/${sysconfdir}/init.d
+ install ${S}/doc/chilli.conf ${D}/${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/chillispot
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"