aboutsummaryrefslogtreecommitdiffstats
path: root/packages/chillispot
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/chillispot
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/chillispot')
-rw-r--r--packages/chillispot/.mtn2git_empty0
-rw-r--r--packages/chillispot/chillispot_1.0RC3.bb17
-rw-r--r--packages/chillispot/files/.mtn2git_empty0
-rw-r--r--packages/chillispot/files/init35
4 files changed, 52 insertions, 0 deletions
diff --git a/packages/chillispot/.mtn2git_empty b/packages/chillispot/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/chillispot/.mtn2git_empty
diff --git a/packages/chillispot/chillispot_1.0RC3.bb b/packages/chillispot/chillispot_1.0RC3.bb
index e69de29bb2..3e52abd914 100644
--- a/packages/chillispot/chillispot_1.0RC3.bb
+++ b/packages/chillispot/chillispot_1.0RC3.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
+HOMEPAGE = "http://www.chillispot.org/"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPL"
+SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
+ file://init"
+RDEPENDS = "kernel-module-tun"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/${sysconfdir} ${D}/${sysconfdir}/init.d
+ install ${S}/doc/chilli.conf ${D}/${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/chillispot
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"
diff --git a/packages/chillispot/files/.mtn2git_empty b/packages/chillispot/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/chillispot/files/.mtn2git_empty
diff --git a/packages/chillispot/files/init b/packages/chillispot/files/init
index e69de29bb2..784e519754 100644
--- a/packages/chillispot/files/init
+++ b/packages/chillispot/files/init
@@ -0,0 +1,35 @@
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/chilli
+NAME=chilli
+DESC=chillispot
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+ start-stop-daemon -S -p /var/run/$NAME.pid -x $DAEMON
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon -K -p /var/run/$NAME.pid -x $DAEMON
+ echo "$NAME."
+ ;;
+ restart|force-reload)
+ echo -n "Restarting $DESC: "
+ start-stop-daemon -K -p /var/run/$NAME.pid -x $DAEMON
+ sleep 1
+ start-stop-daemon -S -p /var/run/$NAME.pid -x $DAEMON
+ echo "$NAME."
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0