aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dbus
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-11-19 19:01:48 +0000
committerKoen Kooi <koen@openembedded.org>2006-11-19 19:01:48 +0000
commit290d10e75ac367d91667013625437aebbbfbd155 (patch)
treebfd4df3f0c9abb9b0f4e0e9cbf29dadc154863aa /packages/dbus
parentf8c8812e50b4143e09fee9605c5596194c86b0a8 (diff)
downloadopenembedded-290d10e75ac367d91667013625437aebbbfbd155.tar.gz
dbus-native: update to latest stable (1.0.1)
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-native_1.0.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/dbus/dbus-native_1.0.1.bb b/packages/dbus/dbus-native_1.0.1.bb
new file mode 100644
index 0000000000..a897ae5bba
--- /dev/null
+++ b/packages/dbus/dbus-native_1.0.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "message bus system for applications to talk to one another"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "GPL"
+SECTION = "base"
+
+PR = "r0"
+
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-1.0.1"
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-${PV}"
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+do_stage () {
+ oe_runmake install
+ autotools_stage_all
+
+ # for dbus-glib-native introspection generation
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}