aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dbus
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-07-28 13:04:53 +0000
committerKoen Kooi <koen@openembedded.org>2006-07-28 13:04:53 +0000
commit4c9bbf534cb45801fcc9fbc7005fa1cece590281 (patch)
treedbb0bfbe7127145b02be970515661ff22dee108a /packages/dbus
parent51372539ce1c7dcc75dfb892d3d141b43d49e34d (diff)
downloadopenembedded-4c9bbf534cb45801fcc9fbc7005fa1cece590281.tar.gz
dbus 0.90: add a patch to fix the segfault when trying to access the system bus
* NOTE: this is not a solution, but just moves the memory corruption in to a non-segfault area
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-0.90/fix-segfault.patch11
-rw-r--r--packages/dbus/dbus_0.90.bb5
2 files changed, 14 insertions, 2 deletions
diff --git a/packages/dbus/dbus-0.90/fix-segfault.patch b/packages/dbus/dbus-0.90/fix-segfault.patch
new file mode 100644
index 0000000000..de5bcff774
--- /dev/null
+++ b/packages/dbus/dbus-0.90/fix-segfault.patch
@@ -0,0 +1,11 @@
+--- /tmp/dbus-marshal-recursive.c 2006-07-28 14:58:08.000000000 +0200
++++ dbus-0.90/dbus/dbus-marshal-recursive.c 2006-07-28 14:58:18.724411000 +0200
+@@ -1294,7 +1294,7 @@
+ _dbus_string_get_length (&block->replacement) - block->padding,
+ &fixups))
+ goto oom;
+-
++printf("%s(%d)""got here", __FILE__, __LINE__);
+ #if RECURSIVE_MARSHAL_WRITE_TRACE
+ _dbus_verbose ("REPLACEMENT at padding %d len %d\n", block->padding,
+ _dbus_string_get_length (&block->replacement) - block->padding);
diff --git a/packages/dbus/dbus_0.90.bb b/packages/dbus/dbus_0.90.bb
index e48b09e4ff..9eec6c86c7 100644
--- a/packages/dbus/dbus_0.90.bb
+++ b/packages/dbus/dbus_0.90.bb
@@ -1,7 +1,7 @@
DEFAULT_PREFERENCE="-1"
SECTION = "base"
-PR = "r0"
+PR = "r1"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
@@ -10,7 +10,8 @@ DEPENDS = "expat glib-2.0 virtual/libintl"
SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
file://cross.patch;patch=1 \
file://tmpdir.patch;patch=1 \
- file://dbus-1.init"
+ file://dbus-1.init \
+ file://fix-segfault.patch;patch=1"
inherit autotools pkgconfig update-rc.d gettext