aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dbus
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-08-27 11:33:11 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2006-08-27 11:33:11 +0000
commita2d4bed15938b2b37d033d37b8d4a939fc51752b (patch)
tree9aeca4c33352c5e7b2fea0b1eba4f5e6539839ba /packages/dbus
parent4be216128262f49d669c3c224a398eb4bfb5c32b (diff)
downloadopenembedded-a2d4bed15938b2b37d033d37b8d4a939fc51752b.tar.gz
dbus-native: add 0.92
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-native_0.92.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/dbus/dbus-native_0.92.bb b/packages/dbus/dbus-native_0.92.bb
new file mode 100644
index 0000000000..db2d7014ef
--- /dev/null
+++ b/packages/dbus/dbus-native_0.92.bb
@@ -0,0 +1,27 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/dbus-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus"
+DEPENDS = "glib-2.0-native"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://tmpdir.patch;patch=1"
+
+inherit autotools pkgconfig gettext native
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+do_stage () {
+ oe_runmake install
+ autotools_stage_all
+
+ # for dbus-glib-native introspection generation
+ install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}