aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dbus
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-07-23 14:22:47 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2006-07-23 14:22:47 +0000
commitcc5c376f17654a5ccd678a55163c707346d76bf8 (patch)
tree40653d4c0d0a8de527279080a22b6bcdab3550c2 /packages/dbus
parent68b5df2b8115eee9576ea414d2663a9000f54ee8 (diff)
downloadopenembedded-cc5c376f17654a5ccd678a55163c707346d76bf8.tar.gz
dbus: add 0.90, dbus-glib and dbus-python bindings 0.70
Diffstat (limited to 'packages/dbus')
-rw-r--r--packages/dbus/dbus-0.90/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-0.90/dbus-1.init86
-rw-r--r--packages/dbus/dbus-glib/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-glib/cross.patch15
-rw-r--r--packages/dbus/dbus-glib/dbus-glib-0.70-fix-includes.patch21
-rw-r--r--packages/dbus/dbus-glib/no-examples.patch8
-rw-r--r--packages/dbus/dbus-glib/no-introspect.patch17
-rw-r--r--packages/dbus/dbus-glib_0.70.bb30
-rw-r--r--packages/dbus/dbus-python/.mtn2git_empty0
-rw-r--r--packages/dbus/dbus-python/dbus-python-0.70-fix-binary-modules-dir.patch18
-rw-r--r--packages/dbus/dbus-python_0.70.bb15
-rw-r--r--packages/dbus/dbus_0.90.bb62
12 files changed, 272 insertions, 0 deletions
diff --git a/packages/dbus/dbus-0.90/.mtn2git_empty b/packages/dbus/dbus-0.90/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-0.90/.mtn2git_empty
diff --git a/packages/dbus/dbus-0.90/dbus-1.init b/packages/dbus/dbus-0.90/dbus-1.init
new file mode 100644
index 0000000000..60440b7223
--- /dev/null
+++ b/packages/dbus/dbus-0.90/dbus-1.init
@@ -0,0 +1,86 @@
+#! /bin/sh
+# -*- coding: utf-8 -*-
+# Debian init.d script for D-BUS
+# Copyright © 2003 Colin Walters <walters@debian.org>
+
+set -e
+
+DAEMON=/usr/bin/dbus-daemon
+NAME=dbus-1
+DAEMONUSER=messagebus
+PIDDIR=/var/run/dbus
+PIDFILE=$PIDDIR/pid
+DESC="system message bus"
+EVENTDIR=/etc/dbus-1/event.d
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/dbus-1 ]; then
+ . /etc/default/dbus-1
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ chown $DAEMONUSER $PIDDIR
+ chgrp $DAEMONUSER $PIDDIR
+ fi
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ if [ -d $EVENTDIR ]; then
+ run-parts --arg=start $EVENTDIR
+ fi
+}
+
+shut_it_down()
+{
+ if [ -d $EVENTDIR ]; then
+ run-parts --reverse --arg=stop $EVENTDIR
+ fi
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER
+ # We no longer include these arguments so that start-stop-daemon
+ # can do its job even given that we may have been upgraded.
+ # We rely on the pidfile being sanely managed
+ # --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
+case "$1" in
+ start)
+ start_it_up
+ ;;
+ stop)
+ shut_it_down
+ ;;
+ restart|force-reload)
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
+ *)
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/dbus/dbus-glib/.mtn2git_empty b/packages/dbus/dbus-glib/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-glib/.mtn2git_empty
diff --git a/packages/dbus/dbus-glib/cross.patch b/packages/dbus/dbus-glib/cross.patch
new file mode 100644
index 0000000000..6d1d9d8e7e
--- /dev/null
+++ b/packages/dbus/dbus-glib/cross.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dbus-0.20/configure.in~cross
++++ dbus-0.20/configure.in
+@@ -466,6 +466,7 @@
+ exit (0);
+ ]])],
+ [have_abstract_sockets=yes],
++ [have_abstract_sockets=no],
+ [have_abstract_sockets=no])
+ AC_LANG_POP(C)
+ AC_MSG_RESULT($have_abstract_sockets)
diff --git a/packages/dbus/dbus-glib/dbus-glib-0.70-fix-includes.patch b/packages/dbus/dbus-glib/dbus-glib-0.70-fix-includes.patch
new file mode 100644
index 0000000000..68edc54038
--- /dev/null
+++ b/packages/dbus/dbus-glib/dbus-glib-0.70-fix-includes.patch
@@ -0,0 +1,21 @@
+--- dbus-glib-0.70/dbus/Makefile.am.fix_includes 2006-07-17 13:00:39.000000000 -0400
++++ dbus-glib-0.70/dbus/Makefile.am 2006-07-17 20:09:00.000000000 -0400
+@@ -38,13 +38,13 @@
+ dbus-gvalue.c \
+ dbus-gvalue.h \
+ dbus-gthread.c \
+- dbus-glib.h \
+- dbus-glib-lowlevel.h \
+- dbus-glib-error-enum.h \
+ $(DBUS_GLIB_INTERNALS)
+
+ libdbus_glib_HEADERS = \
+- dbus-gtype-specialized.h
++ dbus-gtype-specialized.h \
++ dbus-glib.h \
++ dbus-glib-lowlevel.h \
++ dbus-glib-error-enum.h
+
+ libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
+
diff --git a/packages/dbus/dbus-glib/no-examples.patch b/packages/dbus/dbus-glib/no-examples.patch
new file mode 100644
index 0000000000..483153db74
--- /dev/null
+++ b/packages/dbus/dbus-glib/no-examples.patch
@@ -0,0 +1,8 @@
+--- dbus-glib-0.70/dbus/Makefile.am.orig 2006-07-23 16:04:43.000000000 +0200
++++ dbus-glib-0.70/dbus/Makefile.am 2006-07-23 16:04:52.000000000 +0200
+@@ -1,4 +1,4 @@
+-SUBDIRS = . examples
++SUBDIRS = .
+
+ INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
+
diff --git a/packages/dbus/dbus-glib/no-introspect.patch b/packages/dbus/dbus-glib/no-introspect.patch
new file mode 100644
index 0000000000..7057a63020
--- /dev/null
+++ b/packages/dbus/dbus-glib/no-introspect.patch
@@ -0,0 +1,17 @@
+--- dbus-glib-0.70/tools/Makefile.am.orig 2006-07-23 15:53:06.000000000 +0200
++++ dbus-glib-0.70/tools/Makefile.am 2006-07-23 15:53:53.000000000 +0200
+@@ -3,14 +3,8 @@
+ nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
+ libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
+-dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/dbus/dbus-binding-tool$(EXEEXT)
+- $(top_builddir)/dbus/dbus-binding-tool --mode=glib-client --output=dbus-glib-bindings.h dbus-bus-introspect.xml
+-
+ BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
+
+-dbus-bus-introspect.xml:
+- DBUS_TOP_BUILDDIR=$(top_builddir) dbus-send --system --print-reply=literal --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.Introspectable.Introspect > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
+-
+ EXTRA_DIST = run-with-tmp-session-bus.sh
+
+ CLEANFILES = \
diff --git a/packages/dbus/dbus-glib_0.70.bb b/packages/dbus/dbus-glib_0.70.bb
new file mode 100644
index 0000000000..304e7aca48
--- /dev/null
+++ b/packages/dbus/dbus-glib_0.70.bb
@@ -0,0 +1,30 @@
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-glib-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://dbus-glib-0.70-fix-includes.patch;patch=1 \
+ file://no-examples.patch;patch=1 \
+ file://no-introspect.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-glib-bindings.h ${S}/tools/
+}
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-glib-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+}
+
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"
diff --git a/packages/dbus/dbus-python/.mtn2git_empty b/packages/dbus/dbus-python/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus-python/.mtn2git_empty
diff --git a/packages/dbus/dbus-python/dbus-python-0.70-fix-binary-modules-dir.patch b/packages/dbus/dbus-python/dbus-python-0.70-fix-binary-modules-dir.patch
new file mode 100644
index 0000000000..17b78d938a
--- /dev/null
+++ b/packages/dbus/dbus-python/dbus-python-0.70-fix-binary-modules-dir.patch
@@ -0,0 +1,18 @@
+--- dbus-python-0.70/setup.py.fix-binary-modules-dir 2006-07-17 20:30:07.000000000 -0400
++++ dbus-python-0.70/setup.py 2006-07-17 20:30:22.000000000 -0400
+@@ -92,12 +92,12 @@
+ "dbus/_util",
+ ],
+ ext_modules=[
+- Extension("dbus_bindings", ["dbus/dbus_bindings.pyx"],
++ Extension("dbus/dbus_bindings", ["dbus/dbus_bindings.pyx"],
+ include_dirs=dbus_includes,
+ libraries=["dbus-1"],
+
+ ),
+- Extension("dbus_glib_bindings", ["dbus/dbus_glib_bindings.pyx"],
++ Extension("dbus/dbus_glib_bindings", ["dbus/dbus_glib_bindings.pyx"],
+ include_dirs=dbus_glib_includes,
+ libraries=["dbus-glib-1", "dbus-1", "glib-2.0"],
+ define_macros=[
+
diff --git a/packages/dbus/dbus-python_0.70.bb b/packages/dbus/dbus-python_0.70.bb
new file mode 100644
index 0000000000..7bfbc931ed
--- /dev/null
+++ b/packages/dbus/dbus-python_0.70.bb
@@ -0,0 +1,15 @@
+DEFAULT_PREFERENCE="-1"
+
+SECTION = "devel/python"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another - python bindings"
+LICENSE = "GPL"
+PR = "r0"
+DEPENDS = "python-native"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-python-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://dbus-python-0.70-fix-binary-modules-dir.patch;patch=1"
+
+inherit distutils
diff --git a/packages/dbus/dbus_0.90.bb b/packages/dbus/dbus_0.90.bb
new file mode 100644
index 0000000000..e48b09e4ff
--- /dev/null
+++ b/packages/dbus/dbus_0.90.bb
@@ -0,0 +1,62 @@
+DEFAULT_PREFERENCE="-1"
+
+SECTION = "base"
+PR = "r0"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl"
+
+SRC_URI = "http://freedesktop.org/software/dbus/releases/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://tmpdir.patch;patch=1 \
+ file://dbus-1.init"
+
+inherit autotools pkgconfig update-rc.d gettext
+
+INITSCRIPT_NAME = "dbus-1"
+INITSCRIPT_PARAMS = "defaults"
+
+CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
+
+FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
+
+pkg_postinst_dbus() {
+#!/bin/sh
+
+# can't do adduser stuff offline
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+MESSAGEUSER=messagebus
+MESSAGEHOME=/var/run/dbus
+
+mkdir -p $MESSAGEHOME || true
+chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
+chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
+}
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+
+ mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+ install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+}
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_dbus', 'dbus-1', d)
+}