aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk-webcore
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-09-18 00:53:47 +0000
committerKristoffer Ericson <kristoffer_e1@hotmail.com>2006-09-18 00:53:47 +0000
commit54a3061ee9a6b045afb7b153167d3e834e040dcf (patch)
tree22ff1e6d409108fafe209160957afa03c8794679 /packages/gtk-webcore
parent8ad4fb970642373bf995a4bca161a90fe6a6041d (diff)
downloadopenembedded-54a3061ee9a6b045afb7b153167d3e834e040dcf.tar.gz
gtk-webcore/osb-jscore-0.5.0: Addition of patches for gcc4 & superh
* Addition of superh-aclocal.patch that adds sh* to host_cpu * Addition of gcc4-fno-threads-statics patch for sh3 * Change .bb file to reflect patches (used append_sh3)
Diffstat (limited to 'packages/gtk-webcore')
-rw-r--r--packages/gtk-webcore/osb-jscore-0.5.0/gcc4-fno-threadsafe-statics.patch11
-rw-r--r--packages/gtk-webcore/osb-jscore-0.5.0/superh-aclocal.patch11
-rw-r--r--packages/gtk-webcore/osb-jscore_0.5.0.bb3
3 files changed, 25 insertions, 0 deletions
diff --git a/packages/gtk-webcore/osb-jscore-0.5.0/gcc4-fno-threadsafe-statics.patch b/packages/gtk-webcore/osb-jscore-0.5.0/gcc4-fno-threadsafe-statics.patch
new file mode 100644
index 0000000000..44e69b2707
--- /dev/null
+++ b/packages/gtk-webcore/osb-jscore-0.5.0/gcc4-fno-threadsafe-statics.patch
@@ -0,0 +1,11 @@
+--- osb-jscore-0.5.0/configure.in_orig 2006-09-18 00:37:27.000000000 +0000
++++ osb-jscore-0.5.0/configure.in 2006-09-18 00:37:51.000000000 +0000
+@@ -61,7 +61,7 @@
+ fi
+ changequote([,])dnl
+
+-CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++"
++CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++ -fno-threadsafe-statics"
+ LDFLAGS="$LDFLAGS -nodefaultlibs -lgcc -lc -lm"
+
+ CPPFLAGS="$CPPFLAGS -I\$(top_srcdir)/kjs -I\$(top_srcdir)/pcre -I\$(top_srcdir)/"
diff --git a/packages/gtk-webcore/osb-jscore-0.5.0/superh-aclocal.patch b/packages/gtk-webcore/osb-jscore-0.5.0/superh-aclocal.patch
new file mode 100644
index 0000000000..706dead8c3
--- /dev/null
+++ b/packages/gtk-webcore/osb-jscore-0.5.0/superh-aclocal.patch
@@ -0,0 +1,11 @@
+--- osb-jscore-0.5.0/aclocal.m4_orig 2006-09-18 00:49:32.000000000 +0000
++++ osb-jscore-0.5.0/aclocal.m4 2006-09-18 00:49:52.000000000 +0000
+@@ -4299,7 +4299,7 @@
+ # This must be Linux ELF.
+ linux-gnu*)
+ case $host_cpu in
+- alpha* | hppa* | i*86 | mips | mipsel | powerpc* | sparc* | ia64* | s390* | x86_64*)
++ alpha* | hppa* | i*86 | mips | mipsel | powerpc* | sparc* | ia64* | s390* | sh* | x86_64*)
+ lt_cv_deplibs_check_method=pass_all ;;
+ *)
+ # glibc up to 2.1.1 does not perform some relocations on ARM
diff --git a/packages/gtk-webcore/osb-jscore_0.5.0.bb b/packages/gtk-webcore/osb-jscore_0.5.0.bb
index 5e38d59f77..3a1ff2b65e 100644
--- a/packages/gtk-webcore/osb-jscore_0.5.0.bb
+++ b/packages/gtk-webcore/osb-jscore_0.5.0.bb
@@ -10,6 +10,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/gtk-webcore/osb-jscore-${PV}.tar.gz \
file://missing-includes.patch;patch=1 \
file://libm.patch;patch=1"
+SRC_URI_append_sh3 = " file://superh-aclocal.patch;patch=1 \
+ file://gcc4-fno-threadsafe-statics.patch;patch=1"
+
inherit autotools pkgconfig
do_configure () {