aboutsummaryrefslogtreecommitdiffstats
path: root/packages/konqueror
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-10-10 00:05:06 +0000
committerKristoffer Ericson <kristoffer_e1@hotmail.com>2006-10-10 00:05:06 +0000
commitd7ce257ea98ee09f1d866b66e7f2013a7c3c114f (patch)
tree146d83200174d0b10c11588b69f7830231ca0bb4 /packages/konqueror
parentba2edadd18221dc8a79713c4bcf8805a29ae6bd8 (diff)
downloadopenembedded-d7ce257ea98ee09f1d866b66e7f2013a7c3c114f.tar.gz
packages/konqueror/konqueror-embedded-20060404: Fix of KDE-config error
* This fixes configure error "kde-config not found..." by removing those checks from acinclude.m4. Changes applied to .bb file and addition of patch. Kde-config is the spawn of the devil. Confirmed build.
Diffstat (limited to 'packages/konqueror')
-rw-r--r--packages/konqueror/konqueror-embedded-20060404/.mtn2git_empty0
-rw-r--r--packages/konqueror/konqueror-embedded-20060404/dont-use-kde-config.patch62
-rw-r--r--packages/konqueror/konqueror-embedded_20060404.bb3
3 files changed, 64 insertions, 1 deletions
diff --git a/packages/konqueror/konqueror-embedded-20060404/.mtn2git_empty b/packages/konqueror/konqueror-embedded-20060404/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/konqueror/konqueror-embedded-20060404/.mtn2git_empty
diff --git a/packages/konqueror/konqueror-embedded-20060404/dont-use-kde-config.patch b/packages/konqueror/konqueror-embedded-20060404/dont-use-kde-config.patch
new file mode 100644
index 0000000000..9bd89f1252
--- /dev/null
+++ b/packages/konqueror/konqueror-embedded-20060404/dont-use-kde-config.patch
@@ -0,0 +1,62 @@
+--- kdenox/devscripts/acinclude.m4.in.qt2_orig 2006-10-09 23:45:34.000000000 +0000
++++ kdenox/devscripts/acinclude.m4.in.qt2 2006-10-09 23:47:51.000000000 +0000
+@@ -4937,31 +4937,31 @@
+ AC_PREFIX_DEFAULT(${KDEDIR:-the kde prefix})
+
+ KDE_SET_DEFAULT_BINDIRS
+- if test "x$prefix" = "xNONE"; then
++ dnl if test "x$prefix" = "xNONE"; then
+ dnl no prefix given: look for kde-config in the PATH and deduce the prefix from it
+- KDE_FIND_PATH(kde-config, KDECONFIG, [$kde_default_bindirs], [KDE_MISSING_PROG_ERROR(kde-config)], [], prepend)
+- else
++ dnl KDE_FIND_PATH(kde-config, KDECONFIG, [$kde_default_bindirs], [KDE_MISSING_PROG_ERROR(kde-config)], [], prepend)
++ dnl else
+ dnl prefix given: look for kde-config, preferrably in prefix, otherwise in PATH
+- kde_save_PATH="$PATH"
+- PATH="$exec_prefix/bin:$prefix/bin:$PATH"
+- KDE_FIND_PATH(kde-config, KDECONFIG, [$kde_default_bindirs], [KDE_MISSING_PROG_ERROR(kde-config)], [], prepend)
+- PATH="$kde_save_PATH"
+- fi
+-
+- kde_libs_prefix=`$KDECONFIG --prefix`
+- if test -z "$kde_libs_prefix" || test ! -x "$kde_libs_prefix"; then
+- AC_MSG_ERROR([$KDECONFIG --prefix outputed the non existant prefix '$kde_libs_prefix' for kdelibs.
+- This means it has been moved since you installed it.
+- This won't work. Please recompile kdelibs for the new prefix.
+- ])
+- fi
+- kde_libs_htmldir=`$KDECONFIG --install html --expandvars`
+- kde_libs_suffix=`$KDECONFIG --libsuffix`
++ dnl kde_save_PATH="$PATH"
++ dnl PATH="$exec_prefix/bin:$prefix/bin:$PATH"
++ dnl KDE_FIND_PATH(kde-config, KDECONFIG, [$kde_default_bindirs], [KDE_MISSING_PROG_ERROR(kde-config)], [], prepend)
++ dnl PATH="$kde_save_PATH"
++ dnl fi
++
++ dnl kde_libs_prefix=`$KDECONFIG --prefix`
++ dnl if test -z "$kde_libs_prefix" || test ! -x "$kde_libs_prefix"; then
++ dnl AC_MSG_ERROR([$KDECONFIG --prefix outputed the non existant prefix '$kde_libs_prefix' for kdelibs.
++ dnl This means it has been moved since you installed it.
++ dnl This won't work. Please recompile kdelibs for the new prefix.
++ dnl ])
++ dnl fi
++ dnl kde_libs_htmldir=`$KDECONFIG --install html --expandvars`
++ dnl kde_libs_suffix=`$KDECONFIG --libsuffix`
+
+ AC_MSG_CHECKING([where to install])
+ if test "x$prefix" = "xNONE"; then
+ prefix=$kde_libs_prefix
+- AC_MSG_RESULT([$prefix (as returned by kde-config)])
++dnl AC_MSG_RESULT([$prefix (as returned by kde-config)])
+ else
+ dnl --prefix was given. Compare prefixes and warn (in configure.in.bot.end) if different
+ given_prefix=$prefix
+@@ -4973,7 +4973,7 @@
+ exec_prefix=`echo "$exec_prefix" | sed 's,//*,/,g' | sed -e 's,/$,,'`
+ given_prefix=`echo "$given_prefix" | sed 's,//*,/,g' | sed -e 's,/$,,'`
+
+- AC_SUBST(KDECONFIG)
++ dnl AC_SUBST(KDECONFIG)
+ AC_SUBST(kde_libs_prefix)
+ AC_SUBST(kde_libs_htmldir)
+
diff --git a/packages/konqueror/konqueror-embedded_20060404.bb b/packages/konqueror/konqueror-embedded_20060404.bb
index 02321bc1c1..221ecb0bb3 100644
--- a/packages/konqueror/konqueror-embedded_20060404.bb
+++ b/packages/konqueror/konqueror-embedded_20060404.bb
@@ -12,7 +12,8 @@ inherit autotools
SRC_URI = "svn://anonsvn.kde.org/home/kde/tags/KDE/3.5.1;module=kdelibs;date=${PV} \
svn://anonsvn.kde.org/home/kde/trunk;module=kdenox;date=${PV} \
- file://gcc4.patch;patch=1"
+ file://gcc4.patch;patch=1 \
+ file://dont-use-kde-config.patch;patch=0"
# uncomment this for a static build
# file://inject-extraflags.patch;patch=1"
S = "${WORKDIR}/kdenox"