aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libpng
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2006-09-11 23:48:02 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2006-09-11 23:48:02 +0000
commitbd4ed80c3eadc1539f3e90e956c076d62aa0d49c (patch)
treee7f569ea188b18d601322dff3c99ec6678affe9d /packages/libpng
parent4082ac4cf6c8d21399aa7aad6838137f9632f4b9 (diff)
downloadopenembedded-bd4ed80c3eadc1539f3e90e956c076d62aa0d49c.tar.gz
libpng 1.2.12: Switch to use autoconf'ed build.
* 1.2.12 (or other version past 1.2.8) switched to the full configure support, use autotools class to build it.
Diffstat (limited to 'packages/libpng')
-rw-r--r--packages/libpng/libpng_1.2.12.bb29
1 files changed, 3 insertions, 26 deletions
diff --git a/packages/libpng/libpng_1.2.12.bb b/packages/libpng/libpng_1.2.12.bb
index 66b691b617..deff600a7a 100644
--- a/packages/libpng/libpng_1.2.12.bb
+++ b/packages/libpng/libpng_1.2.12.bb
@@ -4,7 +4,7 @@ LICENSE = "libpng"
SECTION = "libs"
PRIORITY = "required"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
-PR = "r3"
+PR = "r4"
DEPENDS = "zlib"
@@ -21,36 +21,13 @@ FILES_${PN}-dev = ${includedir} ${libdir}/lib*.so ${libdir}/*.la \
SRC_URI = "${SOURCEFORGE_MIRROR}/libpng/libpng-${PV}.tar.bz2"
S = "${WORKDIR}/libpng-${PV}"
-inherit pkgconfig binconfig pkgconfig
-
-EXTRA_OEMAKE_append = " ZLIBINC=${STAGING_INCDIR} ZLIBLIB=${STAGING_LIBDIR}"
-CFLAGS += "-DPNG_NO_ASSEMBLER_CODE"
-
-do_compile() {
- sed < scripts/makefile.linux > makefile -e 's/^ZLIBINC.*//' -e 's/^ZLIBLIB.*//'
- unset LDFLAGS
- oe_runmake 'CC=${CC}' 'LD=${LD}' 'CFLAGS=${CFLAGS}' \
- 'ZLIBINC=${STAGING_INCDIR}' \
- 'ZLIBLIB=${STAGING_LIBDIR}'
-}
-
-# apperently libpng doesn't expand the vars in libpng.pc, so we'll do that with sed
-# pkgconfig.bbclass will use a similar trick to fix them
-
-do_stage_prepend() {
- sed -i -e 's:=@libdir@:=${libdir}:;' \
- -e 's:=@includedir@:=${includedir}:;' \
- -e 's:=@prefix@:=${prefix}:' \
- -e 's:=@exec_prefix@:=${exec_prefix}:' \
- -e 's:-lpng12:-lpng12\ -lz\ -lm:' \
- libpng.pc
-
-}
+inherit autotools binconfig pkgconfig
do_stage() {
cp libpng.pc libpng12.pc
install -m 644 png.h ${STAGING_INCDIR}/png.h
install -m 644 pngconf.h ${STAGING_INCDIR}/pngconf.h
+ oe_libinstall -so libpng ${STAGING_LIBDIR}/
oe_libinstall -so libpng12 ${STAGING_LIBDIR}/
ln -sf libpng12.so ${STAGING_LIBDIR}/libpng.so
}