aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux-libc-headers
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2005-09-19 11:58:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-19 11:58:33 +0000
commit06926d0f7b737204ff8f31d8551d72e223ce4a78 (patch)
treed1e7924612073550eabda8e7b7af4056e8a0d3cf /packages/linux-libc-headers
parent84bbf466b67cdfb80784e9eac2a3a793c1e1b163 (diff)
downloadopenembedded-06926d0f7b737204ff8f31d8551d72e223ce4a78.tar.gz
packages/linux-libc-headers:
-Use a more compatible command-line argument. -a is compatible to -dpR and -d is the same as -P and -P exist on FreeBSD
Diffstat (limited to 'packages/linux-libc-headers')
-rw-r--r--packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb6
-rw-r--r--packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb6
-rw-r--r--packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb6
3 files changed, 9 insertions, 9 deletions
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
index c7d6367c7b..65e3f8b25b 100644
--- a/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
+++ b/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
@@ -36,11 +36,11 @@ do_configure () {
if test ! -e include/asm-$ARCH; then
oefatal unable to create asm symlink in kernel headers
fi
- cp -a "include/asm-$ARCH" "include/asm"
+ cp -pPR "include/asm-$ARCH" "include/asm"
if test "$ARCH" = "arm"; then
- cp -a include/asm/arch-ebsa285 include/asm/arch
+ cp -pPR include/asm/arch-ebsa285 include/asm/arch
elif test "$ARCH" = "sh"; then
- cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
+ cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
fi
}
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
index f881d38a34..6a9d81916e 100644
--- a/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
+++ b/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
@@ -32,11 +32,11 @@ do_configure () {
if test ! -e include/asm-$ARCH; then
oefatal unable to create asm symlink in kernel headers
fi
- cp -a "include/asm-$ARCH" "include/asm"
+ cp -pPR "include/asm-$ARCH" "include/asm"
if test "$ARCH" = "arm"; then
- cp -a include/asm/arch-ebsa285 include/asm/arch
+ cp -pPR include/asm/arch-ebsa285 include/asm/arch
elif test "$ARCH" = "sh"; then
- cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
+ cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
fi
}
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
index c127e8a9e7..9e72bc4b25 100644
--- a/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
+++ b/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
@@ -40,11 +40,11 @@ do_configure () {
if test ! -e include/asm-$ARCH; then
oefatal unable to create asm symlink in kernel headers
fi
- cp -a "include/asm-$ARCH" "include/asm"
+ cp -pPR "include/asm-$ARCH" "include/asm"
if test "$ARCH" = "arm"; then
- cp -a include/asm/arch-ebsa285 include/asm/arch
+ cp -pPR include/asm/arch-ebsa285 include/asm/arch
elif test "$ARCH" = "sh"; then
- cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
+ cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
fi
}