aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/ixp4xx-kernel.inc
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-16 10:13:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-16 10:13:55 +0000
commit2b9be5e324beee66740c311c67c660f544b8497d (patch)
tree6439ae8d48b84142b7d33a0290fe74a305185327 /packages/linux/ixp4xx-kernel.inc
parentf2cfb2628d56ad31d4fe97a08b1012c252109b90 (diff)
downloadopenembedded-2b9be5e324beee66740c311c67c660f544b8497d.tar.gz
ixp4xx-kernel: fix boot setup parameters in 2.6.15
- there is now a default machine-specific command line and an override for the memory config to provide a useable default per-machine.
Diffstat (limited to 'packages/linux/ixp4xx-kernel.inc')
-rw-r--r--packages/linux/ixp4xx-kernel.inc24
1 files changed, 6 insertions, 18 deletions
diff --git a/packages/linux/ixp4xx-kernel.inc b/packages/linux/ixp4xx-kernel.inc
index 0f3717c7d3..a0e149623e 100644
--- a/packages/linux/ixp4xx-kernel.inc
+++ b/packages/linux/ixp4xx-kernel.inc
@@ -155,31 +155,19 @@ ARCH = "arm"
KERNEL_IMAGETYPE = "zImage"
# To specify the console set KERNEL_CONSOLE in the .bb file.
-# CMDLINE_ROOT contains the boot options, CMDLINE_KERNEL_OPTIONS
-# contains the things for a specific kernel.
-#
-# These are set from MACHINE specific defaults below, but an override
-# in local.conf will still take precedence.
-#
-# CMDLINE_KERNEL_OPTIONS: overridable in local.conf
-# MACH_KERNEL_OPTIONS: the default, added to so additional stuff can be
-# put in from local.conf etc.
-MACH_KERNEL_OPTIONS += "rtc-x1205.probe=0,0x6f rtc-x1205.hctosys=1"
-MACH_KERNEL_OPTIONS += "rtc-ds1672.probe=0,0x68 rtc-ds1672.hctosys=1"
-MACH_KERNEL_OPTIONS += "pcf8563.hctosys=1"
-#
-CMDLINE_KERNEL_OPTIONS ?= "${MACH_KERNEL_OPTIONS}"
+# CMDLINE_ROOT contains the boot options, these will be
+# appended to the build in boot options (so it is only necessary
+# to override stuff in the kernel source).
# CMDLINE_ROOT: machine specific boot options - should not be set on a
# generic kernel!
-#FIXME: this is to make NSLU2 work (temporary!)
-CMDLINE_ROOT ?= "root=/dev/mtdblock4 rootfstype=jffs2 init=/linuxrc mem=32M"
-#CMDLINE_ROOT ?= "mem=32M"
+CMDLINE_ROOT ?= ""
# CMDLINE_DEBUG: debug options such as noirqdebug, defaults to empty
# override in local.conf etc
CMDLINE_DEBUG ?= ""
-CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_KERNEL_OPTIONS} ${CMDLINE_DEBUG} ${CMDLINE_CONSOLE}"
+
+CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_DEBUG} ${CMDLINE_CONSOLE}"
# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
# required. Notice that this has to be done for each separately built