aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mysql
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-12-21 16:47:12 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-12-21 16:47:12 +0000
commitdbd1d69358e8ad34bae632f8fff266f21d4440c3 (patch)
treec5dd46204a3038a1ec82fdb931b3aeb7f0a2288c /packages/mysql
parentfd021ba0bcb90b524ede0384973cb3571311b5d2 (diff)
downloadopenembedded-dbd1d69358e8ad34bae632f8fff266f21d4440c3.tar.gz
mysql: update to 4.1.16 - close #485
- dropped 4.1.10a, 4.1.12 - removed MAINTAINER field
Diffstat (limited to 'packages/mysql')
-rw-r--r--packages/mysql/mysql-4.1.10a/autofoo.patch323
-rw-r--r--packages/mysql/mysql-4.1.10a/gen_lex_hash.patch21
-rw-r--r--packages/mysql/mysql-4.1.12/.mtn2git_empty0
-rw-r--r--packages/mysql/mysql-4.1.16/.mtn2git_empty (renamed from packages/mysql/mysql-4.1.10a/.mtn2git_empty)0
-rw-r--r--packages/mysql/mysql-4.1.16/autofoo.patch (renamed from packages/mysql/mysql-4.1.12/autofoo.patch)40
-rw-r--r--packages/mysql/mysql-4.1.16/gen_lex_hash.patch19
-rw-r--r--packages/mysql/mysql-native_4.1.10a.bb17
-rw-r--r--packages/mysql/mysql-native_4.1.16.bb (renamed from packages/mysql/mysql-native_4.1.12.bb)0
-rw-r--r--packages/mysql/mysql_4.1.10a.bb34
-rw-r--r--packages/mysql/mysql_4.1.16.bb (renamed from packages/mysql/mysql_4.1.12.bb)8
10 files changed, 40 insertions, 422 deletions
diff --git a/packages/mysql/mysql-4.1.10a/autofoo.patch b/packages/mysql/mysql-4.1.10a/autofoo.patch
deleted file mode 100644
index 3ebb133b4d..0000000000
--- a/packages/mysql/mysql-4.1.10a/autofoo.patch
+++ /dev/null
@@ -1,323 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: mysql-4.1.10a/acinclude.m4
-===================================================================
---- mysql-4.1.10a.orig/acinclude.m4 2005-03-12 17:51:18.685178808 -0500
-+++ mysql-4.1.10a/acinclude.m4 2005-03-12 17:51:18.955137768 -0500
-@@ -1,5 +1,88 @@
- # Local macros for automake & autoconf
-
-+AH_TEMPLATE([SPRINTF_RETURNS_INT], [sprintf returns an int])
-+AH_TEMPLATE([SPRINTF_RETURNS_PTR], [sprintf returns a char *])
-+AH_TEMPLATE([SPRINTF_RETURNS_GARBAGE], [sprintf returns something unknown to us])
-+
-+AC_DEFUN([MYSQL_SPRINTF_RET], [
-+ AC_CACHE_CHECK([return type of sprintf],
-+ [mysql_cv_func_sprintf_ret], [
-+ old_CFLAGS="$CFLAGS"
-+ CFLAGS="$CFLAGS -Werror"
-+ AC_COMPILE_IFELSE([
-+#include <stdio.h>
-+int sprintf(char *str, const char *format, ...);
-+ ], [mysql_cv_func_sprintf_ret=int],
-+ AC_COMPILE_IFELSE([
-+#include <stdio.h>
-+char * sprintf(char *str, const char *format, ...);
-+ ], [mysql_cv_func_sprintf_ret=ptr],
-+ [mysql_cv_func_sprintf_ret=unknown])
-+ )
-+ CFLAGS="$old_CFLAGS"
-+ ])
-+ if test x"$mysql_cv_func_sprintf_ret" = "xint"; then
-+ AC_DEFINE([SPRINTF_RETURNS_INT], [1])
-+ elif test x"$mysql_cv_func_sprintf_ret" = "xptr"; then
-+ AC_DEFINE([SPRINTF_RETURNS_PTR], [1])
-+ else
-+ AC_DEFINE([SPRINTF_RETURNS_GARBAGE], [1])
-+ fi
-+])
-+
-+# _MYSQL_FUNC_ATOMIC_ADD
-+# ----------------------
-+# Check for Linux specific atomic_add function
-+AC_DEFUN([_MYSQL_FUNC_ATOMIC_ADD],
-+[AC_CACHE_CHECK([for atomic_add], [mysql_cv_func_atomic_add],
-+[AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <asm/atomic.h>]],
-+ [
-+int main()
-+{
-+ atomic_t v;
-+
-+ atomic_set(&v, 23);
-+ atomic_add(5, &v);
-+ return atomic_read(&v) == 28 ? 0 : -1;
-+}
-+ ])],
-+ [mysql_cv_func_atomic_add=yes],
-+ [mysql_cv_func_atomic_add=no])])
-+ if test x"$mysql_func_atomic_add" = "xyes"; then
-+ AC_DEFINE([HAVE_ATOMIC_ADD], [1])
-+ fi[]dnl
-+])# _MYSQL_FUNC_ATOMIC_ADD
-+
-+# _MYSQL_FUNC_ATOMIC_SUB
-+# ----------------------
-+# Check for Linux specific atomic_sub function
-+AC_DEFUN([_MYSQL_FUNC_ATOMIC_SUB],
-+[AC_CACHE_CHECK([for atomic_sub], [mysql_cv_func_atomic_sub],
-+[AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <asm/atomic.h>]],
-+ [
-+int main()
-+{
-+ atomic_t v;
-+
-+ atomic_set(&v, 23);
-+ atomic_sub(5, &v);
-+ return atomic_read(&v) == 18 ? 0 : -1;
-+}
-+ ])],
-+ [mysql_cv_func_atomic_sub=yes],
-+ [mysql_cv_func_atomic_sub=no])])
-+ if test x"$mysql_func_atomic_sub" = "xyes"; then
-+ AC_DEFINE([HAVE_ATOMIC_SUB], [1])
-+ fi[]dnl
-+])# _MYSQL_FUNC_ATOMIC_SUB
-+
-+# MYSQL_FUNCS_ATOMIC
-+# ------------------
-+# Check for Linux specific atomic add and sub functions
-+AC_DEFUN([MYSQL_FUNCS_ATOMIC], [
-+ AC_REQUIRE([_MYSQL_FUNC_ATOMIC_ADD])dnl
-+ AC_REQUIRE([_MYSQL_FUNC_ATOMIC_SUB])dnl
-+])# MYSQL_FUNCS_ATOMIC
-
- AC_DEFUN([MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY], [
- AC_CACHE_CHECK([HIST_ENTRY is declared in readline/readline.h], mysql_cv_hist_entry_declared,
-@@ -310,7 +393,7 @@
- AC_DEFUN([MYSQL_CHECK_ULONG],
- [AC_MSG_CHECKING(for type ulong)
- AC_CACHE_VAL(ac_cv_ulong,
--[AC_TRY_RUN([#include <stdio.h>
-+[AC_TRY_LINK([#include <stdio.h>
- #include <sys/types.h>
- main()
- {
-@@ -328,7 +411,7 @@
- AC_DEFUN([MYSQL_CHECK_UCHAR],
- [AC_MSG_CHECKING(for type uchar)
- AC_CACHE_VAL(ac_cv_uchar,
--[AC_TRY_RUN([#include <stdio.h>
-+[AC_TRY_LINK([#include <stdio.h>
- #include <sys/types.h>
- main()
- {
-@@ -346,7 +429,7 @@
- AC_DEFUN([MYSQL_CHECK_UINT],
- [AC_MSG_CHECKING(for type uint)
- AC_CACHE_VAL(ac_cv_uint,
--[AC_TRY_RUN([#include <stdio.h>
-+[AC_TRY_LINK([#include <stdio.h>
- #include <sys/types.h>
- main()
- {
-@@ -365,7 +448,7 @@
- AC_DEFUN([MYSQL_CHECK_IN_ADDR_T],
- [AC_MSG_CHECKING(for type in_addr_t)
- AC_CACHE_VAL(ac_cv_in_addr_t,
--[AC_TRY_RUN([#include <stdio.h>
-+[AC_TRY_LINK([#include <stdio.h>
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-@@ -426,7 +509,7 @@
- AC_DEFUN([MYSQL_CHECK_FP_EXCEPT],
- [AC_MSG_CHECKING(for type fp_except)
- AC_CACHE_VAL(ac_cv_fp_except,
--[AC_TRY_RUN([#include <stdio.h>
-+[AC_TRY_LINK([#include <stdio.h>
- #include <sys/types.h>
- #include <ieeefp.h>
- main()
-Index: mysql-4.1.10a/configure.in
-===================================================================
---- mysql-4.1.10a.orig/configure.in 2005-03-12 17:51:18.685178808 -0500
-+++ mysql-4.1.10a/configure.in 2005-03-12 17:51:18.957137464 -0500
-@@ -212,8 +212,6 @@
- else
- AC_PATH_PROG(AS, as, as)
- fi
--# Still need ranlib for readline; local static use only so no libtool.
--AC_PROG_RANLIB
- # We use libtool
- #AC_LIBTOOL_WIN32_DLL
- AC_PROG_LIBTOOL
-@@ -234,44 +232,7 @@
- AC_CHECK_PROG(PDFMANUAL, pdftex, manual.pdf)
- AC_CHECK_PROG(DVIS, tex, manual.dvi)
-
--AC_MSG_CHECKING("return type of sprintf")
--
--#check the return type of sprintf
--case $SYSTEM_TYPE in
-- *netware*)
-- AC_DEFINE(SPRINTF_RETURNS_INT, [1]) AC_MSG_RESULT("int")
-- ;;
-- *)
--AC_TRY_RUN([
-- int main()
-- {
-- char* s = "hello";
-- char buf[6];
-- if((int)sprintf(buf, s) == strlen(s))
-- return 0;
--
-- return -1;
-- }
-- ],
-- [AC_DEFINE(SPRINTF_RETURNS_INT, [1], [POSIX sprintf])
-- AC_MSG_RESULT("int")],
-- [AC_TRY_RUN([
-- int main()
-- {
-- char* s = "hello";
-- char buf[6];
-- if((char*)sprintf(buf,s) == buf + strlen(s))
-- return 0;
-- return -1;
-- } ],
-- [AC_DEFINE(SPRINTF_RETURNS_PTR, [1], [Broken sprintf])
-- AC_MSG_RESULT("ptr")],
-- [AC_DEFINE(SPRINTF_RETURNS_GARBAGE, [1], [Broken sprintf])
-- AC_MSG_RESULT("garbage")])
-- ])
-- ;;
--esac
--
-+MYSQL_SPRINTF_RET
-
- # option, cache_name, variable,
- # code to execute if yes, code to exectute if fail
-@@ -842,42 +803,7 @@
- AC_SUBST(WRAPLIBS)
-
- if test "$IS_LINUX" = "true"; then
-- AC_MSG_CHECKING([for atomic operations])
--
-- atom_ops=
-- AC_TRY_RUN([
--#include <asm/atomic.h>
--int main()
--{
-- atomic_t v;
--
-- atomic_set(&v, 23);
-- atomic_add(5, &v);
-- return atomic_read(&v) == 28 ? 0 : -1;
--}
-- ],
-- [AC_DEFINE([HAVE_ATOMIC_ADD], [1],
-- [atomic_add() from <asm/atomic.h> (Linux only)])
-- atom_ops="${atom_ops}atomic_add "],
-- )
-- AC_TRY_RUN([
--#include <asm/atomic.h>
--int main()
--{
-- atomic_t v;
--
-- atomic_set(&v, 23);
-- atomic_sub(5, &v);
-- return atomic_read(&v) == 18 ? 0 : -1;
--}
-- ],
-- [AC_DEFINE([HAVE_ATOMIC_SUB], [1],
-- [atomic_sub() from <asm/atomic.h> (Linux only)])
-- atom_ops="${atom_ops}atomic_sub "],
-- )
--
-- if test -z "$atom_ops"; then atom_ops="no"; fi
-- AC_MSG_RESULT($atom_ops)
-+ MYSQL_FUNCS_ATOMIC
-
- AC_ARG_WITH(pstack,
- [ --with-pstack Use the pstack backtrace library],
-@@ -930,13 +856,13 @@
- # Later in this script LIBS will be augmented with a threads library.
- NON_THREADED_LIBS="$LIBS"
-
--AC_MSG_CHECKING([for int8])
-+AC_CACHE_CHECK([for int8], [mysql_cv_type_int8], [
- case $SYSTEM_TYPE in
- *netware)
-- AC_MSG_RESULT([no])
-+ mysql_cv_type_int8=no
- ;;
- *)
--AC_TRY_RUN([
-+AC_LINK_IFELSE([AC_LANG_PROGRAM([[
- #ifdef HAVE_STDLIB_H
- #include <stdlib.h>
- #endif
-@@ -947,22 +873,21 @@
-
- #ifdef HAVE_SYS_TYPES_H
- #include <sys/types.h>
--#endif
--
-+#endif]], [
- int main()
- {
- int8 i;
- return 0;
--}
--],
--[AC_DEFINE([HAVE_INT_8_16_32], [1],
-- [whether int8, int16 and int32 types exist])
--AC_MSG_RESULT([yes])],
--[AC_MSG_RESULT([no])]
--)
-+}])], [mysql_cv_type_int8=yes], [mysql_cv_type_int8=no])
- ;;
- esac
-
-+if test x"$mysql_cv_type_int8" = "xyes"; then
-+ AC_DEFINE([HAVE_INT_8_16_32], [1],
-+ [whether int8, int16 and int32 types exist])
-+fi
-+])
-+
- #
- # Some system specific hacks
- #
-@@ -1783,7 +1708,7 @@
- AC_MSG_ERROR("MySQL needs a long long type.")
- fi
- # off_t is not a builtin type
--MYSQL_CHECK_SIZEOF(off_t, 4)
-+AC_CHECK_SIZEOF(off_t, 4)
- if test "$ac_cv_sizeof_off_t" -eq 0
- then
- AC_MSG_ERROR("MySQL needs a off_t type.")
-Index: mysql-4.1.10a/innobase/configure.in
-===================================================================
---- mysql-4.1.10a.orig/innobase/configure.in 2005-03-12 17:51:18.685178808 -0500
-+++ mysql-4.1.10a/innobase/configure.in 2005-03-12 17:52:45.208025336 -0500
-@@ -3,6 +3,7 @@
- AC_CANONICAL_SYSTEM
- AM_MAINTAINER_MODE
- AM_CONFIG_HEADER(ib_config.h)
-+AC_CONFIG_AUX_DIR([..])
- AM_INIT_AUTOMAKE(ib, 0.90)
-
- # This is need before AC_PROG_CC
-@@ -32,7 +33,6 @@
- CXXFLAGS="$CXXFLAGS "
-
- AC_PROG_CC
--AC_PROG_RANLIB
- AC_PROG_INSTALL
- AC_PROG_LIBTOOL
- AC_CHECK_HEADERS(aio.h sched.h)
diff --git a/packages/mysql/mysql-4.1.10a/gen_lex_hash.patch b/packages/mysql/mysql-4.1.10a/gen_lex_hash.patch
deleted file mode 100644
index 27bfc0f6a3..0000000000
--- a/packages/mysql/mysql-4.1.10a/gen_lex_hash.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- mysql-4.1.4a-gamma/sql/Makefile.am~gen_lex_hash
-+++ mysql-4.1.4a-gamma/sql/Makefile.am
-@@ -140,9 +140,10 @@
- @echo "If it fails, re-run configure with --with-low-memory"
- $(CXXCOMPILE) $(LM_CFLAGS) -c $<
-
--lex_hash.h: lex.h gen_lex_hash.cc sql_yacc.h
-- $(MAKE) gen_lex_hash$(EXEEXT)
-- ./gen_lex_hash$(EXEEXT) > $@
-+GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
-+
-+lex_hash.h: lex.h gen_lex_hash$(EXEEXT) sql_yacc.h
-+ $(GEN_LEX_HASH) > $@ || rm -f $@
-
- # Hack to ensure that lex_hash.h is built early
- sql_lex.o: lex_hash.h
diff --git a/packages/mysql/mysql-4.1.12/.mtn2git_empty b/packages/mysql/mysql-4.1.12/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/mysql/mysql-4.1.12/.mtn2git_empty
+++ /dev/null
diff --git a/packages/mysql/mysql-4.1.10a/.mtn2git_empty b/packages/mysql/mysql-4.1.16/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/mysql/mysql-4.1.10a/.mtn2git_empty
+++ b/packages/mysql/mysql-4.1.16/.mtn2git_empty
diff --git a/packages/mysql/mysql-4.1.12/autofoo.patch b/packages/mysql/mysql-4.1.16/autofoo.patch
index 3458e3ccf0..f2d5354572 100644
--- a/packages/mysql/mysql-4.1.12/autofoo.patch
+++ b/packages/mysql/mysql-4.1.16/autofoo.patch
@@ -3,10 +3,8 @@
# Patch managed by http://www.holgerschurig.de/patcher.html
#
-Index: mysql-4.1.10a/acinclude.m4
-===================================================================
---- mysql-4.1.10a.orig/acinclude.m4 2005-03-12 17:51:18.685178808 -0500
-+++ mysql-4.1.10a/acinclude.m4 2005-03-12 17:51:18.955137768 -0500
+--- mysql-4.1.15/acinclude.m4~autofoo
++++ mysql-4.1.15/acinclude.m4
@@ -1,5 +1,88 @@
# Local macros for automake & autoconf
@@ -96,7 +94,7 @@ Index: mysql-4.1.10a/acinclude.m4
AC_DEFUN([MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY], [
AC_CACHE_CHECK([HIST_ENTRY is declared in readline/readline.h], mysql_cv_hist_entry_declared,
-@@ -310,7 +393,7 @@
+@@ -340,7 +423,7 @@
AC_DEFUN([MYSQL_CHECK_ULONG],
[AC_MSG_CHECKING(for type ulong)
AC_CACHE_VAL(ac_cv_ulong,
@@ -105,7 +103,7 @@ Index: mysql-4.1.10a/acinclude.m4
#include <sys/types.h>
main()
{
-@@ -328,7 +411,7 @@
+@@ -358,7 +441,7 @@
AC_DEFUN([MYSQL_CHECK_UCHAR],
[AC_MSG_CHECKING(for type uchar)
AC_CACHE_VAL(ac_cv_uchar,
@@ -114,7 +112,7 @@ Index: mysql-4.1.10a/acinclude.m4
#include <sys/types.h>
main()
{
-@@ -346,7 +429,7 @@
+@@ -376,7 +459,7 @@
AC_DEFUN([MYSQL_CHECK_UINT],
[AC_MSG_CHECKING(for type uint)
AC_CACHE_VAL(ac_cv_uint,
@@ -123,7 +121,7 @@ Index: mysql-4.1.10a/acinclude.m4
#include <sys/types.h>
main()
{
-@@ -365,7 +448,7 @@
+@@ -395,7 +478,7 @@
AC_DEFUN([MYSQL_CHECK_IN_ADDR_T],
[AC_MSG_CHECKING(for type in_addr_t)
AC_CACHE_VAL(ac_cv_in_addr_t,
@@ -132,7 +130,7 @@ Index: mysql-4.1.10a/acinclude.m4
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
-@@ -426,7 +509,7 @@
+@@ -456,7 +539,7 @@
AC_DEFUN([MYSQL_CHECK_FP_EXCEPT],
[AC_MSG_CHECKING(for type fp_except)
AC_CACHE_VAL(ac_cv_fp_except,
@@ -141,11 +139,9 @@ Index: mysql-4.1.10a/acinclude.m4
#include <sys/types.h>
#include <ieeefp.h>
main()
-Index: mysql-4.1.10a/configure.in
-===================================================================
---- mysql-4.1.10a.orig/configure.in 2005-03-12 17:51:18.685178808 -0500
-+++ mysql-4.1.10a/configure.in 2005-03-12 17:51:18.957137464 -0500
-@@ -212,8 +212,6 @@
+--- mysql-4.1.15/configure.in~autofoo
++++ mysql-4.1.15/configure.in
+@@ -234,8 +234,6 @@
else
AC_PATH_PROG(AS, as, as)
fi
@@ -154,7 +150,7 @@ Index: mysql-4.1.10a/configure.in
# We use libtool
#AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
-@@ -234,44 +232,7 @@
+@@ -256,44 +254,7 @@
AC_CHECK_PROG(PDFMANUAL, pdftex, manual.pdf)
AC_CHECK_PROG(DVIS, tex, manual.dvi)
@@ -200,7 +196,7 @@ Index: mysql-4.1.10a/configure.in
# option, cache_name, variable,
# code to execute if yes, code to exectute if fail
-@@ -842,42 +803,7 @@
+@@ -870,42 +831,7 @@
AC_SUBST(WRAPLIBS)
if test "$TARGET_LINUX" = "true"; then
@@ -244,7 +240,7 @@ Index: mysql-4.1.10a/configure.in
AC_ARG_WITH(pstack,
[ --with-pstack Use the pstack backtrace library],
-@@ -930,13 +856,13 @@
+@@ -958,13 +884,13 @@
# Later in this script LIBS will be augmented with a threads library.
NON_THREADED_LIBS="$LIBS"
@@ -261,7 +257,7 @@ Index: mysql-4.1.10a/configure.in
#ifdef HAVE_STDLIB_H
#include <stdlib.h>
#endif
-@@ -947,22 +873,21 @@
+@@ -975,22 +901,21 @@
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
@@ -292,7 +288,7 @@ Index: mysql-4.1.10a/configure.in
#
# Some system specific hacks
#
-@@ -1783,7 +1708,7 @@
+@@ -1798,7 +1723,7 @@
AC_MSG_ERROR("MySQL needs a long long type.")
fi
# off_t is not a builtin type
@@ -301,10 +297,8 @@ Index: mysql-4.1.10a/configure.in
if test "$ac_cv_sizeof_off_t" -eq 0
then
AC_MSG_ERROR("MySQL needs a off_t type.")
-Index: mysql-4.1.10a/innobase/configure.in
-===================================================================
---- mysql-4.1.10a.orig/innobase/configure.in 2005-03-12 17:51:18.685178808 -0500
-+++ mysql-4.1.10a/innobase/configure.in 2005-03-12 17:52:45.208025336 -0500
+--- mysql-4.1.15/innobase/configure.in~autofoo
++++ mysql-4.1.15/innobase/configure.in
@@ -3,6 +3,7 @@
AC_CANONICAL_SYSTEM
AM_MAINTAINER_MODE
diff --git a/packages/mysql/mysql-4.1.16/gen_lex_hash.patch b/packages/mysql/mysql-4.1.16/gen_lex_hash.patch
new file mode 100644
index 0000000000..c398d048dc
--- /dev/null
+++ b/packages/mysql/mysql-4.1.16/gen_lex_hash.patch
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- mysql-4.1.15/sql/Makefile.am~gen_lexhash
++++ mysql-4.1.15/sql/Makefile.am
+@@ -137,8 +137,10 @@
+ @echo "If it fails, re-run configure with --with-low-memory"
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
++GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
++
+ lex_hash.h: gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@
++ $(GEN_LEX_HASH) > $@
+
+ # For testing of udf_example.so; Works on platforms with gcc
+ # (This is not part of our build process but only provided as an example)
diff --git a/packages/mysql/mysql-native_4.1.10a.bb b/packages/mysql/mysql-native_4.1.10a.bb
deleted file mode 100644
index f3b1b0e1ae..0000000000
--- a/packages/mysql/mysql-native_4.1.10a.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SECTION = "console/network"
-include mysql_${PV}.bb
-inherit native
-
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/mysql-${PV}', '${FILE_DIRNAME}/mysql-4.1', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-PACKAGES = ""
-DEPENDS = "ncurses-native"
-EXTRA_OEMAKE = ""
-EXTRA_OECONF = " --with-embedded-server "
-
-do_stage() {
- install -m 0755 sql/gen_lex_hash ${STAGING_BINDIR}/
-}
-
-do_install() {
- :
-}
diff --git a/packages/mysql/mysql-native_4.1.12.bb b/packages/mysql/mysql-native_4.1.16.bb
index c871a8f9da..c871a8f9da 100644
--- a/packages/mysql/mysql-native_4.1.12.bb
+++ b/packages/mysql/mysql-native_4.1.16.bb
diff --git a/packages/mysql/mysql_4.1.10a.bb b/packages/mysql/mysql_4.1.10a.bb
deleted file mode 100644
index 0edbe0913f..0000000000
--- a/packages/mysql/mysql_4.1.10a.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-DESCRIPTION = "The MySQL Open Source Database System"
-MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
-SECTION = "libs"
-DEPENDS += "ncurses mysql-native"
-PR = "r4"
-LICENSE = "GPL"
-SRC_URI = "http://mirrors.develooper.com/mysql/Downloads/MySQL-4.1/mysql-${PV}.tar.gz \
- file://autofoo.patch;patch=1 \
- file://gen_lex_hash.patch;patch=1"
-S = "${WORKDIR}/mysql-${PV}"
-
-inherit autotools
-
-EXTRA_OEMAKE = "'GEN_LEX_HASH=${STAGING_BINDIR}/gen_lex_hash'"
-EXTRA_OECONF = " --with-embedded-server "
-
-do_stage() {
- autotools_stage_includes
- oe_libinstall -a -so -C libmysql libmysqlclient ${STAGING_LIBDIR}
- oe_libinstall -a -C libmysqld libmysqld ${STAGING_LIBDIR}
-}
-
-do_install() {
- oe_runmake 'DESTDIR=${D}' install
- mv -f ${D}${libdir}/mysql/* ${D}${libdir}
- rmdir ${D}${libdir}/mysql
-}
-
-PACKAGES =+ "libmysqlclient libmysqlclient-dev"
-
-FILES_libmysqlclient = "${libdir}/libmysqlclient*.so.*"
-FILES_libmysqlclient-dev = "${incdir}/mysql ${libdir}/lib* \
- ${bindir}/mysql_config"
-
diff --git a/packages/mysql/mysql_4.1.12.bb b/packages/mysql/mysql_4.1.16.bb
index 9d1754608f..fe8c42dd88 100644
--- a/packages/mysql/mysql_4.1.12.bb
+++ b/packages/mysql/mysql_4.1.16.bb
@@ -1,15 +1,15 @@
DESCRIPTION = "The MySQL Open Source Database System"
-MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
SECTION = "libs"
DEPENDS += "ncurses mysql-native"
-PR = "r4"
LICENSE = "GPL"
+
SRC_URI = "http://mirrors.develooper.com/mysql/Downloads/MySQL-4.1/mysql-${PV}.tar.gz \
file://autofoo.patch;patch=1 \
- file://gen_lex_hash.patch;patch=1"
+ file://gen_lex_hash.patch;patch=1"
+
S = "${WORKDIR}/mysql-${PV}"
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/mysql-${PV}', '${FILE_DIRNAME}/mysql-4.1.10a', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/mysql-${PV}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
BINCONFIG_GLOB = "mysql_config"
inherit autotools binconfig