aboutsummaryrefslogtreecommitdiffstats
path: root/packages/opie-unikeyboard
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-02-02 22:07:05 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-02-02 22:07:05 +0000
commit73ef7b5c0de85525c666e4cb8e0421bae4ec147e (patch)
tree6ab35cf3505f2ae8069386dd705f8a00f23d8265 /packages/opie-unikeyboard
parent7b57ac2ec7359b00a7ab046a40ab037cb90177c2 (diff)
downloadopenembedded-73ef7b5c0de85525c666e4cb8e0421bae4ec147e.tar.gz
compute TAG line in opie.bbclass instead of in (all) opie files
BKrev: 42014f09KAfHSQPBUOyP1omr2yGkzA
Diffstat (limited to 'packages/opie-unikeyboard')
-rw-r--r--packages/opie-unikeyboard/opie-unikeyboard_1.1.9.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/opie-unikeyboard/opie-unikeyboard_1.1.9.bb b/packages/opie-unikeyboard/opie-unikeyboard_1.1.9.bb
index e69de29bb2..d2553d6035 100644
--- a/packages/opie-unikeyboard/opie-unikeyboard_1.1.9.bb
+++ b/packages/opie-unikeyboard/opie-unikeyboard_1.1.9.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Unicode input method"
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+MAINTAINER = "Team Opie <opie@handhelds.org>"
+LICENSE = "GPL"
+
+APPNAME = "qunikeyboard"
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/inputmethods/unikeyboard "
+
+S = "${WORKDIR}/unikeyboard"
+
+inherit opie
+
+pkg_postinst() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+if pidof -s qpe >/dev/null; then
+ /opt/QtPalmtop/bin/qcop QPE/TaskBar "reloadApplets()"
+else
+ exit 0
+fi
+}
+
+pkg_postrm() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+/opt/QtPalmtop/bin/qcop QPE/TaskBar "reloadInputMethods()"
+}
+
+# FILES plugins/inputmethods/libqunikeyboard.so*
+do_install() {
+}
+