aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-08-05 10:28:21 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-08-05 10:28:21 +0000
commite9de7a29dfc59a02a854ee89b8e3b1e897a83792 (patch)
tree1ced7ed5aac9f3a0e6da009bbd2c92a90ca14d04 /packages/python
parenta9b96c7308bcb4bfaf5d1fba983375d54f4b386f (diff)
downloadopenembedded-e9de7a29dfc59a02a854ee89b8e3b1e897a83792.tar.gz
python-native 2.4.0 don't modify first shebang line when installing packages via distutils. closes #1271
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-native-2.4.0/dont-modify-shebang-line.patch16
-rw-r--r--packages/python/python-native_2.4.0.bb10
2 files changed, 22 insertions, 4 deletions
diff --git a/packages/python/python-native-2.4.0/dont-modify-shebang-line.patch b/packages/python/python-native-2.4.0/dont-modify-shebang-line.patch
new file mode 100644
index 0000000000..54109afd62
--- /dev/null
+++ b/packages/python/python-native-2.4.0/dont-modify-shebang-line.patch
@@ -0,0 +1,16 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- Python-2.4/Lib/distutils/command/build_scripts.py~dont-modify-shebang-line
++++ Python-2.4/Lib/distutils/command/build_scripts.py
+@@ -87,7 +87,7 @@
+ continue
+
+ match = first_line_re.match(first_line)
+- if match:
++ if False: #match:
+ adjust = 1
+ post_interp = match.group(1) or ''
+
diff --git a/packages/python/python-native_2.4.0.bb b/packages/python/python-native_2.4.0.bb
index 00092d1e15..4f5db82569 100644
--- a/packages/python/python-native_2.4.0.bb
+++ b/packages/python/python-native_2.4.0.bb
@@ -5,13 +5,14 @@ SECTION = "devel/python"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = ""
-PR = "r0"
+PR = "r1"
EXCLUDE_FROM_WORLD = "1"
SRC_URI = "http://www.python.org/ftp/python/2.4/Python-2.4.tar.bz2 \
- file://bindir-libdir.patch;patch=1 \
- file://cross-distutils.patch;patch=1"
+ file://bindir-libdir.patch;patch=1 \
+ file://cross-distutils.patch;patch=1 \
+ file://dont-modify-shebang-line.patch;patch=1"
S = "${WORKDIR}/Python-2.4"
inherit autotools native
@@ -20,7 +21,8 @@ EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc --without-cxx --
--with-prefix=${STAGING_DIR} --with-exec-prefix=${STAGING_DIR}/${BUILD_SYS}"
EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
-do_configure () {
+do_configure() {
+ # the autofoo stuff is too old to allow regenerating
oe_runconf
}