aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tcltk
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-16 14:35:51 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-16 14:35:51 +0000
commit256e671e1944961ca4e19c13684cec34da1966bf (patch)
treeb170d1e2bae0bf48f40e7a40caeda9ea89d7e06b /packages/tcltk
parent1dabe9686d98a903097219d046aa167595c9387a (diff)
downloadopenembedded-256e671e1944961ca4e19c13684cec34da1966bf.tar.gz
tcltk: apply patch to fix a bogus line in the configure scripts
bash 3.1 has a more strict syntax checking than 3.0, this is why it bailed out only on some boxes
Diffstat (limited to 'packages/tcltk')
-rw-r--r--packages/tcltk/tcl/.mtn2git_empty0
-rw-r--r--packages/tcltk/tcl/fix-configure.patch25
-rw-r--r--packages/tcltk/tcl_8.4.11.bb5
-rw-r--r--packages/tcltk/tk/.mtn2git_empty0
-rw-r--r--packages/tcltk/tk/fix-configure.patch16
-rw-r--r--packages/tcltk/tk_8.4.11.bb5
6 files changed, 47 insertions, 4 deletions
diff --git a/packages/tcltk/tcl/.mtn2git_empty b/packages/tcltk/tcl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tcltk/tcl/.mtn2git_empty
diff --git a/packages/tcltk/tcl/fix-configure.patch b/packages/tcltk/tcl/fix-configure.patch
new file mode 100644
index 0000000000..e37780352d
--- /dev/null
+++ b/packages/tcltk/tcl/fix-configure.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- tcl8.4.11/unix/configure~fix-configure
++++ tcl8.4.11/unix/configure
+@@ -2130,7 +2130,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print }' /etc/.relid'`
++ system=MP-RAS-`awk '{print }' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
+@@ -7608,7 +7608,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print }' /etc/.relid'`
++ system=MP-RAS-`awk '{print }' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
diff --git a/packages/tcltk/tcl_8.4.11.bb b/packages/tcltk/tcl_8.4.11.bb
index 0851cbd165..6dc5bb5365 100644
--- a/packages/tcltk/tcl_8.4.11.bb
+++ b/packages/tcltk/tcl_8.4.11.bb
@@ -2,10 +2,11 @@ DESCRIPTION = "Tool Command Language"
LICENSE = "tcl"
SECTION = "devel/tcltk"
HOMEPAGE = "http://tcl.sourceforge.net"
-PR = "r2"
+PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tcl${PV}-src.tar.gz \
- file://tcl-add-soname.patch;patch=1"
+ file://tcl-add-soname.patch;patch=1 \
+ file://fix-configure.patch;patch=1"
S = "${WORKDIR}/tcl${PV}/unix"
inherit autotools
diff --git a/packages/tcltk/tk/.mtn2git_empty b/packages/tcltk/tk/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tcltk/tk/.mtn2git_empty
diff --git a/packages/tcltk/tk/fix-configure.patch b/packages/tcltk/tk/fix-configure.patch
new file mode 100644
index 0000000000..6c6f0374bd
--- /dev/null
+++ b/packages/tcltk/tk/fix-configure.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- tk8.4.11/unix/configure~fix-configure
++++ tk8.4.11/unix/configure
+@@ -1849,7 +1849,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print }' /etc/.relid'`
++ system=MP-RAS-`awk '{print }' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
diff --git a/packages/tcltk/tk_8.4.11.bb b/packages/tcltk/tk_8.4.11.bb
index b993a4be03..7a66ddcafb 100644
--- a/packages/tcltk/tk_8.4.11.bb
+++ b/packages/tcltk/tk_8.4.11.bb
@@ -4,11 +4,12 @@ SECTION = "devel/tcltk"
HOMEPAGE = "http://tcl.sourceforge.net"
DEPENDS = "tcl libx11"
RDEPENDS = "tcl"
-PR = "r2"
+PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tk${PV}-src.tar.gz \
file://disable-xim.patch;patch=1;pnum=0 \
- file://tk-add-soname.patch;patch=1"
+ file://tk-add-soname.patch;patch=1 \
+ file://fix-configure.patch;patch=1"
S = "${WORKDIR}/tk${PV}/unix"
inherit autotools