aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uboot
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2006-08-10 22:39:22 +0000
committerPhilip Balister <philip@balister.org>2006-08-10 22:39:22 +0000
commitb0d728d444fca302a14672f02aaf7b9375690b6b (patch)
tree88da1b88f8800044fce7787cdf8155d57e8d96ce /packages/uboot
parentd9894509a7e38a1259feb1963388d6c22d2fe62a (diff)
downloadopenembedded-b0d728d444fca302a14672f02aaf7b9375690b6b.tar.gz
Add u-boot built from git repository. Source pulled from tag LABEL.2006.06.30.2020.
This version compiles with gcc4 and has some compilation fixes needed to build u-boot for the omap5912osk board.
Diffstat (limited to 'packages/uboot')
-rw-r--r--packages/uboot/u-boot_LABEL.2006.06.30.2020.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/uboot/u-boot_LABEL.2006.06.30.2020.bb b/packages/uboot/u-boot_LABEL.2006.06.30.2020.bb
new file mode 100644
index 0000000000..efe4addbb0
--- /dev/null
+++ b/packages/uboot/u-boot_LABEL.2006.06.30.2020.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "U-boot bootloader"
+PROVIDES = "virtual/bootloader"
+SECTION = "bootloader"
+MAINTAINER = "philip@balister.org"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r0"
+
+TAG = "${@bb.data.getVar('PV',d,1).replace('.', '_')}"
+
+SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git;tag=${TAG}"
+# file://config.patch;patch=1"
+
+S = "${WORKDIR}/git"
+
+#EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CFLAGS="" CPPFLAGS="" LDFLAGS="""
+EXTRA_OEMAKE = ""
+
+UBOOT_MACHINE ?= "${MACHINE}_config"
+UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.bin"
+
+
+#inherit base
+
+do_compile () {
+ unset LDFLAGS
+ unset CFLAGS
+ unset CPPFLAGS
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake all
+}
+
+do_stage() {
+ install -m755 tools/mkimage ${STAGING_BINDIR}
+}
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
+}
+do_deploy[dirs] = "${S}"
+addtask deploy before do_build after do_compile