aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xapian
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-04 12:18:54 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-04 12:18:54 +0000
commit2c140aef109e137be70dd19872728143d81f98be (patch)
tree29b5dc490f798c6aac695b42c4a3d51e754519fb /packages/xapian
parente7005ef68aeb05f4656029050b31c44a8e09f167 (diff)
downloadopenembedded-2c140aef109e137be70dd19872728143d81f98be.tar.gz
xapian: commit my latest work on xapian-quickindex. partly closes 3711.
* xapian-quickindex looks like a good candidate for creating an offline wikipedia.
Diffstat (limited to 'packages/xapian')
-rw-r--r--packages/xapian/xapian-core-native_1.0.5.bb5
-rw-r--r--packages/xapian/xapian-quickstart.inc20
-rw-r--r--packages/xapian/xapian-quickstartindex-native_1.0.bb9
-rw-r--r--packages/xapian/xapian-quickstartindex_1.0.bb20
-rw-r--r--packages/xapian/xapian-quickstartsearch_1.0.bb4
5 files changed, 41 insertions, 17 deletions
diff --git a/packages/xapian/xapian-core-native_1.0.5.bb b/packages/xapian/xapian-core-native_1.0.5.bb
new file mode 100644
index 0000000000..d3c425f6c4
--- /dev/null
+++ b/packages/xapian/xapian-core-native_1.0.5.bb
@@ -0,0 +1,5 @@
+require xapian-core_${PV}.bb
+
+inherit native
+
+S = "${WORKDIR}/xapian-core-${PV}"
diff --git a/packages/xapian/xapian-quickstart.inc b/packages/xapian/xapian-quickstart.inc
new file mode 100644
index 0000000000..aab599f64b
--- /dev/null
+++ b/packages/xapian/xapian-quickstart.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Simplest possible indexer (from an older release of xapian)."
+HOMEPAGE = "http://users.softlab.ece.ntua.gr/~ttsiod/buildWikipediaOffline.html"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "xapian-core"
+
+BINARY_NAME = ${@bb.data.getVar("PN",d,1).replace("xapian-","").replace("-native","")}
+S = "${WORKDIR}"
+
+SRC_URI = "http://users.softlab.ece.ntua.gr/~ttsiod/${BINARY_NAME}.cc"
+
+do_compile() {
+ ${CXX} ${CXXLAGS} ${LDFLAGS} -I${STAGING_INCDIR_NATIVE} -lxapian -o ${BINARY_NAME} ${BINARY_NAME}.cc
+}
+
+do_install() {
+ install -d ${D}$
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/${BINARY_NAME} ${D}${bindir}/
+}
diff --git a/packages/xapian/xapian-quickstartindex-native_1.0.bb b/packages/xapian/xapian-quickstartindex-native_1.0.bb
new file mode 100644
index 0000000000..fe84d4cbf5
--- /dev/null
+++ b/packages/xapian/xapian-quickstartindex-native_1.0.bb
@@ -0,0 +1,9 @@
+require xapian-quickstartindex_${PV}.bb
+
+DEPENDS = "xapian-core-native"
+
+inherit native
+
+do_stage() {
+ install -m 0744 ${WORKDIR}/${BINARY_NAME} ${STAGING_BINDIR}
+}
diff --git a/packages/xapian/xapian-quickstartindex_1.0.bb b/packages/xapian/xapian-quickstartindex_1.0.bb
index 6deff9191e..7a17f7b354 100644
--- a/packages/xapian/xapian-quickstartindex_1.0.bb
+++ b/packages/xapian/xapian-quickstartindex_1.0.bb
@@ -1,18 +1,4 @@
-DESCRIPTION = "Simplest possible indexer (from older release of xapian)"
-HOMEPAGE = "http://users.softlab.ece.ntua.gr/~ttsiod/buildWikipediaOffline.html"
-PRIORITY = "optional"
-LICENSE = "GPL"
-DEPENDS = "xapian-core"
-PR = "r0"
+require xapian-quickstart.inc
-SRC_URI = "http://users.softlab.ece.ntua.gr/~ttsiod/quickstartindex.cc"
-S = "${WORKDIR}"
-
-do_compile() {
- ${CXX} ${CXXLAGS} ${LDFLAGS} -lxapian -o quickstartindex quickstartindex.cc
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/quickstartindex ${D}${bindir}/
-}
+DESCRIPTION += "This package provides the tool for creating the index."
+PR = "r1"
diff --git a/packages/xapian/xapian-quickstartsearch_1.0.bb b/packages/xapian/xapian-quickstartsearch_1.0.bb
new file mode 100644
index 0000000000..c3381f6abd
--- /dev/null
+++ b/packages/xapian/xapian-quickstartsearch_1.0.bb
@@ -0,0 +1,4 @@
+require xapian-quickstart.inc
+
+DESCRIPTION += "This package provides the tool for searching the index."
+PR = "r1"