aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/antlr
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/antlr
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/antlr')
-rw-r--r--recipes/antlr/antlr-native_2.7.7.bb17
-rw-r--r--recipes/antlr/antlr_2.7.7.bb16
-rwxr-xr-xrecipes/antlr/files/runantlr11
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes/antlr/antlr-native_2.7.7.bb b/recipes/antlr/antlr-native_2.7.7.bb
new file mode 100644
index 0000000000..871e620b93
--- /dev/null
+++ b/recipes/antlr/antlr-native_2.7.7.bb
@@ -0,0 +1,17 @@
+require antlr_${PV}.bb
+
+SRC_URI += "file://runantlr"
+
+inherit java-native
+
+do_configure() {
+ sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_NATIVE}/java/antlr.jar|" ${WORKDIR}/runantlr
+}
+
+do_stage() {
+ java_stage
+
+ install -d ${STAGING_BINDIR}
+
+ install -m 0755 ${WORKDIR}/runantlr ${STAGING_BINDIR}
+}
diff --git a/recipes/antlr/antlr_2.7.7.bb b/recipes/antlr/antlr_2.7.7.bb
new file mode 100644
index 0000000000..431b7b5b4f
--- /dev/null
+++ b/recipes/antlr/antlr_2.7.7.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Framework for constructing recognizers, interpreters, compilers, and translators"
+# see http://www.antlr2.org/license.html
+LICENSE = "Public Domain"
+HOMEPAGE = "http://www.antlr2.org"
+
+SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz"
+
+inherit java-library
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath . -d build `find antlr -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
diff --git a/recipes/antlr/files/runantlr b/recipes/antlr/files/runantlr
new file mode 100755
index 0000000000..b924bf477d
--- /dev/null
+++ b/recipes/antlr/files/runantlr
@@ -0,0 +1,11 @@
+#!/bin/sh
+echo Running 'java antlr.Tool $*' with @JAR_FILE@ appended to the CLASSPATH variable
+
+export CLASSPATH
+CLASSPATH=$CLASSPATH:@JAR_FILE@
+
+if [ ! $JAVA ];then
+ JAVA=java
+fi
+
+$JAVA antlr.Tool $*