aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bonnie
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bonnie
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bonnie')
-rw-r--r--recipes/bonnie/bonnie++.inc30
-rw-r--r--recipes/bonnie/bonnie++_1.03a.bb1
-rw-r--r--recipes/bonnie/bonnie++_1.03c.bb1
-rw-r--r--recipes/bonnie/files/gcc-4.3-fixes.patch16
4 files changed, 48 insertions, 0 deletions
diff --git a/recipes/bonnie/bonnie++.inc b/recipes/bonnie/bonnie++.inc
new file mode 100644
index 0000000000..7e9d81579c
--- /dev/null
+++ b/recipes/bonnie/bonnie++.inc
@@ -0,0 +1,30 @@
+# bonnie OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="Tests large file IO and creation/deletion of small files."
+LICENSE="GPL"
+
+
+SRC_URI="http://www.coker.com.au/bonnie++/${PN}-${PV}.tgz \
+ file://gcc-4.3-fixes.patch;patch=1"
+
+inherit autotools
+
+EXES="bonnie++ zcav"
+SCRIPTS="bon_csv2html bon_csv2txt"
+
+PACKAGES += "bonnie-scripts"
+
+FILES_${PN} = "/sbin"
+FILES_bonnie-scripts="/bin"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+do_install () {
+ install -d ${D}/bin
+ install -d ${D}/sbin
+
+ install -m 0755 ${EXES} ${D}/sbin
+ install -m 0755 ${SCRIPTS} ${D}/bin
+}
diff --git a/recipes/bonnie/bonnie++_1.03a.bb b/recipes/bonnie/bonnie++_1.03a.bb
new file mode 100644
index 0000000000..3934aff43e
--- /dev/null
+++ b/recipes/bonnie/bonnie++_1.03a.bb
@@ -0,0 +1 @@
+require bonnie++.inc
diff --git a/recipes/bonnie/bonnie++_1.03c.bb b/recipes/bonnie/bonnie++_1.03c.bb
new file mode 100644
index 0000000000..3934aff43e
--- /dev/null
+++ b/recipes/bonnie/bonnie++_1.03c.bb
@@ -0,0 +1 @@
+require bonnie++.inc
diff --git a/recipes/bonnie/files/gcc-4.3-fixes.patch b/recipes/bonnie/files/gcc-4.3-fixes.patch
new file mode 100644
index 0000000000..cecf87e05a
--- /dev/null
+++ b/recipes/bonnie/files/gcc-4.3-fixes.patch
@@ -0,0 +1,16 @@
+---
+ zcav.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: bonnie++-1.03a/zcav.cpp
+===================================================================
+--- bonnie++-1.03a.orig/zcav.cpp
++++ bonnie++-1.03a/zcav.cpp
+@@ -15,6 +15,7 @@ using namespace std;
+ #else
+ #include <vector.h>
+ #endif
++#include <string.h>
+
+ // Read the specified number of megabytes of data from the fd and return the
+ // amount of time elapsed in seconds.