aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bzip2/bzip2_1.0.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bzip2/bzip2_1.0.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bzip2/bzip2_1.0.2.bb')
-rw-r--r--recipes/bzip2/bzip2_1.0.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/bzip2/bzip2_1.0.2.bb b/recipes/bzip2/bzip2_1.0.2.bb
new file mode 100644
index 0000000000..1e1cb8e539
--- /dev/null
+++ b/recipes/bzip2/bzip2_1.0.2.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Very high-quality data compression program."
+SECTION = "console/utils"
+PR = "r1"
+
+LICENSE = "bzip2"
+SRC_URI = "ftp://sources.redhat.com/pub/bzip2/v102/bzip2-${PV}.tar.gz \
+ file://installpaths.patch;patch=1"
+
+CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
+
+do_compile () {
+ oe_runmake -f Makefile-libbz2_so
+ ln -sf libbz2.so.1.0.2 libbz2.so.1.0
+ ln -sf libbz2.so.1.0.2 libbz2.so.1
+ ln -sf libbz2.so.1.0.2 libbz2.so
+ oe_runmake libbz2.a bzip2 bzip2recover
+}
+
+do_stage () {
+ install -m 0644 bzlib.h ${STAGING_INCDIR}/
+ oe_libinstall -a -so libbz2 ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ oe_libinstall -a -so libbz2 ${D}${libdir}
+ mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
+ mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
+}
+
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
+ update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
+}
+
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove bunzip2 bunzip2.${PN}
+ update-alternatives --remove bzcat bzcat.${PN}
+}