aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cacao
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2010-08-17 01:08:34 +0000
committerTom Rini <tom_rini@mentor.com>2010-09-30 14:03:09 -0700
commitccc23f16dc039cb9f7fee5425846c2a21b2a36f7 (patch)
tree0fcd044f824bc70f714b9d6d9b5f22fade2b53e2 /recipes/cacao
parentaaa6bfa82aff074560881f381743811e2a0f309f (diff)
downloadopenembedded-ccc23f16dc039cb9f7fee5425846c2a21b2a36f7.tar.gz
cacaoh-native: Removed legacy style staging
* converted do_stage to do_install * use oe-stylize.py (with care as it gets require wrong). * Switch to INC_PR, bump. Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/cacao')
-rw-r--r--recipes/cacao/cacaoh-native.inc12
-rw-r--r--recipes/cacao/cacaoh-native_0.99.3.bb3
-rw-r--r--recipes/cacao/cacaoh-native_0.99.4.bb3
3 files changed, 10 insertions, 8 deletions
diff --git a/recipes/cacao/cacaoh-native.inc b/recipes/cacao/cacaoh-native.inc
index a44c5035c6..2b3709f62f 100644
--- a/recipes/cacao/cacaoh-native.inc
+++ b/recipes/cacao/cacaoh-native.inc
@@ -1,9 +1,10 @@
DESCRIPTION = "Header generator for Cacao JVM - Needed for cross-compilation builds"
HOMEPAGE = "http://www.cacaojvm.org/"
-LICENSE = "GPL"
-
+LICENSE = "GPL"
DEPENDS = "libtool-native zlib-native virtual/javac-native classpath-native"
+INC_PR = "r2"
+
S = "${WORKDIR}/cacao-${PV}"
inherit autotools native
@@ -21,6 +22,9 @@ do_compile() {
oe_runmake -C src/cacaoh cacaoh
}
-do_stage() {
- install -m 0755 src/cacaoh/.libs/cacaoh ${STAGING_BINDIR}/cacaoh-${PV}
+do_install() {
+ install -d ${D}${bindir}/cacaoh-${PV}
+ install -m 0755 src/cacaoh/.libs/cacaoh ${D}${bindir}/cacaoh-${PV}
}
+
+NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes/cacao/cacaoh-native_0.99.3.bb b/recipes/cacao/cacaoh-native_0.99.3.bb
index b3baee0c12..b1d127cb0d 100644
--- a/recipes/cacao/cacaoh-native_0.99.3.bb
+++ b/recipes/cacao/cacaoh-native_0.99.3.bb
@@ -1,8 +1,7 @@
require cacaoh-native.inc
-PR = "r1"
+PR = "${INC_PR}.1"
SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2"
-
SRC_URI[md5sum] = "db93ab31c6d1b7f1e213771bb81bde58"
SRC_URI[sha256sum] = "1ea5bd257f755ffcae2c7a1935c37147c7392478922410e0870361eea08b6c27"
diff --git a/recipes/cacao/cacaoh-native_0.99.4.bb b/recipes/cacao/cacaoh-native_0.99.4.bb
index a9effc08e1..4c631838eb 100644
--- a/recipes/cacao/cacaoh-native_0.99.4.bb
+++ b/recipes/cacao/cacaoh-native_0.99.4.bb
@@ -1,8 +1,7 @@
require cacaoh-native.inc
-PR = "r0"
+PR = "${INC_PR}.1"
SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2"
-
SRC_URI[md5sum] = "63220327925ace13756ae334c55a3baa"
SRC_URI[sha256sum] = "1dfc4903dc0172286df4f1740fd0f12749ac81d51c602290b47cbe83d51e1d56"