aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cairo/cairo_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cairo/cairo_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cairo/cairo_git.bb')
-rw-r--r--recipes/cairo/cairo_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/cairo/cairo_git.bb b/recipes/cairo/cairo_git.bb
new file mode 100644
index 0000000000..44212103a6
--- /dev/null
+++ b/recipes/cairo/cairo_git.bb
@@ -0,0 +1,24 @@
+#This is a development snapshot, so lets hint OE to use the releases
+DEFAULT_PREFERENCE = "-1"
+
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "pixman virtual/libx11 libsm libpng fontconfig libxrender"
+DESCRIPTION = "Cairo graphics library"
+LICENSE = "MPL LGPL"
+
+PV = "1.5.3+git${SRCDATE}"
+
+SRC_URI = "git://git.cairographics.org/git/cairo;protocol=git \
+ "
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+
+do_compile_append() {
+ cd ${S}/perf ; oe_runmake
+}
+
+do_stage () {
+ autotools_stage_all
+}