aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cpuburn/cpuburn/gcc_CC.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/cpuburn/cpuburn/gcc_CC.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cpuburn/cpuburn/gcc_CC.patch')
-rw-r--r--recipes/cpuburn/cpuburn/gcc_CC.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/cpuburn/cpuburn/gcc_CC.patch b/recipes/cpuburn/cpuburn/gcc_CC.patch
new file mode 100644
index 0000000000..a572754eb0
--- /dev/null
+++ b/recipes/cpuburn/cpuburn/gcc_CC.patch
@@ -0,0 +1,19 @@
+--- cpuburn-1.4/Makefile.orig 2006-03-09 16:11:53.368477664 -0700
++++ cpuburn-1.4/Makefile 2006-03-09 16:13:27.053235416 -0700
+@@ -1,3 +1,15 @@
++prefix=/usr/local
++
+ all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
+ .S:
+- gcc -s -nostdlib -o $@ $<
++ ${CC} ${CFLAGS} -s -nostdlib -o $@ $<
++
++install:
++ install -d ${DESTDIR}${prefix}/bin
++ install -m 0755 burnP5 ${DESTDIR}${prefix}/bin
++ install -m 0755 burnP6 ${DESTDIR}${prefix}/bin
++ install -m 0755 burnK6 ${DESTDIR}${prefix}/bin
++ install -m 0755 burnK7 ${DESTDIR}${prefix}/bin
++ install -m 0755 burnBX ${DESTDIR}${prefix}/bin
++ install -m 0755 burnMMX ${DESTDIR}${prefix}/bin
++