aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-15 17:38:02 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-15 17:38:02 +0200
commit92910fe1806e2d3d4eaa211d38e3d73ac18486da (patch)
tree1e02bba3cfcb97fcf36b56b569cad57de21e1225 /recipes/dbus
parent0736d94059a89bfeab5b1a38af9ff6ca12e7d263 (diff)
downloadopenembedded-92910fe1806e2d3d4eaa211d38e3d73ac18486da.tar.gz
dbus: remove old versions
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dbus')
-rw-r--r--recipes/dbus/dbus-1.0.3/0001-Make-the-default-DBus-reply-timeout-configurable.patch78
-rw-r--r--recipes/dbus/dbus-1.0.3/cross.patch10
-rw-r--r--recipes/dbus/dbus-1.0.3/dbus-1.init110
-rw-r--r--recipes/dbus/dbus-1.0.3/fedora-compile-fix.patch18
-rw-r--r--recipes/dbus/dbus-1.0.3/fix-install-daemon.patch13
-rw-r--r--recipes/dbus/dbus-1.0.3/fix-waitpid.patch11
-rw-r--r--recipes/dbus/dbus-1.0.3/tmpdir.patch30
-rw-r--r--recipes/dbus/dbus-1.2.20/0001-Make-the-default-DBus-reply-timeout-configurable.patch78
-rw-r--r--recipes/dbus/dbus-1.2.20/dbus-1.init111
-rw-r--r--recipes/dbus/dbus-1.2.20/fix-install-daemon.patch13
-rw-r--r--recipes/dbus/dbus-1.2.20/tmpdir.patch30
-rw-r--r--recipes/dbus/dbus-native_1.0.3.bb35
-rw-r--r--recipes/dbus/dbus_1.0.3.bb7
-rw-r--r--recipes/dbus/dbus_1.2.20.bb15
14 files changed, 0 insertions, 559 deletions
diff --git a/recipes/dbus/dbus-1.0.3/0001-Make-the-default-DBus-reply-timeout-configurable.patch b/recipes/dbus/dbus-1.0.3/0001-Make-the-default-DBus-reply-timeout-configurable.patch
deleted file mode 100644
index a38e3db0de..0000000000
--- a/recipes/dbus/dbus-1.0.3/0001-Make-the-default-DBus-reply-timeout-configurable.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From fb546488e93a1638d377b228bbb0d2ab58462168 Mon Sep 17 00:00:00 2001
-From: Daniel Willmann <daniel@totalueberwachung.de>
-Date: Thu, 2 Oct 2008 15:50:17 +0800
-Subject: [PATCH] Make the default DBus reply timeout configurable
-
-This patch adds an option --with-dbus-default-reply-timeout to configure
-that will set the default reply timeout used by libdbus in milliseconds.
-autoconf and autoheader need to be rerun in order to regenerate the
-correct configure and config.h.in files.
----
- configure.in | 9 +++++++++
- dbus/dbus-connection-internal.h | 3 ---
- dbus/dbus-pending-call.c | 1 +
- 3 files changed, 10 insertions(+), 3 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index 62ac387..5c912d7 100644
---- a/configure.in
-+++ b/configure.in
-@@ -88,6 +88,7 @@ AC_ARG_WITH(console-auth-dir, AS_HELP_STRING([--with-console-auth-dir=[dirname]]
- AC_ARG_WITH(console-owner-file, AS_HELP_STRING([--with-console-owner-file=[filename]],[file whose owner determines current console owner]))
- AC_ARG_WITH(dbus_user, AS_HELP_STRING([--with-dbus-user=<user>],[User for running the DBUS daemon (messagebus)]))
- AC_ARG_WITH(dbus_daemondir, AS_HELP_STRING([--with-dbus-daemondir=[dirname]],[Directory for installing the DBUS daemon]))
-+AC_ARG_WITH(dbus_default_reply_timeout, AS_HELP_STRING([--with-dbus-default-reply-timeout=[milliseconds]],[Default reply timeout for DBus method calls]))
-
- AC_DEFINE(DBUS_UNIX,1,[dbus on unix])
-
-@@ -986,6 +987,13 @@ if test x$have_libaudit = xyes ; then
- AC_DEFINE(HAVE_LIBAUDIT,1,[audit daemon SELinux support])
- fi
-
-+if test -z "$with_dbus_default_reply_timeout" ; then
-+ DBUS_DEFAULT_REPLY_TIMEOUT=25000
-+else
-+ DBUS_DEFAULT_REPLY_TIMEOUT=$with_dbus_default_reply_timeout
-+fi
-+AC_DEFINE_UNQUOTED(_DBUS_DEFAULT_TIMEOUT_VALUE,$DBUS_DEFAULT_REPLY_TIMEOUT,[default timeout value for dbus calls])
-+
- #### Set up final flags
- DBUS_CLIENT_CFLAGS=
- DBUS_CLIENT_LIBS="$THREAD_LIBS"
-@@ -1348,6 +1356,7 @@ echo "
- Gettext libs (empty OK): ${INTLLIBS}
- Using XML parser: ${with_xml}
- Init scripts style: ${with_init_scripts}
-+ Default reply timeout: ${DBUS_DEFAULT_REPLY_TIMEOUT}
- Abstract socket names: ${ac_cv_have_abstract_sockets}
- System bus socket: ${DBUS_SYSTEM_SOCKET}
- System bus address: ${DBUS_SYSTEM_BUS_DEFAULT_ADDRESS}
-diff --git a/dbus/dbus-connection-internal.h b/dbus/dbus-connection-internal.h
-index df54412..5fe536b 100644
---- a/dbus/dbus-connection-internal.h
-+++ b/dbus/dbus-connection-internal.h
-@@ -41,9 +41,6 @@ typedef enum
- DBUS_ITERATION_BLOCK = 1 << 2 /**< Block if nothing to do. */
- } DBusIterationFlags;
-
--/** default timeout value when waiting for a message reply, 25 seconds */
--#define _DBUS_DEFAULT_TIMEOUT_VALUE (25 * 1000)
--
- void _dbus_connection_lock (DBusConnection *connection);
- void _dbus_connection_unlock (DBusConnection *connection);
- DBusConnection * _dbus_connection_ref_unlocked (DBusConnection *connection);
-diff --git a/dbus/dbus-pending-call.c b/dbus/dbus-pending-call.c
-index 51b9378..5a7a5f4 100644
---- a/dbus/dbus-pending-call.c
-+++ b/dbus/dbus-pending-call.c
-@@ -21,6 +21,7 @@
- *
- */
-
-+#include <config.h>
- #include "dbus-internals.h"
- #include "dbus-connection-internal.h"
- #include "dbus-pending-call-internal.h"
---
-1.5.6.4
-
diff --git a/recipes/dbus/dbus-1.0.3/cross.patch b/recipes/dbus/dbus-1.0.3/cross.patch
deleted file mode 100644
index 268a3ae3de..0000000000
--- a/recipes/dbus/dbus-1.0.3/cross.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- /tmp/configure.in 2006-11-09 21:47:10.000000000 +0100
-+++ dbus-0.95/configure.in 2006-11-09 21:48:13.108554000 +0100
-@@ -719,6 +719,7 @@
- exit (0);
- ]])],
- [ac_cv_have_abstract_sockets=yes],
-+ [ac_cv_have_abstract_sockets=no],
- [ac_cv_have_abstract_sockets=no]
- )])
- AC_LANG_POP(C)
diff --git a/recipes/dbus/dbus-1.0.3/dbus-1.init b/recipes/dbus/dbus-1.0.3/dbus-1.init
deleted file mode 100644
index 0725083c69..0000000000
--- a/recipes/dbus/dbus-1.0.3/dbus-1.init
+++ /dev/null
@@ -1,110 +0,0 @@
-#! /bin/sh
-# -*- coding: utf-8 -*-
-# Debian init.d script for D-BUS
-# Copyright © 2003 Colin Walters <walters@debian.org>
-
-set -e
-
-DAEMON=/usr/bin/dbus-daemon
-NAME=dbus
-DAEMONUSER=messagebus
-PIDDIR=/var/run/dbus
-PIDFILE=$PIDDIR/pid
-UUIDDIR=/var/lib/dbus
-DESC="system message bus"
-EVENTDIR=/etc/dbus-1/event.d
-
-test -x $DAEMON || exit 0
-
-# Source defaults file; edit that file to configure this script.
-ENABLED=1
-PARAMS=""
-if [ -e /etc/default/dbus ]; then
- . /etc/default/dbus
-fi
-
-test "$ENABLED" != "0" || exit 0
-
-start_it_up()
-{
- if [ ! -d $PIDDIR ]; then
- mkdir -p $PIDDIR
- chown $DAEMONUSER $PIDDIR
- chgrp $DAEMONUSER $PIDDIR
- fi
- if [ -e $PIDFILE ]; then
- PIDDIR=/proc/$(cat $PIDFILE)
- if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
- echo "$DESC already started; not starting."
- else
- echo "Removing stale PID file $PIDFILE."
- rm -f $PIDFILE
- fi
- fi
-
- if [ ! -d $UUIDDIR ]; then
- mkdir -p $UUIDDIR
- chown $DAEMONUSER $UUIDDIR
- chgrp $DAEMONUSER $UUIDDIR
- fi
-
- dbus-uuidgen --ensure
-
- echo -n "Starting $DESC: "
- start-stop-daemon --start --quiet --pidfile $PIDFILE \
- --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- if [ -d $EVENTDIR ]; then
- run-parts --arg=start $EVENTDIR
- fi
-}
-
-shut_it_down()
-{
- if [ -d $EVENTDIR ]; then
- # TODO: --reverse when busybox supports it
- run-parts --arg=stop $EVENTDIR
- fi
- echo -n "Stopping $DESC: "
- start-stop-daemon --stop --quiet --pidfile $PIDFILE \
- --user $DAEMONUSER
- # We no longer include these arguments so that start-stop-daemon
- # can do its job even given that we may have been upgraded.
- # We rely on the pidfile being sanely managed
- # --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- rm -f $PIDFILE
-}
-
-reload_it()
-{
- echo -n "Reloading $DESC config: "
- dbus-send --print-reply --system --type=method_call \
- --dest=org.freedesktop.DBus \
- / org.freedesktop.DBus.ReloadConfig > /dev/null
- # hopefully this is enough time for dbus to reload it's config file.
- echo "done."
-}
-
-case "$1" in
- start)
- start_it_up
- ;;
- stop)
- shut_it_down
- ;;
- reload|force-reload)
- reload_it
- ;;
- restart)
- shut_it_down
- sleep 1
- start_it_up
- ;;
- *)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/recipes/dbus/dbus-1.0.3/fedora-compile-fix.patch b/recipes/dbus/dbus-1.0.3/fedora-compile-fix.patch
deleted file mode 100644
index eac37f04dd..0000000000
--- a/recipes/dbus/dbus-1.0.3/fedora-compile-fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Do not fail with udrec being unknown and say we are using
-_GNU_SOURCE. This is needed for the libc/header/gcc combo
-fedora 9 is using. bits/socket.h has struct udrec #ifdefed
-with _GNU.
-
-Index: dbus-1.0.3/dbus/dbus-sysdeps-unix.c
-===================================================================
---- dbus-1.0.3.orig/dbus/dbus-sysdeps-unix.c
-+++ dbus-1.0.3/dbus/dbus-sysdeps-unix.c
-@@ -22,6 +22,8 @@
- *
- */
-
-+#define _GNU_SOURCE
-+
- #include "dbus-internals.h"
- #include "dbus-sysdeps.h"
- #include "dbus-sysdeps-unix.h"
diff --git a/recipes/dbus/dbus-1.0.3/fix-install-daemon.patch b/recipes/dbus/dbus-1.0.3/fix-install-daemon.patch
deleted file mode 100644
index c31786357d..0000000000
--- a/recipes/dbus/dbus-1.0.3/fix-install-daemon.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: dbus-0.94/bus/Makefile.am
-===================================================================
---- dbus-0.94.orig/bus/Makefile.am 2006-10-01 17:36:18.000000000 +0200
-+++ dbus-0.94/bus/Makefile.am 2006-10-14 21:40:05.000000000 +0200
-@@ -110,7 +110,7 @@
- $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
- chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
- fi
-- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
-+ $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
- $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
- $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
diff --git a/recipes/dbus/dbus-1.0.3/fix-waitpid.patch b/recipes/dbus/dbus-1.0.3/fix-waitpid.patch
deleted file mode 100644
index 80c431809c..0000000000
--- a/recipes/dbus/dbus-1.0.3/fix-waitpid.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- /tmp/dbus-launch.c 2007-02-05 18:43:24.000000000 +0100
-+++ dbus-1.0.2/tools/dbus-launch.c 2007-02-05 18:43:37.675251000 +0100
-@@ -622,7 +622,7 @@
-
- exit_with_session = FALSE;
- config_file = NULL;
--
-+ signal(SIGCHLD, SIG_DFL);
- prev_arg = NULL;
- i = 1;
- while (i < argc)
diff --git a/recipes/dbus/dbus-1.0.3/tmpdir.patch b/recipes/dbus/dbus-1.0.3/tmpdir.patch
deleted file mode 100644
index 838b903f0a..0000000000
--- a/recipes/dbus/dbus-1.0.3/tmpdir.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- dbus-0.22/configure.in.orig 2004-08-13 00:57:16.000000000 +0200
-+++ dbus-0.22/configure.in 2004-12-30 21:15:57.000000000 +0100
-@@ -1047,15 +1048,18 @@
- AC_SUBST(ABSOLUTE_TOP_BUILDDIR)
-
- #### Find socket directories
--if ! test -z "$TMPDIR" ; then
-- DEFAULT_SOCKET_DIR=$TMPDIR
--elif ! test -z "$TEMP" ; then
-- DEFAULT_SOCKET_DIR=$TEMP
--elif ! test -z "$TMP" ; then
-- DEFAULT_SOCKET_DIR=$TMP
--else
-- DEFAULT_SOCKET_DIR=/tmp
--fi
-+#if ! test -z "$TMPDIR" ; then
-+# DEFAULT_SOCKET_DIR=$TMPDIR
-+#elif ! test -z "$TEMP" ; then
-+# DEFAULT_SOCKET_DIR=$TEMP
-+#elif ! test -z "$TMP" ; then
-+# DEFAULT_SOCKET_DIR=$TMP
-+#else
-+# DEFAULT_SOCKET_DIR=/tmp
-+#fi
-+
-+# checks disabled to avoid expanding this at build time
-+DEFAULT_SOCKET_DIR=/tmp
-
- if ! test -z "$with_test_socket_dir" ; then
- TEST_SOCKET_DIR="$with_test_socket_dir"
diff --git a/recipes/dbus/dbus-1.2.20/0001-Make-the-default-DBus-reply-timeout-configurable.patch b/recipes/dbus/dbus-1.2.20/0001-Make-the-default-DBus-reply-timeout-configurable.patch
deleted file mode 100644
index a38e3db0de..0000000000
--- a/recipes/dbus/dbus-1.2.20/0001-Make-the-default-DBus-reply-timeout-configurable.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From fb546488e93a1638d377b228bbb0d2ab58462168 Mon Sep 17 00:00:00 2001
-From: Daniel Willmann <daniel@totalueberwachung.de>
-Date: Thu, 2 Oct 2008 15:50:17 +0800
-Subject: [PATCH] Make the default DBus reply timeout configurable
-
-This patch adds an option --with-dbus-default-reply-timeout to configure
-that will set the default reply timeout used by libdbus in milliseconds.
-autoconf and autoheader need to be rerun in order to regenerate the
-correct configure and config.h.in files.
----
- configure.in | 9 +++++++++
- dbus/dbus-connection-internal.h | 3 ---
- dbus/dbus-pending-call.c | 1 +
- 3 files changed, 10 insertions(+), 3 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index 62ac387..5c912d7 100644
---- a/configure.in
-+++ b/configure.in
-@@ -88,6 +88,7 @@ AC_ARG_WITH(console-auth-dir, AS_HELP_STRING([--with-console-auth-dir=[dirname]]
- AC_ARG_WITH(console-owner-file, AS_HELP_STRING([--with-console-owner-file=[filename]],[file whose owner determines current console owner]))
- AC_ARG_WITH(dbus_user, AS_HELP_STRING([--with-dbus-user=<user>],[User for running the DBUS daemon (messagebus)]))
- AC_ARG_WITH(dbus_daemondir, AS_HELP_STRING([--with-dbus-daemondir=[dirname]],[Directory for installing the DBUS daemon]))
-+AC_ARG_WITH(dbus_default_reply_timeout, AS_HELP_STRING([--with-dbus-default-reply-timeout=[milliseconds]],[Default reply timeout for DBus method calls]))
-
- AC_DEFINE(DBUS_UNIX,1,[dbus on unix])
-
-@@ -986,6 +987,13 @@ if test x$have_libaudit = xyes ; then
- AC_DEFINE(HAVE_LIBAUDIT,1,[audit daemon SELinux support])
- fi
-
-+if test -z "$with_dbus_default_reply_timeout" ; then
-+ DBUS_DEFAULT_REPLY_TIMEOUT=25000
-+else
-+ DBUS_DEFAULT_REPLY_TIMEOUT=$with_dbus_default_reply_timeout
-+fi
-+AC_DEFINE_UNQUOTED(_DBUS_DEFAULT_TIMEOUT_VALUE,$DBUS_DEFAULT_REPLY_TIMEOUT,[default timeout value for dbus calls])
-+
- #### Set up final flags
- DBUS_CLIENT_CFLAGS=
- DBUS_CLIENT_LIBS="$THREAD_LIBS"
-@@ -1348,6 +1356,7 @@ echo "
- Gettext libs (empty OK): ${INTLLIBS}
- Using XML parser: ${with_xml}
- Init scripts style: ${with_init_scripts}
-+ Default reply timeout: ${DBUS_DEFAULT_REPLY_TIMEOUT}
- Abstract socket names: ${ac_cv_have_abstract_sockets}
- System bus socket: ${DBUS_SYSTEM_SOCKET}
- System bus address: ${DBUS_SYSTEM_BUS_DEFAULT_ADDRESS}
-diff --git a/dbus/dbus-connection-internal.h b/dbus/dbus-connection-internal.h
-index df54412..5fe536b 100644
---- a/dbus/dbus-connection-internal.h
-+++ b/dbus/dbus-connection-internal.h
-@@ -41,9 +41,6 @@ typedef enum
- DBUS_ITERATION_BLOCK = 1 << 2 /**< Block if nothing to do. */
- } DBusIterationFlags;
-
--/** default timeout value when waiting for a message reply, 25 seconds */
--#define _DBUS_DEFAULT_TIMEOUT_VALUE (25 * 1000)
--
- void _dbus_connection_lock (DBusConnection *connection);
- void _dbus_connection_unlock (DBusConnection *connection);
- DBusConnection * _dbus_connection_ref_unlocked (DBusConnection *connection);
-diff --git a/dbus/dbus-pending-call.c b/dbus/dbus-pending-call.c
-index 51b9378..5a7a5f4 100644
---- a/dbus/dbus-pending-call.c
-+++ b/dbus/dbus-pending-call.c
-@@ -21,6 +21,7 @@
- *
- */
-
-+#include <config.h>
- #include "dbus-internals.h"
- #include "dbus-connection-internal.h"
- #include "dbus-pending-call-internal.h"
---
-1.5.6.4
-
diff --git a/recipes/dbus/dbus-1.2.20/dbus-1.init b/recipes/dbus/dbus-1.2.20/dbus-1.init
deleted file mode 100644
index 8209454088..0000000000
--- a/recipes/dbus/dbus-1.2.20/dbus-1.init
+++ /dev/null
@@ -1,111 +0,0 @@
-#! /bin/sh
-# -*- coding: utf-8 -*-
-# Debian init.d script for D-BUS
-# Copyright © 2003 Colin Walters <walters@debian.org>
-# Copyright 2008 OE Team
-
-set -e
-
-DAEMON=/usr/bin/dbus-daemon
-NAME=dbus
-DAEMONUSER=messagebus
-RUNDIR=/var/run/dbus
-PIDFILE=/var/run/dbus/pid
-UUIDDIR=/var/lib/dbus
-DESC="system message bus"
-EVENTDIR=/etc/dbus-1/event.d
-
-test -x $DAEMON || exit 0
-
-# Source defaults file; edit that file to configure this script.
-ENABLED=1
-PARAMS=""
-if [ -e /etc/default/dbus ]; then
- . /etc/default/dbus
-fi
-
-test "$ENABLED" != "0" || exit 0
-
-start_it_up()
-{
- if [ ! -d $RUNDIR ]; then
- mkdir -p $RUNDIR
- chown $DAEMONUSER $RUNDIR
- chgrp $DAEMONUSER $RUNDIR
- fi
- if [ -e $PIDFILE ]; then
- PIDDIR=/proc/$(cat $PIDFILE)
- if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
- echo "$DESC already started; not starting."
- else
- echo "Removing stale PID file $PIDFILE."
- rm -f $PIDFILE
- fi
- fi
-
- if [ ! -d $UUIDDIR ]; then
- mkdir -p $UUIDDIR
- chown $DAEMONUSER $UUIDDIR
- chgrp $DAEMONUSER $UUIDDIR
- fi
-
- dbus-uuidgen --ensure
-
- echo -n "Starting $DESC: "
- start-stop-daemon --start --pidfile $PIDFILE \
- --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- if [ -d $EVENTDIR ]; then
- run-parts --arg=start $EVENTDIR
- fi
-}
-
-shut_it_down()
-{
- if [ -d $EVENTDIR ]; then
- # TODO: --reverse when busybox supports it
- run-parts --arg=stop $EVENTDIR
- fi
- echo -n "Stopping $DESC: "
- start-stop-daemon --stop --oknodo --pidfile $PIDFILE \
- --user $DAEMONUSER
- # We no longer include these arguments so that start-stop-daemon
- # can do its job even given that we may have been upgraded.
- # We rely on the pidfile being sanely managed
- # --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- rm -f $PIDFILE
-}
-
-reload_it()
-{
- echo -n "Reloading $DESC config: "
- dbus-send --print-reply --system --type=method_call \
- --dest=org.freedesktop.DBus \
- / org.freedesktop.DBus.ReloadConfig > /dev/null
- # hopefully this is enough time for dbus to reload it's config file.
- echo "done."
-}
-
-case "$1" in
- start)
- start_it_up
- ;;
- stop)
- shut_it_down
- ;;
- reload|force-reload)
- reload_it
- ;;
- restart)
- shut_it_down
- sleep 1
- start_it_up
- ;;
- *)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/recipes/dbus/dbus-1.2.20/fix-install-daemon.patch b/recipes/dbus/dbus-1.2.20/fix-install-daemon.patch
deleted file mode 100644
index c31786357d..0000000000
--- a/recipes/dbus/dbus-1.2.20/fix-install-daemon.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: dbus-0.94/bus/Makefile.am
-===================================================================
---- dbus-0.94.orig/bus/Makefile.am 2006-10-01 17:36:18.000000000 +0200
-+++ dbus-0.94/bus/Makefile.am 2006-10-14 21:40:05.000000000 +0200
-@@ -110,7 +110,7 @@
- $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
- chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
- fi
-- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
-+ $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
- $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
- $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
diff --git a/recipes/dbus/dbus-1.2.20/tmpdir.patch b/recipes/dbus/dbus-1.2.20/tmpdir.patch
deleted file mode 100644
index 838b903f0a..0000000000
--- a/recipes/dbus/dbus-1.2.20/tmpdir.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- dbus-0.22/configure.in.orig 2004-08-13 00:57:16.000000000 +0200
-+++ dbus-0.22/configure.in 2004-12-30 21:15:57.000000000 +0100
-@@ -1047,15 +1048,18 @@
- AC_SUBST(ABSOLUTE_TOP_BUILDDIR)
-
- #### Find socket directories
--if ! test -z "$TMPDIR" ; then
-- DEFAULT_SOCKET_DIR=$TMPDIR
--elif ! test -z "$TEMP" ; then
-- DEFAULT_SOCKET_DIR=$TEMP
--elif ! test -z "$TMP" ; then
-- DEFAULT_SOCKET_DIR=$TMP
--else
-- DEFAULT_SOCKET_DIR=/tmp
--fi
-+#if ! test -z "$TMPDIR" ; then
-+# DEFAULT_SOCKET_DIR=$TMPDIR
-+#elif ! test -z "$TEMP" ; then
-+# DEFAULT_SOCKET_DIR=$TEMP
-+#elif ! test -z "$TMP" ; then
-+# DEFAULT_SOCKET_DIR=$TMP
-+#else
-+# DEFAULT_SOCKET_DIR=/tmp
-+#fi
-+
-+# checks disabled to avoid expanding this at build time
-+DEFAULT_SOCKET_DIR=/tmp
-
- if ! test -z "$with_test_socket_dir" ; then
- TEST_SOCKET_DIR="$with_test_socket_dir"
diff --git a/recipes/dbus/dbus-native_1.0.3.bb b/recipes/dbus/dbus-native_1.0.3.bb
deleted file mode 100644
index d883f0a2d0..0000000000
--- a/recipes/dbus/dbus-native_1.0.3.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-require dbus.inc
-
-PR = "${INC_PR}.0"
-DEFAULT_PREFERENCE = "-1"
-
-inherit native
-
-EXTRA_OECONF_X = "--without-x"
-
-DEPENDS = "glib-2.0-native libxml2-native expat-native"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
-
-SRC_URI = "\
- http://freedesktop.org/software/dbus/releases/dbus/dbus-${PV}.tar.gz \
- file://cross.patch \
- file://tmpdir.patch \
- file://fedora-compile-fix.patch \
- file://dbus-1.init \
-"
-
-do_stage() {
- oe_runmake install
- autotools_stage_all
-
- # for dbus-glib-native introspection generation
- install -d ${STAGING_DATADIR}/dbus
- install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
-}
-
-do_install() {
- :
-}
-
-SRC_URI[md5sum] = "ce328423db5743fe9006d39113b5324d"
-SRC_URI[sha256sum] = "4be82f4ef8f4657f997a44b3daddba3f95dbb6518487509767d803dd72bf529e"
diff --git a/recipes/dbus/dbus_1.0.3.bb b/recipes/dbus/dbus_1.0.3.bb
deleted file mode 100644
index c4eef9be57..0000000000
--- a/recipes/dbus/dbus_1.0.3.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require dbus.inc
-PR = "${INC_PR}.0"
-
-DEFAULT_PREFERENCE = "-1"
-
-SRC_URI[dbus.md5sum] = "ce328423db5743fe9006d39113b5324d"
-SRC_URI[dbus.sha256sum] = "4be82f4ef8f4657f997a44b3daddba3f95dbb6518487509767d803dd72bf529e"
diff --git a/recipes/dbus/dbus_1.2.20.bb b/recipes/dbus/dbus_1.2.20.bb
deleted file mode 100644
index 25cc5ac754..0000000000
--- a/recipes/dbus/dbus_1.2.20.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-include dbus.inc
-
-PR = "${INC_PR}.0"
-
-SRC_URI = "\
- http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz;name=dbus \
- file://tmpdir.patch \
- file://fix-install-daemon.patch \
- file://0001-Make-the-default-DBus-reply-timeout-configurable.patch \
- file://dbus-1.init \
-"
-
-SRC_URI[dbus.md5sum] = "63f4e2412f6599a5e7b10281b9ddc0ac"
-SRC_URI[dbus.sha256sum] = "0ef086d738710384d525130797ee86a0ce2daebffa7dc4d28386503ef7448011"
-