aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/diffutils/diffutils_2.8.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/diffutils/diffutils_2.8.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/diffutils/diffutils_2.8.1.bb')
-rw-r--r--recipes/diffutils/diffutils_2.8.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/diffutils/diffutils_2.8.1.bb b/recipes/diffutils/diffutils_2.8.1.bb
new file mode 100644
index 0000000000..b979fa89f6
--- /dev/null
+++ b/recipes/diffutils/diffutils_2.8.1.bb
@@ -0,0 +1,39 @@
+SECTION = "base"
+LICENSE = "GPL"
+DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
+sdiff, and cmp utilities. These programs are usually \
+used for creating patch files."
+PR = "r4"
+
+SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+# diffutils assumes non-glibc compilation with uclibc and
+# this causes it to generate its own implementations of
+# standard functionality. regex.c actually breaks compilation
+# because it uses __mempcpy, there are other things (TBD:
+# see diffutils.mk in buildroot)
+EXTRA_OECONF_linux-uclibc = "--without-included-regex"
+EXTRA_OECONF_linux-uclibcgnueabi = "--without-included-regex"
+
+do_install_append () {
+ mv ${D}${bindir}/diff ${D}${bindir}/diff.${PN}
+ mv ${D}${bindir}/cmp ${D}${bindir}/cmp.${PN}
+}
+
+ALTERNATIVE_NAME = "diff"
+ALTERNATIVE_PATH = "diff.${PN}"
+ALTERNATIVE_PRIORITY = "100"
+
+pkg_postinst_${PN} () {
+
+update-alternatives --install /usr/bin/cmp cmp cmp.diffutils 100
+
+}
+
+pkg_postrm_${PN} () {
+
+update-alternatives --remove cmp cmp.diffutils
+
+}