aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dpkg
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-03 12:39:04 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-03 12:50:38 +0200
commitd70e2c39e058a2173dd00440f97a84b575f535b5 (patch)
tree93f0e041bd8b907567f1a98bd1faa7f0ae37e627 /recipes/dpkg
parent3c83508467dcdaec76a5f9d293e5f35534d9f78c (diff)
downloadopenembedded-d70e2c39e058a2173dd00440f97a84b575f535b5.tar.gz
dpkg : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/dpkg')
-rw-r--r--recipes/dpkg/files/autofoo.patch48
-rw-r--r--recipes/dpkg/files/nochroot.patch18
2 files changed, 0 insertions, 66 deletions
diff --git a/recipes/dpkg/files/autofoo.patch b/recipes/dpkg/files/autofoo.patch
deleted file mode 100644
index 691121e418..0000000000
--- a/recipes/dpkg/files/autofoo.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- dpkg-1.10.23/configure.in~autofoo
-+++ dpkg-1.10.23/configure.in
-@@ -227,21 +227,36 @@
- # OpenBSD passes AC_TRY_COMPILE for va_copy even though
- # it doesn't seem to exist, which is odd. We need to use
- # AC_TRY_RUN.
-+#
-+# If crosscompiling, use AC_TRY_COMPILE. -CL
- AC_TRY_RUN([
- #include <stdarg.h>
- main(){
- va_list v1,v2;
- va_copy(v1, v2);
- exit(0);}
--], [AC_MSG_RESULT(yes)
--AC_DEFINE(HAVE_VA_COPY,,[Whether the va_copy macro exists])],[AC_MSG_RESULT(no)
--AC_MSG_CHECKING([for va_list assignment copy])
-+], [dpkg_cv_va_copy=yes], [dpkg_cv_va_copy=no],
- AC_TRY_COMPILE([
- #include <stdarg.h>
-+main(){
-+va_list v1,v2;
-+va_copy(v1, v2);
-+exit(0);}
-+], [dpkg_cv_va_copy=yes], [dpkg_vc_va_copy=no]))
-+
-+if test "$dpkg_cv_va_copy" = "yes"; then
-+ AC_MSG_RESULT(yes)
-+ AC_DEFINE(HAVE_VA_COPY,,[Whether the va_copy macro exists])
-+else
-+ AC_MSG_RESULT(no)
-+ AC_MSG_CHECKING([for va_list assignment copy])
-+ AC_TRY_COMPILE([
-+#include <stdarg.h>
- ],[
- va_list v1,v2;
- v1 = v2;
--], AC_MSG_RESULT(yes),AC_MSG_ERROR(no))])
-+], AC_MSG_RESULT(yes), AC_MSG_ERROR(no))
-+fi
-
- DPKG_C_GCC_ATTRIBUTE([,,],supported,[int x],[,,],ATTRIB,[Define if function attributes a la GCC 2.5 and higher are available.],
- DPKG_C_GCC_ATTRIBUTE(noreturn,noreturn,[int x],noreturn,NORETURN,[Define if nonreturning functions a la GCC 2.5 and higher are available.])
diff --git a/recipes/dpkg/files/nochroot.patch b/recipes/dpkg/files/nochroot.patch
deleted file mode 100644
index 3a8beaebbf..0000000000
--- a/recipes/dpkg/files/nochroot.patch
+++ /dev/null
@@ -1,18 +0,0 @@
----
- src/help.c | 2 ++
- 1 file changed, 2 insertions(+)
-
---- dpkg-1.13.22.orig/src/help.c
-+++ dpkg-1.13.22/src/help.c
-@@ -175,9 +175,11 @@ static const char* preexecscript(const c
- */
- size_t instdirl;
-
-+#if 0
- if (*instdir) {
- if (chroot(instdir)) ohshite(_("failed to chroot to `%.250s'"),instdir);
- }
-+#endif
- if (f_debug & dbg_scripts) {
- fprintf(stderr,"D0%05o: fork/exec %s (",dbg_scripts,path);
- while (*++argv) fprintf(stderr," %s",*argv);