aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin.shar@gmail.com>2010-12-06 00:17:39 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-06 10:26:56 +0100
commit19c2a2b42f86e2dac063f2b69dfc9bc879a55cab (patch)
tree178060408a766a5d5339ab65fcb16b41c3ed5f7d /recipes/e17
parentbbb2e203a3854b2669fb7a1245f6fe46b7ff00d2 (diff)
downloadopenembedded-19c2a2b42f86e2dac063f2b69dfc9bc879a55cab.tar.gz
e-wm-theme-illume-efenniht: add recipe for efenniht e17 theme.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/e-wm-theme-illume-efenniht_svn.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/e17/e-wm-theme-illume-efenniht_svn.bb b/recipes/e17/e-wm-theme-illume-efenniht_svn.bb
new file mode 100644
index 0000000000..2e207841ec
--- /dev/null
+++ b/recipes/e17/e-wm-theme-illume-efenniht_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "efenniht illume theme - Efenniht was devised to be clean and neutral. Its name (which means equinox) comes from the chromatic duality that was decided at the very beginning, with a dark theme (black and orange) and a bright one (white and blue) to be developed so that more people feel comfortable using it. Efenniht uses few animations, discrete contrasts between shades of gray and fine lines (colored) that outline the selected elements."
+SECTION = "e/utils"
+HOMEPAGE = "http://trac.enlightenment.org/e/wiki/Themes#Efenniht"
+DEPENDS = "edje-native"
+RDEPENDS_${PN} = "e-wm"
+RSUGGESTS_${PN} = "elementary-theme-efenniht"
+PACKAGE_ARCH = "all"
+LICENSE = "MIT/BSD"
+
+SRCREV = "${EFL_SRCREV}"
+PV = "0.0+svnr${SRCPV}"
+
+inherit e-base
+
+SRCNAME = "efenniht"
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/THEMES;module=${SRCNAME};proto=http"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images ${S}/efenniht.edc -o ${S}/efenniht.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/efenniht.edj ${D}${datadir}/enlightenment/data/themes/
+}
+
+FILES_${PN} = "${datadir}/enlightenment/data/themes/"