summaryrefslogtreecommitdiffstats
path: root/recipes/efl1/ecore
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-14 12:31:56 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-17 21:34:20 +0100
commit406cd0fee12ad99ba6d6f7d55f743cc4c6697955 (patch)
treea42d23b341fe47e817eb2db16da9193a0aa43c3d /recipes/efl1/ecore
parentcbe3df9e564ebb72fa87aa76640b057b86e27f88 (diff)
downloadopenembedded-406cd0fee12ad99ba6d6f7d55f743cc4c6697955.tar.gz
ecore: fix building for uClibc
Diffstat (limited to 'recipes/efl1/ecore')
-rw-r--r--recipes/efl1/ecore/exit_uclibc.patch26
-rw-r--r--recipes/efl1/ecore/iconv.patch35
2 files changed, 61 insertions, 0 deletions
diff --git a/recipes/efl1/ecore/exit_uclibc.patch b/recipes/efl1/ecore/exit_uclibc.patch
new file mode 100644
index 0000000000..dea010c116
--- /dev/null
+++ b/recipes/efl1/ecore/exit_uclibc.patch
@@ -0,0 +1,26 @@
+Index: ecore/src/lib/ecore_con/ecore_con_dns.c
+===================================================================
+--- ecore.orig/src/lib/ecore_con/ecore_con_dns.c 2009-11-14 00:12:04.279051754 +0100
++++ ecore/src/lib/ecore_con/ecore_con_dns.c 2009-11-14 00:14:41.685708230 +0100
+@@ -135,7 +135,7 @@
+ write(fd[1], "", 1);
+ }
+ close(fd[1]);
+-# ifdef __USE_ISOC99
++# if defined(__USE_ISOC99) && !defined(__UCLIBC__)
+ _Exit(0);
+ # else
+ _exit(0);
+Index: ecore/src/lib/ecore_con/ecore_con_info.c
+===================================================================
+--- ecore.orig/src/lib/ecore_con/ecore_con_info.c 2009-11-14 00:14:56.056955719 +0100
++++ ecore/src/lib/ecore_con/ecore_con_info.c 2009-11-14 00:16:40.035696191 +0100
+@@ -243,7 +243,7 @@
+ freeaddrinfo(result);
+ err = write(fd[1], "", 1);
+ close(fd[1]);
+-# ifdef __USE_ISOC99
++# if defined(__USE_ISOC99) && !defined(__UCLIBC__)
+ _Exit(0);
+ # else
+ _exit(0);
diff --git a/recipes/efl1/ecore/iconv.patch b/recipes/efl1/ecore/iconv.patch
new file mode 100644
index 0000000000..bd7f20df3f
--- /dev/null
+++ b/recipes/efl1/ecore/iconv.patch
@@ -0,0 +1,35 @@
+Index: ecore/configure.ac
+===================================================================
+--- ecore.orig/configure.ac 2009-11-13 23:33:16.504742218 +0100
++++ ecore/configure.ac 2009-11-13 23:41:52.360519091 +0100
+@@ -392,6 +392,7 @@
+ ]
+ )
+
++if test "x${LTLIBICONV}" = "x" ; then
+ if test "x${have_iconv}" = "xno" ; then
+ AC_CHECK_LIB(c, iconv,
+ [have_iconv="yes"] )
+@@ -413,6 +414,9 @@
+ fi
+
+ fi
++else
++ have_iconv="yes"
++fi
+ AC_MSG_CHECKING(for explicit iconv link options)
+ AC_MSG_RESULT($iconv_libs)
+
+Index: ecore/src/lib/ecore_txt/Makefile.am
+===================================================================
+--- ecore.orig/src/lib/ecore_txt/Makefile.am 2009-11-13 23:32:49.374328084 +0100
++++ ecore/src/lib/ecore_txt/Makefile.am 2009-11-13 23:33:08.383909514 +0100
+@@ -16,7 +16,7 @@
+ libecore_txt_la_SOURCES = \
+ ecore_txt.c
+
+-libecore_txt_la_LIBADD = @iconv_libs@ \
++libecore_txt_la_LIBADD = @iconv_libs@ $(LTLIBICONV) \
+ @EINA_LIBS@
+
+ libecore_txt_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -version-info @version_info@ @ecore_txt_release_info@