aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1/esmart_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/efl1/esmart_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/efl1/esmart_svn.bb')
-rw-r--r--recipes/efl1/esmart_svn.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/efl1/esmart_svn.bb b/recipes/efl1/esmart_svn.bb
new file mode 100644
index 0000000000..1ff75a4a84
--- /dev/null
+++ b/recipes/efl1/esmart_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "ESmart is a collection of smart Evas objects"
+LICENSE = "MIT BSD"
+DEPENDS = "evas ecore edje imlib2 epsilon libtool"
+PV = "0.9.0.050+svnr${SRCREV}"
+PR = "r1"
+
+inherit efl
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+PACKAGES =+ "${PN}-textentry \
+ ${PN}-thumb \
+ ${PN}-container \
+ ${PN}-container-plugins \
+ ${PN}-file-dialog \
+ ${PN}-draggies \
+ ${PN}-trans-x11"
+
+FILES_${PN}-dbg += "${libdir}/.debug/ ${libdir}/esmart/*/.debug/"
+FILES_${PN}-textentry = "${libdir}/libesmart_text_entry*.so*"
+FILES_${PN}-thumb = "${libdir}/libesmart_thumb*.so*"
+FILES_${PN}-container = "${libdir}/libesmart_container*"
+DEPENDS_${PN}-container += "${PN}-container-plugins"
+FILES_${PN}-container-plugins = "${libdir}/esmart/layout/*.so"
+FILES_${PN}-file-dialog = "${libdir}/libesmart_file_dialog*.so*"
+FILES_${PN}-draggies = "${libdir}/libesmart_draggies*.so*"
+FILES_${PN}-trans-x11 = "${libdir}/libesmart_trans_x11*.so*"