aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-configure-common.inc
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-10-30 21:48:21 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-10 13:44:14 +0000
commitbea72c2fecde175add169bb55df1922b048030c8 (patch)
treec2c6a971451e2e686d1273b9ffad1ef8e8550bf3 /recipes/gcc/gcc-configure-common.inc
parent29efbb74780d1de0694d8cdab5527599436119dc (diff)
downloadopenembedded-bea72c2fecde175add169bb55df1922b048030c8.tar.gz
Start removal of layout_* variables and replace these with new mechanisms to allow nextgen SDK generation (from Poky)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'recipes/gcc/gcc-configure-common.inc')
-rw-r--r--recipes/gcc/gcc-configure-common.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/gcc/gcc-configure-common.inc b/recipes/gcc/gcc-configure-common.inc
index a0a7dfab74..efe8ee8787 100644
--- a/recipes/gcc/gcc-configure-common.inc
+++ b/recipes/gcc/gcc-configure-common.inc
@@ -83,12 +83,12 @@ do_configure () {
if [ "${HOST_SYS}" != "${TARGET_SYS}" ]; then
# splice our idea of where the headers live into gcc's world
- echo "NATIVE_SYSTEM_HEADER_DIR = ${layout_includedir}" > ${T}/t-oe
+ echo "NATIVE_SYSTEM_HEADER_DIR = ${target_includedir}" > ${T}/t-oe
sed 's%^tmake_file=.*$%& ${T}/t-oe%' < ${S}/gcc/Makefile.in >${S}/gcc/Makefile.in.new
mv ${S}/gcc/Makefile.in.new ${S}/gcc/Makefile.in
cat ${S}/gcc/defaults.h | grep -v "\#endif.*GCC_DEFAULTS_H" > ${S}/gcc/defaults.h.new
echo "#ifndef STANDARD_INCLUDE_DIR" >> ${S}/gcc/defaults.h.new
- echo "#define STANDARD_INCLUDE_DIR \"${layout_includedir}\"" >> ${S}/gcc/defaults.h.new
+ echo "#define STANDARD_INCLUDE_DIR \"${target_includedir}\"" >> ${S}/gcc/defaults.h.new
echo "#endif" >> ${S}/gcc/defaults.h.new
echo "#endif /* ! GCC_DEFAULTS_H */" >> ${S}/gcc/defaults.h.new
mv ${S}/gcc/defaults.h.new ${S}/gcc/defaults.h