aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuchess
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-18 14:40:24 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-18 15:04:53 +0100
commit780b100bd0c6ae69fa4f9f1fff0768a6b9f494aa (patch)
treeb84376b5fdeec8fbb44f579aa672c8bb16d01e03 /recipes/gnuchess
parent0ca3942e51a1178bd8bfec9c141a0e4c0d85046f (diff)
downloadopenembedded-780b100bd0c6ae69fa4f9f1fff0768a6b9f494aa.tar.gz
gnuchess: add launcher and icon, thanks to Graziano Sorbaioli
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/gnuchess')
-rw-r--r--recipes/gnuchess/files/gnuchess.desktop12
-rw-r--r--recipes/gnuchess/files/gnuchess.pngbin0 -> 2623 bytes
-rw-r--r--recipes/gnuchess/files/gnuchess.sh3
-rw-r--r--recipes/gnuchess/gnuchess_5.021.bb14
4 files changed, 28 insertions, 1 deletions
diff --git a/recipes/gnuchess/files/gnuchess.desktop b/recipes/gnuchess/files/gnuchess.desktop
new file mode 100644
index 0000000000..5b2eb4002d
--- /dev/null
+++ b/recipes/gnuchess/files/gnuchess.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=GNU Chess
+Comment=Chess game of the GNU Project
+Encoding=UTF-8
+Version=4.2.7
+Type=Application
+Exec=/usr/bin/gnuchess.sh
+Terminal=false
+Categories=Game;
+X-MB-SingleInstance=true
+Icon=gnuchess
+
diff --git a/recipes/gnuchess/files/gnuchess.png b/recipes/gnuchess/files/gnuchess.png
new file mode 100644
index 0000000000..a0d2e5fa62
--- /dev/null
+++ b/recipes/gnuchess/files/gnuchess.png
Binary files differ
diff --git a/recipes/gnuchess/files/gnuchess.sh b/recipes/gnuchess/files/gnuchess.sh
new file mode 100644
index 0000000000..2da70498d1
--- /dev/null
+++ b/recipes/gnuchess/files/gnuchess.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+xboard -size Average -font 6x13 -coordFont 6x13 -clockFont 6x13 -fcp "/usr/bin/gnuchess -b- -e 100 -l- -f 1 -p-"
+
diff --git a/recipes/gnuchess/gnuchess_5.021.bb b/recipes/gnuchess/gnuchess_5.021.bb
index 18c94bdab0..8d1afea1bf 100644
--- a/recipes/gnuchess/gnuchess_5.021.bb
+++ b/recipes/gnuchess/gnuchess_5.021.bb
@@ -3,11 +3,23 @@ SECTION = "console"
PRIORITY = "optional"
MAINTAINER = "Andreas Holzer <a.holzer@cheese.at>"
LICENSE = "GPL"
-SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz"
+PR = "r1"
+RSUGGESTS_${PN} = "xboard"
+SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz \
+ file://gnuchess.desktop \
+ file://gnuchess.png \
+ file://gnuchess.sh \
+"
S = "${WORKDIR}/chess-5.02/src"
inherit autotools
do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/pixmaps/
+ install -d ${D}${datadir}/applications/
+ install -m 0755 ${WORKDIR}/gnuchess.sh ${D}${bindir}
+ install -m 0644 ${WORKDIR}/gnuchess.png ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/gnuchess.desktop ${D}${datadir}/applications/
install -D ${S}/gnuchess ${D}${bindir}/gnuchess
}