aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gputty
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gputty
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gputty')
-rw-r--r--recipes/gputty/gputty/conf.patch26
-rw-r--r--recipes/gputty/gputty/gputty4
-rw-r--r--recipes/gputty/gputty_0.9.8.bb27
3 files changed, 57 insertions, 0 deletions
diff --git a/recipes/gputty/gputty/conf.patch b/recipes/gputty/gputty/conf.patch
new file mode 100644
index 0000000000..deb4548092
--- /dev/null
+++ b/recipes/gputty/gputty/conf.patch
@@ -0,0 +1,26 @@
+# Added support to store the configuration in the user home directory
+# Released under the original terms of the package
+# Submitted ustream 12/03/04
+
+--- gputty-0.9.7/src/gputty.c 2004-06-28 06:23:36.000000000 -0700
++++ gputty-0.9.7.new/src/gputty.c 2004-07-12 13:32:41.632259216 -0700
+@@ -424,8 +424,18 @@
+ (void*)gtk_entry_get_text(GTK_ENTRY(g->hn_eusername)));
+ if(g->config == NULL)
+ fprintf(stderr, "%s", "gputty: not saving configuration\n");
+- else if(config_save(g->config, ".gputty") != 0)
++ else {
++ char filename[64];
++
++ if (getenv("HOME"))
++ snprintf(filename, sizeof(filename) - 1,
++ "%s/.gputty\n", getenv("HOME"));
++ else
++ strncpy(filename, ".gputty", sizeof(filename) - 1);
++
++ if(config_save(g->config, filename) != 0)
+ fprintf(stderr, "%s", "gputty: an error occured while saving configuration\n");
++ }
+ gtk_main_quit();
+ }
+
diff --git a/recipes/gputty/gputty/gputty b/recipes/gputty/gputty/gputty
new file mode 100644
index 0000000000..4ba531ecd3
--- /dev/null
+++ b/recipes/gputty/gputty/gputty
@@ -0,0 +1,4 @@
+ssh=ssh
+xterm=x-terminal-emulator
+hostname=
+username=
diff --git a/recipes/gputty/gputty_0.9.8.bb b/recipes/gputty/gputty_0.9.8.bb
new file mode 100644
index 0000000000..5e1ed06357
--- /dev/null
+++ b/recipes/gputty/gputty_0.9.8.bb
@@ -0,0 +1,27 @@
+# OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "GPuTTY is a PuTTY clone using the Gnome environment"
+HOMEPAGE = "http://www.defora.org/index.php?page=gputty"
+LICENSE = "GPL"
+SECTION = "network"
+PR = "r0"
+
+SRC_URI = "http://people.defora.org/~khorben/projects/gputty/gputty-${PV}.tar.gz \
+ file://gputty"
+
+do_compile() {
+ oe_runmake -C src
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ oe_runmake -C src BINDIR="${bindir}" DESTDIR="${D}" install
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${WORKDIR}/gputty ${D}${sysconfdir}/
+}
+
+# Save the configuration file in the package
+FILES_${PN} += " /etc/gputty"
+