aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-03 12:40:22 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-03 12:50:39 +0200
commit8ff7ddf5496d6b605b99dea2f17b65eaeb7f52f3 (patch)
tree005e53a73476ea6b9328ea38e5a8052f5595646d /recipes/gstreamer
parent57fb60fd052a18a58ccd6c2f26e487078c9fc866 (diff)
downloadopenembedded-8ff7ddf5496d6b605b99dea2f17b65eaeb7f52f3.tar.gz
gstreamer : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gstreamer')
-rw-r--r--recipes/gstreamer/gst-plugins-bad/cross-compile.patch44
-rw-r--r--recipes/gstreamer/gstreamer/configure-largefile.patch13
-rw-r--r--recipes/gstreamer/gstreamer/filesrc-uri.patch22
3 files changed, 0 insertions, 79 deletions
diff --git a/recipes/gstreamer/gst-plugins-bad/cross-compile.patch b/recipes/gstreamer/gst-plugins-bad/cross-compile.patch
deleted file mode 100644
index cc4d972f3e..0000000000
--- a/recipes/gstreamer/gst-plugins-bad/cross-compile.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- gst-plugins-bad-0.10.3/configure.ac~cross-compile
-+++ gst-plugins-bad-0.10.3/configure.ac
-@@ -398,35 +398,7 @@
- GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
- HAVE_FAAD="yes"
- GST_CHECK_LIBHEADER(FAAD, faad, faacDecOpen, -lm, faad.h,
-- FAAD_LIBS="-lfaad -lm", HAVE_FAAD="no")
-- if test $HAVE_FAAD = "yes"; then
-- AC_MSG_CHECKING([Checking for FAAD >= 2])
-- AC_TRY_RUN([
--
--#include <faad.h>
--#if !defined(FAAD2_VERSION) || !defined(FAAD_FMT_DOUBLE)
--#error Not faad2
--#else
--#include <string.h>
--
--int main()
--{
--char version[9] = FAAD2_VERSION;
--// a release candidate of 2.0 is not enought for us
--if ( strstr( version, "2.0 RC" ) ) { return 1; }
--
--return 0;
--}
--
--#endif
-- ], [
-- HAVE_FAAD="yes"
-- AC_MSG_RESULT(yes)
-- ], [
-- HAVE_FAAD="no"
-- AC_MSG_RESULT(no)
-- ])
-- fi
-+ FAAD_LIBS="-lfaad -lm")
- AS_SCRUB_INCLUDE(FAAD_CFLAGS)
- AC_SUBST(FAAD_LIBS)
- ])
diff --git a/recipes/gstreamer/gstreamer/configure-largefile.patch b/recipes/gstreamer/gstreamer/configure-largefile.patch
deleted file mode 100644
index 6ea1ef3dba..0000000000
--- a/recipes/gstreamer/gstreamer/configure-largefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.ac~ 2004-06-03 12:37:47.000000000 +0100
-+++ configure.ac 2004-06-04 13:31:02.000000000 +0100
-@@ -172,6 +172,10 @@
- ],
- [
- AC_MSG_RESULT(no)
-+],
-+[
-+ AC_MSG_RESULT(cross-compiling, assumed yes)
-+ GST_PKG_CFLAGS="-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
- ])
-
- dnl check for mmap
diff --git a/recipes/gstreamer/gstreamer/filesrc-uri.patch b/recipes/gstreamer/gstreamer/filesrc-uri.patch
deleted file mode 100644
index 0bde73d970..0000000000
--- a/recipes/gstreamer/gstreamer/filesrc-uri.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: gst/elements/gstfilesrc.c
-===================================================================
-RCS file: /cvs/gstreamer/gstreamer/gst/elements/gstfilesrc.c,v
-retrieving revision 1.108.4.3
-diff -u -r1.108.4.3 gstfilesrc.c
---- gstreamer.orig/gst/elements/gstfilesrc.c 3 Jun 2005 09:29:31 -0000 1.108.4.3
-+++ gstreamer/gst/elements/gstfilesrc.c 12 Aug 2005 11:54:38 -0000
-@@ -306,7 +306,13 @@
- src->filename = NULL;
- src->uri = NULL;
- } else {
-- src->filename = g_strdup (location);
-+ const gchar *file_prefix = "file://";
-+
-+ if (g_str_has_prefix (location, file_prefix)) {
-+ src->filename = g_strdup (location + strlen (file_prefix));
-+ } else {
-+ src->filename = g_strdup (location);
-+ }
- src->uri = gst_uri_construct ("file", src->filename);
- }
- g_object_notify (G_OBJECT (src), "location");